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1 Introduction  
 

The purpose of this document is to give guidelines for use and integration of the                             
following TeraRanger Evo distance sensors:  
 
1. TeraRanger Evo 60m 

2. TeraRanger Evo 40m 

3. TeraRanger Evo 15m 

4. TeraRanger Evo 3m   

with (a) UART/I2C backboard, and/or (b) USB backboard using these standard                     
communication interfaces. Please consult the following table for visual differences                   
between TeraRanger Evo sensors.  
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Product  Visualization   Hardware  

TeraRanger Evo 60m 

 

Black optical sensor module. 

TeraRanger Evo 40m 

 

A blue sticker is applied on the 
sensor. 

TeraRanger Evo 15m 

 

A green sticker is applied on the 
sensor. 



 

​2​ Mechanical integration 
The mechanical design of the main sensor module (black) allows easy assembly to its 
backboard (yellow) using a simple ‘clip-in’ technique. (When you clip the two together, 
ensure there is no visible gap between the black and yellow parts.) The yellow 
backboard has two mounting holes for final installation.  

 

   

When choosing a place for mounting, please consider the following recommendations: 

● Choose a place which is in accordance with the optical constraints listed below 
● Mounting close to sources of heat or strong electromagnetic fields can decrease 

the sensing performance 
● Do not mount anything directly in front of the sensor or in a cone of 

approximately +/-15° around the central optical axis of the sensor 
● Within the first meter from the sensor, avoid objects with high surface reflectivity 

in a cone of approximately +/-45° around the central optical axis of the sensor 
● It is better to avoid having other sources of Continuous Wave or modulated IR 

light close to the sensor 
● Please consider that dust, dirt and condensation can affect the sensor 

performance 
● Do not add an additional cover in front of the sensor 
● Drone rotor blades, or other environments with flickering (‘chopped’) ambient 

light in the field of view can affect sensors’ readings 
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TeraRanger Evo 3m 

 

Sensor’s lens surface is flat, 
unlike Evo 60m, 40m, 15m.  



 

​2.1​ Mechanical design 

 

​2.2​ Sensor handling during system assembly 
During assembly and integration, please observe all common ESD precautions. All 
optical surfaces (sensor front) should be kept clean and free from contact with 
chemicals. 

​3​ USB backboard use 
 

 

 

The USB backboard comes with a standard Micro-USB connector. 
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​3.1​ Graphical User Interface (version 1.0.3) 
A free Graphical User Interface (GUI) is available, providing an easy way to visualize the 
data from your TeraRanger Evo. This is useful for demonstration, testing purposes and 
checking some of the basic parameters of the sensor. It also provides a way to easily 
upgrade the firmware running on the device. 

The GUI is available for download here: ​GUI Download​. (See “Download” section of the 
TeraRanger Evo product page). Please ensure you are using GUI version 1.0.3 or later. 

If you need to identify which TeraRanger Evo sensor is currently connected, in the GUI 
select, ​Help > About​. 

​3.1.1​ Prerequisites 

For usage on Windows 7 and Windows 8, please download the Virtual COM Port driver 
from ​http://www.st.com/en/development-tools/stsw-stm32102.html​ and ​follow the 
​”ReadMe file” instructions given by the installer​​. After successful installation, unplug 
the interface for a few seconds, and plug it back in. The virtual COM port should now be 
available on your PC. 
 
Users of Windows 10 do not need to download this driver as the built in Windows driver 
is recommended.  

​3.1.2​ Basic Operation 

Make sure your TeraRanger Evo is connected to a USB port on your computer. In the 
GUI select File > Connect. You should immediately see a distance reading in millimetres 
and the status should change to ‘Connected’. 
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​3.1.3​ Firmware Upgrade 

The current firmware version on your TeraRanger Evo can be found by selecting ​Help > 
About​ in the graphical user interface. It is possible to upgrade the firmware running on 
your device if a new firmware version is made available on the Terabee website. 

Please note the Upgrade Firmware feature is only supported on Windows 7, 8 and 10. 
Please carefully follow the steps outlined below to avoid permanently disabling your 
device. 

● Install the latest version of the TeraRanger Evo GUI on your computer  
● Download the latest firmware file from the Terabee website 
● In the GUI Select ​File > Connect​ and then ​File > Upgrade​ ​Firmware 
● You will be presented with a dialog window asking you to confirm your choice 
● After confirming your choice, a new dialog window will present you with 

instructions on selecting the firmware file and launching the upgrade process, 
read the instructions carefully. 

● Press ​‘Select File’​ and select the new firmware file with Windows File Explorer 
● Press ​‘Upgrade’​ and wait until the operation finishes 
● Close the Upgrade dialog box 
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​3.2​ Connecting the TeraRanger Evo to a Host Computer 
TeraRanger Evo can interact as a virtual COM port using the following configuration: 
115200 bit/s, 8 data bits, no parity bit and one stop bit. 

In Windows you can also use any terminal emulation software of your choosing, 
however we suggest you use HTerm (​http://www.der-hammer.info/terminal/​). Extract 
the downloaded zip file to the folder of your choice, open it and double click on the 
“HTerm.exe” document. 

Connect the TeraRanger Evo to your computer and select the corresponding USB port 
(click “R” button to refresh the port list). Select values for the following fields: (1) 
Baudrate, (2) Data Bits, (3) Parity, (4) Stop Bits. For easier readings, select the “LF” option 
for “Newline at” tab. See Figure below for visual instructions. 

 

Once you have selected the USB port and required values, click on the “Connect” button. 
The data will now appear in the “Received data” box (Figure below). 
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To communicate with the terminal emulation software, you need to send a command in 
hexadecimal via the “Type” box. First check the “Hex” checkbox and choose the “HEX” 
Type. The figure above shows an example of the command which allows data to be 
shown in TEXT mode. 

​4​ I2C/UART backboard use 

 

​4.2​ I2C/UART interface 
The TeraRanger Evo can be controlled through I2C ​or​ UART interfaces. It uses a single 9 
pin Hirose DF13 connector for interfacing to the host system. The mating connector is a 
Hirose DF13-9S-1.25C with crimping contacts DF13-2630SCF (tin) or DF13-2630SCFA 
(gold). Please consider the mechanical stability of the mated connectors and avoid any 
kind of excess force on the connector (during installation and once integrated) and 
follow the recommendations in the Hirose DF13 series datasheet (available here: 
https://www.hirose.com/product/en/products/DF13​) to ensure a reliable connection. 

The table below provides an overview of the pin out of the DF13 connector: 

Pin out and description (According to DF13 datasheet) 
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Pin  Designator  Description 

1  Tx  UART transmit output. 3.3V logic 

2  Rx  UART receive input. 3.3V logic 

3  GND  Power supply and interface ground 

4  SDA  I2C serial data line. 3.3V logic 

https://www.hirose.com/product/en/products/DF13


 

 

​4.2.1​ Backboard LEDs 

Five LEDs are mounted to give visual feedback on the sensor. Table 2 lists the 
functionality of each LED: 

 

 

​4.2.2​ Electrical characteristics 

DC electrical characteristics  
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5  SCL  I2C serial clock line. 3.3V logic 

6  rfu  RESERVED FOR FUTURE USE 

7  5V  +5V supply input 

8  GND  Power supply and interface ground 

9  rfu  RESERVED FOR FUTURE USE 

LED  Description 

PWR (orange)  Power indicator, on when 5V connected 

Rx/Tx (red/green)  UART receive and transmit indicators 

LED 0 / LED 1  For internal use only 

Parameter  Sensor  Minimum  Maximum 

Power supply  

Voltage input (V) 

Current 

Evo 60m   

4.75 V 

 

5.25 V 
Evo 40m 



 

 

* Value recorded while reading a target at 2m distance. NB: this value depends on 
ambient conditions, distance and target reflectivity 

​4.3​ I2C protocol information 
The communication parameters are: 

Frequency​: 400kHz 

Primary Address Length​: 7-bit 

Primary Slave Address​: 0x31 

Built-in pull-up resistors:​ 10 kOhms on SDA and SCL (avoid additional pull-up 
resistors on the same bus to prevent transmission problems) 

The TeraRanger Evo is ‘free running’. This means that it will restart a new measurement 
as soon as the last one is finished. The displayed data via I2C protocol is always updated 
at the end of a measurement. Nevertheless, it can always be read at any time. 

Reading the distance is done by first writing a Trigger Reading command to the sensor - 
send 0x62 (this is the 7 bit address 0x31 followed by the write bit ‘0’) and then reading 
from the sensor by sending 0x63 (the base address with the Read bit ‘1’) followed by 
three byte read operations. The first two bytes you receive are a 16 bit word containing 
the latest measurement in mm**, the third byte is the CRC8 checksum. 
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consumption (mA)  Evo 15m  90 mA  330 mA 

Evo 3m  4.75 V 
70 mA 

5.25 V 
250 mA 

Interface logic 
levels 

(referenced to 
+3V3) 

LOW 

HIGH 

   

 

- 

2.3 

 

 

1 

- 



 

**The TeraRanger Evo will output 01CRC (first distance byte set to zero and the second 
to one) as an error message ​if the sensor is unable to measure a distance​. ​If the 
target is too close​ (below the minimum distance), the TeraRanger Evo will output 
00CRC  (both distance bytes set to zero). ​If the target is too far away​ (above the 
maximum distance), the TeraRanger Evo will output  XXCRC with XX = FFFFhex (both 
distance bytes set to 0xFF) 

Writing commands to the TeraRanger Evo: 

1. Send the address byte consisting of a 7 bit base address and the last bit 
indicating write (‘0’), e.g. 0x62 for base address 0x31. All commands listed in the 
table below are ‘write operations’. The answer will be in the next read operation 
for which you have to send the 7 bit address with the read bit set 

2. Send the desired command listed in the table below (see table below in the next 
paragraph) 

3. In case the command creates an answer, read it back immediately 

Reading data from the TeraRanger Evo: 

1. Send the address byte consisting of 7 bit base address and the last bit indicating 
read (‘1’), e.g. 0x63 for base address 0x31 

2. Read back the the number of bytes imposed by the command, e.g. three bytes 
for a distance reading 

​4.3.1​ I2C commands 
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Command  Name  Description 

0x00  TRIGGER READING  Write this command to the TeraRanger 
Evo and after a wait of approximately 
500us read the 3 byte distance 
response 

0x01  WHO_AM_I  Write this value to TeraRanger Evo via 
I2C and the device responds with 0xA1 

0xA2  CHANGE_BASE_ADDR​[1]  Write this value followed by the new 
address to set ​[2]​, eg. send 0x42 if you 
want the Evo’s base address to change 
to 0x42, ignore Read/Write bits.  



 

 

1] ​This command assigns a base address that will be memorised by the TerRanger Evo ie. power cycling the Evo will not 
restore the default I2C address. 

  
[2] ​Valid addresses accepted by the TeraRanger Evo are in the range 0x02 to 0x7F. Assignment of addresses within a local 
system is up to the system architect. For example, the I2C standard defines reserved addresses but if it is known that the 
reserved address is never going to be used for its intended purpose, a reserved address can be used as the Evo I2C Base 
Address. 

​4.4​ UART Communication 

​4.4.1​ UART protocol information  

The UART communication for the TeraRanger Evo uses a simple Modbus-like protocol. 
The communication parameters are: 
 

Baud Rate​: 115 200 

Data Bits​: 8 

Stop Bit(s)​: 1 

Parity​: None 
HW Flow Control​: None 

​4.4.2​ Commands 
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Wait at least 1 second for the 
TeraRanger Evo to rejoin the I2C bus 
with the new address. 

Address  Command  Data  CRC-8 

0x00  PRINTOUT MODE 
0x11 

TEXT 

0x01 

0x45 



 

 
 
The default mode of TeraRanger Evo is Binary mode. For changing the output format to 
Text mode, please use the following command in hexadecimal: ​00 11 01 45​.​ ​Accordingly, 
to switch back to Binary mode use the hexadecimal command: ​00 11 02 4C​. 

​4.4.3​ UART output format 

Two output formats are available: 
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0x00  PRINTOUT MODE 
0x11 

BINARY 

0x02 

0x4C 

Text 
output 

Data output in human readable form (5 to 7 bytes message):  

xxxxx\n 

- Distance reading in millimeters* (maximum 5 bytes per sensor):                 
xxxxx 

- New line character: \n (10 decimal / 0x0A hex) 

*please be aware that there is no zero-padding for leading zeros!  

- If the TeraRanger Evo is unable to measure a distance, it will                       
output -1\n as an error message 

- If the target is too close (below the minimum distance), the                     
TeraRanger Evo will output -Inf\n 

- If the target is too far away (above the maximum distance), the                       
TeraRanger Evo will output +Inf\n 

Binary 
output 

Data output (4 bytes message): 

TXXCRC8 

- Header (1 byte): T (84 decimal / 0x54 hex) 
- Distance reading in millimeters** (2 bytes): XX 
- Checksum (1 byte) of previous 3 bytes: CRC8 

**The TeraRanger Evo will output T01CRC (first distance byte set to zero                       
and the second to one) as an error message if the sensor is unable to                             
measure a distance: 

- If the target is too close (below the minimum distance), the                     
TeraRanger Evo will output T00CRC (both distance bytes set to                   
zero) 
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- If the target is too far away (above the maximum distance), the                       
TeraRanger Evo will output TXXCRC with XX = FFFFhex (both                   
distance bytes set to 0xFF) 



 

​5​ Declaration of Conformity 
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CE certified, eye-safe and RoHS compliant 
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