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© 2021 LeddarTech Inc. All rights reserved. 

The information contained herein is the property of the Company and shall not be reproduced in whole or in 
part without the prior written approval of the Company. 

Leddar, LeddarTech, LeddarSteer, LeddarEngine, LeddarVision, LeddarSP, LeddarCore, VAYADrive, 
VayaVision, and related logos are trademarks or registered trademarks of LeddarTech Inc. All other brands, 
product names, and marks are or may be trademarks or registered trademarks used to identify products or 
services of their respective owners. 

Please contact a LeddarTech sales representative if you have any questions regarding the information 
contained in this document or regarding LeddarTech products. For the most recent version of this document, 
visit LeddarTech’s website. We also highly recommend that you read our Standard Sales Terms and 
Conditions, Product Warranty, and End-User License Agreement carefully. Documentation available at 
www.leddartech.com, section “Resources.” 

Leddar™ Configurator software: this software is based in part on the work of the Independent JPEG Group. 

Keep this User Guide for future reference. 
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DISCLAIMER 

LeddarTech® shall not be liable for any errors or omissions herein or for any damages arising out of or related 
to this document or the information contained herein, even if LeddarTech has been advised of the possibility 
of such damages. 

Descriptions of products, including, but not limited to, specifications and drawings, and other related 
information contained in this document, are provided only to illustrate their operation and application 
examples. The illustrations shown, including screen captures, may differ from the appearance of the actual 
product. 

LeddarTech has made every effort to ensure that the information contained in the documentation 
accompanying its products, including, without limitation, its Specification Sheet, is accurate. However, 
LeddarTech will not be liable for any errors or omissions therein and reserves the right to modify the design 
and characteristics of products at any time without notice. For the most recent version of any product 
documentation, visit LeddarTech’s website at www.leddartech.com. In case of discrepancy, the web version 
takes precedence over any printed literature. 

LeddarTech may expressly designate certain products as completing a particular qualification (e.g., AEC-
Q100). Customer agrees that it has the necessary expertise to select the product with the appropriate 
qualification designation for its applications and that proper product selection is at customer’s own risk. The 
customer is solely responsible for compliance with all legal and regulatory requirements in connection with 
such selection. 

LeddarTech does not control the installation and use of its products and shall have no liability if a product is 
used for an application for which it is not suited. LeddarTech’s products are not recommended or authorized 
for safety, life support, medical applications, applications involving hazardous, corrosive, or radioactive 
substances, or for any use or application in which the failure of a component could cause personal injury, 
loss of life, or substantial harm to the environment or property. Where LeddarTech specifically promotes 
products as facilitating functional safety or as compliant with functional safety standards, such products are 
intended to help enable customers to design and create their own applications that meet applicable functional 
safety standards and requirements. Using products in an application does not by itself establish any safety 
features in the application. 

Any technical advice provided by LeddarTech with reference to the use of its products is given without 
assumption by LeddarTech of any liability, and LeddarTech assumes no obligation or liability for the advice 
given or results obtained, all such advice being given and accepted at customer’s sole risk. 

LeddarTech reserves the right to modify its products at any time, without notice, at its sole discretion. The 
products’ performance specifications and operating parameters are determined in an independent state and 
are not guaranteed to perform the same way if installed in a customer product. 

  

http://www.leddartech.com/
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Document Conventions 

This document uses the following conventions: 

Name of menu > 
name of the window 

Shows the access path to menus under each section of Leddar™ Configurator. 

Arial bold 
The names of buttons, menus, dialog boxes, icons, and elements of the interface 
are in bold type. 

 

Note: Contains helpful suggestions and references to information included within 
this User Guide. 

 

Warning: Refers to a warning or important information to follow. 

This document uses the metric system (SI). 
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1. Label Explanation and Safety Information 

1.1. Labels 

Table 1: Explanation of labels on the sensor 

Label Location Description 

 

Back of sensor 

Eye safety hazard 

Class 1 laser product as defined by the IEC 
60825-1 standard 

 

Bottom of sensor 
Tamper-proof “Warranty Void” sticker applied to 
the sensor 

 

Back of sensor 

Model number (MOD) 

Serial number (SN) 

Manufacturing date (MFD) 

Country of assembly 

LeddarTech website address 

1.2. Regulatory Compliance 

Table 2: Regulatory compliance information 

Compliance Feature Description 

EMC/EMI 

Complies with electromagnetic compatibility requirements as defined by IEC 
61000-6-2:2016 (Immunity Standard for Industrial Environments) and IEC 
61000-6-3 A1:2010 (Emission Standard for Residential, Commercial, and Light 
Industrial Environments). 

ICES-003 
Class A digital apparatus. Complies with the Canadian Interference-Causing 
Equipment Standard ICES-003. 

Water ingress IP67 index as defined by IEC 60529:2013 

Dust ingress 
Complies with Environmental Practices for Electronic Equipment Design in 
Heavy-Duty Vehicle Applications standard SAE J1455:2017. 

Ocular safety 
Complies with Class 1 laser product requirements as defined by IEC 60825-1 
and FDA performance standards for laser products US 21CR1040. 

CE Compliant 

RoHS Complies with EU RoHS Directive 2011/65/EU amended 2015/863. 

Shock 
Complies with environmental testing / mechanical shock (endurance and 
collision) requirements for road vehicles standard ISO 16750-3:2003 as 
defined by IEC 60068-2-27:2008. 

Vibration 
Complies with environmental testing / sinusoidal vibration requirements for 
road vehicles standard ISO 16750-3:2003 as defined by IEC 60068-2-64:2008. 
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2. Definitions 

Table 3: Definitions 

Term Definition 

3D flash 

3D flash is a type of LiDAR technology used by LeddarTech to provide detections in a 
3D environment. The first two dimensions are the relative positions of the segments 
in the frame (row/line and column). The third dimension is the distance of the 
detection(s). 

LeddarTech’s LiDAR technology creates optimal illumination of the field of view of a 
target, which is then captured in segments by the sensor detector arrays. See section 
3.1 on page 22 for more details. 

Amplitude 

The amplitude is expressed in counts and represents the quantity of light reflected 
and captured by the sensor. This measure defines the strength of the digital signal. 

 

Fig. 1: Saturation 

Saturation occurs when an object is very close to the LiDAR or has a high reflec-
tance. The power of the received signal can be very high and saturates the analog-to-
digital converter. 

Channel Synonym of “segment.” See the definition of the word “segment.” 

Crosstalk 

The phenomenon by which an optical or electrical signal transmitted in one channel 
creates an undesired effect in an adjacent channel. See section 0 on page 18 for 
more details. 

 

Fig. 2: Optical crosstalk 
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Term Definition 

 

Fig. 3: Electrical crosstalk 

Detection 
A detection, also called “echo,” is defined by distance, amplitude, channel index, 
timestamp, and flag. 

Distance 
Distance to an object measured in the segment (in meters) from the reference point. 
Range: 0 to Instrumented Range. 

Flag Information relative to detection quality (bit field). 

FoV Field of view 

GPS 
In autonomous navigation systems, the GPS provides a clock signal that can be used 
to synchronize various systems. 

LCA LeddarCore Automotive product family 

NIR Near-infrared light 

Object 
Objects, people, or animals (moving or stationary). Throughout this document, all 
these elements will be referred to as “objects.” 

Parasite ripple A ripple that occurs following a strong detection. 

PPS 
Pulses per second. Signal used as a time reference by the central system to 
synchronize multiple sensors together with the GPS to increase the accuracy of 
perception. 

PTP Precision Time Protocol. Used to synchronize clocks throughout a computer network. 

Segment A vertical (V) and horizontal (H) index in the FoV. Synonym of “channel.” 

SoC System on chip 

Timestamp 
(32 bits) 

Time, in milliseconds (ms), elapsed since the sensor was powered on. Range: 0 to 
232 – 1. It will restart at 0 within 49 days of continuous operation. 

Timestamp 
(64 bits) 

Time elapsed since 00:00:00 UTC on January 1, 1970 (also called UNIX Time). 
Expressed in milliseconds (ms) by default but can be configured to be expressed in 
microseconds (µs) for more precision. Range: 0 to 264 – 1. 

Optical and Electrical Crosstalk 

In autonomous driving scenarios, a multitude of variable reflective objects may be present and will affect the 
performance levels of the LiDAR system. Highly reflective objects may cause detrimental effects in the 
detection system due to optical reflections or artefacts in the electronics. The next few paragraphs explain 
some of these issues and the LeddarSP’s capacity to overcome them. 

https://en.wikipedia.org/wiki/Clock_synchronization


 

54A0049_7.0_EN / Leddar Pixell – User Guide 19 | 127 

2.1. Optical Crosstalk 

Lens flare, diffusion, and reflections may cause undesired signals, which are commonly referred to as optical 
crosstalk. To resolve this issue, LeddarSP uses a method that is based on a deconvolution process to 
reverse these effects. 

The platform approach has been adopted in LeddarSP, and two chosen methods have been carefully 
implemented. 

The first method is based on pulse deconvolution; it has the advantage of requiring a very short computation 
time, which optimizes the addressable pixel per second. The second method is based on trace deconvolution 
and requires more computing time. 

Both methods’ performance improvement on false detections is limited by calibration imperfections. 

2.2. Electronic Crosstalk 

Additionally, LeddarSP corrects photodetector and electronic imperfections in the detection. When a light 
pulse is received on a photodetector channel, artefacts are created in the electric signal that is generated by 
the adjacent photodetectors, which is commonly known as electronic crosstalk (“xtalk”). 

The shape and amplitude of the electronic crosstalk depend mainly on the sensor’s characteristics. 

The amplitude of an electronic crosstalk signal is about 40 dB below the aggressor amplitude for the pixels 
just next to the aggressor, decreasing gradually to reach about 60 dB from 4 pixels from the aggressor. 

Both optical and electronic crosstalks are mitigated by calibration measurements in specially designed 
manufacturing set-ups. 

The Leddar Pixell embeds LeddarEngine algorithms designed to mitigate electronic crosstalk and minimize 
the probability of spurious detections, providing an improvement of more than 16 dB on amplitude 
measurements. 

The exact performance of LeddarSP algorithms varies from unit to unit and with the scene view by the LiDAR. 
The reflectivity, size, and distance of objects to the LiDAR and object proximity to other objects impact the 
ability of the global LeddarSP algorithms to mitigate electronic crosstalk. 

Therefore, with extremely strong aggressors, it is still possible to have a significant residual after a correction. 
This may lead to unwanted detections (i.e., false positives) or missed detections (i.e., false negatives). 
However, the detections in an area that have been corrected are flagged (see Table 27 on page 79); they 
must, therefore, be used with more caution. 

The corrected area, where false positives and false negatives can occur, extends over 17 meters around the 
aggressor at most. The start and the end of a correction depends on the context; the start can be up to 
7.7 meters before the aggressor, whereas the end can be up to 14.4 meters after the aggressor. 

2.3. False Positives and False Negatives Around Reflective Events 

Both modes of crosstalk inject pulse-like signals on the same photodiode array and contaminate a good 
number of lateral segments. Special algorithms are used to remove false positives on the same line and both 
sides around the strong reflector. Depending on the intensity of the reflective event, the capacity of detection 
on the horizontal line is limited up to 7 meters behind the reflector. 
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Fig. 4: Residual crosstalk effects around a strong reflector 

False positives identified as related to crosstalk are removed in zone B to D. At a greater distance, the 
detection range is partially reduced in zone E. In zone B to D, false negatives are expected, and their 
numbers will vary depending on the strength of the main reflector. In general, detection will improve away 
from strong reflector both laterally and vertically some segments away and in the distance. LeddarTech 
recommends implementing a lower responsiveness zone D (Fig. 4 above) from the distance of a flagged 
aggressor (Flags Sat = 3 and Xtalk = 6) extending up to a maximum of 3.5 meters ahead and 7 meters 
behind reflector in distance. This zone externs laterally for all segments within one of the sub-fields of view 
(Fig. 9), where the strong reflector is present. Inside this lower responsiveness zone, low-reflectivity targets 
may not always be detected while the saturation condition is present. This evaluation must be done 
separately for each of the eight lines. 

Table 4: Distance around strong reflectors to consider for the zone 

Amplitude Zone Affected Area D (Fig. 4) 

Zones I and II ≈ 1.5 m around aggressor 

Zone III ≈ 3.5 m 

Zones IV and V +7 m / -3.5 m 

• A: Worst crosstalk effects for extremely high reflector: False positives +/- 1 segment H+V
• B: Removal of false positives generated by crosstalk, very limited detection capability, 

possible false negatives with improvement away from affected segment both in distance, 
vertically and laterally

• C: Removal of false positives up to end detectors for the head seeing the reflector,  limited 
detection capability, possible false negatives

• D: Limited detection capability of low reflectivity target, False negatives possible from 
distance of reflector  7m behind To 3.5m before with improvement away from affected 
segment both in distance and laterally.

• E: Higher detection threshold zone with reduced range
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Fig. 5: Detection count vs. distance 

  



 

22 | 127 © 2021 LeddarTech Inc. 

3. Introduction 

3.1. Underlying Principles and LiDAR Fundamentals 

Created by LeddarTech, Leddar™ is a unique sensing technology based on laser illumination (infrared 
spectrum) and the principle of a light’s time of flight. The laser emitters illuminate the area of interest. The 
multichannel sensor receiver collects the back-scattered light and measures the time taken for the light to 
return to the sensor. 

A photodetector array is used and provides multiple detection and ranging segments. The full-waveform 
analysis enables the detection and distance measurement of multiple objects in each segment, as illustrated 
in Fig. 6, provided that foreground objects do not fully obscure objects behind them. 

 

Fig. 6: Time of flight 

3.2. Key Factors for Best Sensor Performance 

To obtain the best operating performance, the following factors are important to consider. 

Table 5: Key factors for best sensor performance 

Key Factor Description 

Size of the target 
The larger the target, the longer the range. 

The smaller the target, the shorter the range. 

Reflectivity of the target 
The range increases with the target’s reflectivity at the emission 
wavelength. 

Position of the target 
within the FoV 

With centered segments, the range is higher. 

With outer segments, the range is lower. 

Weather conditions 
Inclement weather conditions such as rain, fog, snow, and dust may 
affect sensor performance. 

Direct sunlight 
Exposing the sensor to direct sunlight may affect performance levels of 
the illuminated portion of the FoV, which may be caused by direct 
sunlight. 
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3.3. Accuracy and Precision Based on Radar Equation 

The LIDAR operates using the same detection fundamentals as conventional radars; the precision of the 
distance measurement depends on how strong the receiving signal is. A stronger signal will lead to a better 
noise ratio at the peak detector, which is directly linked to the precision of the detection. The Leddar Pixell 
follows a typical radar equation that links the precision with the amplitude counts of the detection. The Leddar 
Pixell’s specification of 0.6 cm is defined at amplitude counts greater than 60 counts. Fig. 7 shows the model 
equation of precision, which has been taken with multiple target types. 

 

Fig. 7: Precision at low-amplitude counts 
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Fig. 8: Accuracy at very low-amplitude counts 

Accuracy is defined as the average distance if several measurements are repeated. The accuracy 
specification is defined for the detection regime selected by design: SNR 9.8 dB, >90% probability of 
detection, and 0.0001 false alarm rate. For very low counts, the detection distance stays within the precision 
specification; however, the accuracy is lower because the probability of detection falls below 90%, and the 
peak detector has a more random behavior. 
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4. Intended Use and Description 

This User Guide is intended for developers and integrators. This document provides information about the 
Leddar Pixell 3D flash LiDAR sensor (hereafter referred to as “the sensor” or “Leddar Pixell”). 3D flash 
technology provides detections in a 3D environment. 

Using the latest 3D flash LiDAR technology, the Pixell provides more scene coverage than most scanning 
LiDARs, which drastically reduces dead zones. Thanks to the Pixell’ s wide horizontal FoV, four sensors will 
cover the entire vehicle surroundings and provide redundancy coverage in its corners. Data provided by 
Leddar Pixell allow for object tracking and identification of possible collisions based on object position, 
velocity, and directionality, without overwhelming the vehicle’s CPU with massive amounts of unnecessary 
data. 

The Pixell has been designed using the state-of-the-art LeddarEngine™, the powerful LiDAR core for 
automotive and mobility applications, leveraging LeddarTech’s patented signal acquisition and processing 
and highly integrated SoC. 

Leddar Pixell 3D flash LiDAR sensors are used to detect the presence of objects, people, and animals 
(whether moving or stationary). Throughout this document, all these elements will be referred to as “objects.” 

The goal of this document is to help you use your sensor and Leddar Configurator so that you can achieve 
the best of their capabilities. 

4.1. Equipment Description 

Model Leddar™ Pixell 

Generation Production unit 

The Leddar Pixell sensor comes with the following software: 

• Leddar Configurator 

• Software Development Kit (SDK) 

Fig. 9, Fig. 10, and Fig. 11 below show the sensor’s main components. 
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Fig. 9: Right, center, and left submodules 

 

Fig. 10: Front view 

Submodule 1 (right*) 
* As seen from rear 

of sensor 

Horizontal 
segment 96 

Submodule 2 
(center) 

Submodule 3 
(left) 

Horizontal 
segment 1 

Heatsink 

Receiver 
windows (3 x) 

Emitter 
windows (3 x) 

Mounting 
threads 
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Fig. 11: Rear view 

4.2. Reference Point and Coordinates 

The distance is measured from the reference point (point zero). 

For the left-right orientation, the reference point is located 123 mm from the sides, as seen in Fig. 12 below. 

 

Fig. 12: Reference point (top view) 
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For the top-bottom orientation, the reference point is located 1 mm above the center of the mounting hole 
and, from there, at 7 mm inwards of the sensor, as seen in Fig. 13 below. 

 

Fig. 13: Reference point (right side view) 

See Appendix E on page 123 for information on converting the Leddar Pixell flash LiDAR sensor’s angular 
data and distance reporting. 

4.3. Emission Concept 

This section provides information about the emission concept of the Leddar Pixell. The figures below show 
the representation of the horizontal FoV and the zones covered by the sensor. 

 

Fig. 14: Representation of the FoV resolution and segment zones 

32-segment zone 

32-segment zone 

32-segment zone 

1 96 
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Leddar Pixell offers minimal dead zones, as seen in Fig. 15 below. This hardware configuration reduces the 
possibility of missing an object, as there is only a 6-cm width between the sensor windows. The width 
progressively reduces to completely disappear after 1 m. 

 

Fig. 15: Emission minimal dead zone 

Depending on the distance, the overlap in the horizontal FoV varies from no overlap to up to 2 segments at 
long distance. This is valid for each side. 

 

Dead-zone distance 
1 m (typical) 
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Fig. 16: Horizontal overlap at 7 m and <1 m 

 

Fig. 17: Vertical emission coverage at a short distance 

The Leddar Pixell uses a bi-static optical design. The spacing between the transmitter window and the 
receiver window (Fig. 18) creates a variable vertical overlap at close range, as shown in Fig. 17. The receiver 
has a single wide FoV depicted in orange in Fig. 17. The emitting section consists of 8 laser lines covering 
the entire horizontal FoV; however, each line scans a portion of the vertical FoV. At a very close range, only 
the top-emitting segments overlap with the receiving FoV. 
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Table 6: Usable segments vs. distance at close range 

Distance Usable Segments 

25 cm 0-383 (4 lines out of 8) 

50 cm 0-575 (6 lines out of 8) 

100 cm 0-767 (complete FoV) 

 

Fig. 18: Distance between two zones 

The Leddar Pixell is a fusion of three laser heads; each covers approximately 60° for a total of 180°. The 
field width and the central angular position of each head can be read from the sensor. The positive central 
angle can be found in the left quadrant. Zero is at the center. The negative central angle can be found in the 
right quadrant. 

 

Fig. 19: Sub-FoVs, as reported 

RX-TX 
separation 
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The segments overlap to minimize the dead zone between each sub-FoV, as seen in Fig. 20 below. 

 

Fig. 20: Emission profile overlapping the FoV 

4.3.1. Illumination Pattern 

LeddarTech flash technology illuminates a wider area than other LiDAR technologies. The result is a minimal 
gap between vertical lines that typically measures around 0.7°. Fig. 21 illustrates the distance in degrees 
between two segment centers. 

 

Fig. 21: Vertical FoV illumination pattern 
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4.3.2. Impact of Range in Vertical Gap 

Because the gap between the laser lines expands in propagation with distance, there is a complex interaction 
for a particular size target and reflectivity and the maximum range up to where this target is detectable. Fig. 
22 below shows how the amplitude of the return signal is affected for this target if aligned to the center or 
between two vertical lines. Loss of 50% of the normal range for this example is measured with a 50 cm x 
50 cm target (50% reflectivity) if it falls totally in the vertical gap. 

 

Fig. 22: Range reduction in a vertical gap 

4.3.3. Channel Index 

The channel index starts from 0 at the top left of the FoV and increases from left to right and from the top 
line to the bottom of the FoV, as shown in Table 7 on page 34. You can set the horizontal and vertical indexes 
in the Raw Detections window. See section 10.6.3 on page 78 for more details. 

A channel (or segment) can be identified either by: 

• its channel index, or 

• its coordinates within the FoV (V Channel, H Channel) in the viewer software (Leddar Configurator). 
See section 10 on page 56 for more details on Leddar Configurator. 

 

Fig. 23: Channel indexes and measurement 
pop-up box in Leddar Configurator 



 

34 | 127 © 2021 LeddarTech Inc. 

Table 7: Channel indexes 

 H Segment 1 H Segment 2 … H Segment 95 H Segment 96 

V Segment 1 0 1 … 94 95 

V Segment 2 96 97 … 190 191 

V Segment 3 192 193 … 286 287 

V Segment 4 288 289 … 382 383 

V Segment 5 384 385 … 478 479 

V Segment 6 480 481 … 574 575 

V Segment 7 576 577 … 670 671 

V Segment 8 672 673 … 766 767 

 

Fig. 14 on page 28 presents a top view of the sensor that shows that each segment zone comprises 
32 segments, where the horizontal segment number 1 is located on the left and the horizontal segment 
number 96. 

The channels, also called “segments,” are identified by their coordinates within the FoV [V Segment, 
H Segment] from left to right and top to bottom. 

4.3.4. Channel Azimuth and Elevation Angles 

As seen in Table 7, each FoV segment is mapped to a unique index. To ensure optimal measurement 
accuracy, the channel angles, in terms of azimuth and elevation, are precisely measured for each segment 
after manufacturing. The reference used for these measurements is the point of maximum amplitude of the 
reflected light pulses, which corresponds to the center of the segment. The measurements are saved in each 
sensor in the form of two mapping tables: one for azimuth angles and the other for elevation angles. Each 
table is a one-dimensional array indexed from 0 to 767. 

It is important to note that due to variability in manufacturing, the precise angles stored in the mapping tables 
might differ from one sensor unit to the other. Therefore, for maximum precision, it is preferable to fetch the 
angular mappings from each sensor independently. 

To fetch those tables from the sensor, get the LT_COMM_ID_AUTO_CHANNEL_ANGLES_AZIMUT 
(0x2580) and LT_COMM_ID_AUTO_CHANNEL_ANGLES_ELEVATION (0x2581) configuration elements 
from the sensor’s configuration using the CFG_REQUEST_GET_CALIB (0x7002) command. 

See Table 48 on page 112 for more information. 

  

Total horizontal FoV 
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4.4. Sensor Alert System 

4.4.1. Overview 

The Leddar Pixell uses an alert system to notify you of potential problems and misuse of the sensor, along 
with other information about its status. 

The alert system is accessible through both the Leddar Configurator software and the communication 
protocol. 

An alert is defined by: 

• an alert type 

• an alert level 

• a unique identifier code 

There are three (3) alert levels: 

Notify: This is generic system information that can be useful to you but is not problematic regarding 
operations or performance. No action is required from you. 

Warning: The sensor is in a problematic condition that requires your attention and might require action. The 
sensor operation will continue, but performance might be degraded depending on the warning code. See 
Table 8 below. 

Critical: The sensor has suffered a critical error and might have stopped operating altogether to protect itself 
or its surroundings (Fig. 26 on page 38). Any measurement output from the sensor in this state should not 
be trusted. Your immediate attention is required. 

4.4.2. Alert Type List 

 
The current alert list is minimal and is mainly used for reporting the sensor’s operating state. 

Table 8: Detection structure (sends echoes) 

Alert Type Type ID Alert Level Description 

ALERT_LCA_INIT 0x00 Notify 
The sensor has not finished initialization after 
powering up. This notification disappears after a 
few seconds. 

ALERT_LCA_CONFIG 0x02 Notify 
The sensor is currently in Self-configuration mode 
and has paused its measurement process. This 
notification disappears after a few seconds. 

ALERT_LCA_ERROR 0x06 Warning 

The sensor is currently in Safe mode following an 
error in the measurement process. 

The unit needs to be power cycled to 
recover from Safe mode. See section 4.5 
on page 37 for more details. 
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4.4.3. Access to Leddar Configurator 

In the Leddar Configurator software, current active alerts can be found in View > State, next to Sensor 
status: at the bottom of the window. 

 

Fig. 24: Sensor status in Leddar Configurator 

If the status is OK, there are no currently active alerts and the sensor is currently in normal operation mode. 

If the status is Notify, Warning, or Critical, one or more alerts are currently active. The number is displayed 
before the status name. Hovering the cursor over the relevant word in color will display the alert information 
in a tooltip. 

 

Fig. 25: Warning code example in the Device State window 
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4.4.4. Access to the Communication Protocol 

The communication protocol allows you to fetch the currently active alerts from the sensor. To do so, the 
CFG_REQUEST_UPDATE request (code 0x0008, see section “Configuration Server Requests” in Appendix 
D “Communication Protocol”) must be made to the configuration server. See Table 43 on page 110 for the 
definition of the alert structure. 

4.5. Sensor Operation Overview 

The sensor firmware operates following an internal state machine. This section outlines the cycle of operation 
of this state machine. 

There are three (3) main states in the sensor: Initialization, Normal Acquisition, and Safe modes. 

Initialization mode: The system boots into this state when powered on. The system loads the sensor 
configuration and calibration from non-volatile memory. It checks whether the loaded data is coherent. It 
performs initial self-tests to detect faults, which lead to Safe mode. If the initialization is successful, the sensor 
transitions to Normal Acquisition mode automatically. 

Normal Acquisition mode: This is the sensor’s main measurement acquisition and transmission mode. 
Lasers are flashing. Pulses are treated through signal processing algorithms and transmitted through the 
Ethernet communication port. Self-checks are embedded in the process to detect faults, which lead to Safe 
mode. If no faults are detected, the sensor remains in this mode until power is turned off. 

Safe mode: The sensor has detected a critical fault that can result in damage to itself, its host, or any 
surrounding material or people. The conditions for the sensor to switch to Safe mode are as follows: 

• Voltage at the capacitor banks too high 

• Pulse repetition rate too high 

• Critical supply for eye-safety hardware protection out of range 

• General voltages out of range 

• Lasers too hot 

• CPU too hot 

• Power distribution electronics too hot 

 

When in Safe mode, the lasers are NOT flashing, the acquisition loop has stopped, and the 
sensor is not outputting any detections. Power consumption is reduced to a minimum. The 
Ethernet link is kept alive to inform you of the current status as much as possible. 

 

 

The only way to exit Safe mode is to power cycle the device. 

If the device has recovered from Safe mode and restarted but the critical condition is still present, the unit 
will return to Safe mode again. 

If the unit returns to Safe mode repeatedly after you power cycle the device, power off the device and contact 
LeddarTech’s technical support for further troubleshooting. 
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A transition graph of the Leddar Pixell state machine is illustrated below. 

 

Fig. 26: Safe mode functionality 
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5. Specifications 

5.1. General Characteristics 

Table 9: Characteristics1, 2 

Description Value 

Number of segments (H x V) 96 x 8 

Horizontal FoV 177.5° 

Vertical FoV 16° 

Angular resolution (horizontal) 1.9° 

Angular resolution (vertical) 2.0° 

Wavelength (nominal) 905 nm 

Frame rate 20 Hz 

Accuracy1, 3 ±3 cm 

Demerging accuracy4 ±10 cm 

Demerging precision4 8 cm 

Automotive connector 
Mating cycle: 10 

See section 7.2 on page 48 for more details. 

Automotive Ethernet 

Physical layer (PHY) compliant with 100BASE-T1 (IEEE 802.3bw). 
Maximum length of 30 m. 

Leddar Pixell does not support the 802.3bp standard. 

Maximum bandwidth Refer to Table 16 on page 44 for more details. 

Startup time 
−30 °C +20 °C 

≤15 s ≤6 s 

5.1.1. Detection Ranges 

Table 10: Detection ranges 

 Detection Range (m) 

Horizontal 
FoV (°) 

Vertical 
FoV (°) 

Vehicle 10% 
reflectivity5 

Vehicle 50% 
reflectivity5 

Reflector 80% 
reflectivity5 

Pedestrian 50% 
reflectivity6 

177.5 16 19 43 53 32 

 

1 Typical specifications. 
2 Environmental conditions, weather, and reflectivity level of elements in the scene may affect sensor performance. 
3 Ambient test performance with a 3 σ standard deviation. Non-saturated signal without crosstalk for non-merged 

events. 
4 Non-saturated signal without crosstalk. 
5 Full pixel coverage. 
6 Euro NCAP Pedestrian reference. 
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5.1.2. Test Conditions 

Table 11: Test conditions 

Test Condition Detection Range Description 

Pedestrian 
18% reflectivity7 

50 cm x 180 cm target 

≥24 m At the center of each 59.16° section of the horizontal FoV 

≥20 m Everywhere else in the 59.16° section of the horizontal FoV 

Vehicle 
10% reflectivity7 

180 cm x 140 cm target 

≥19.2 m At the center of each 59.16° section of the horizontal FoV 

≥15.4 m Everywhere else in the 59.16° section of the horizontal FoV 

Vehicle 
50% reflectivity7 

180 cm x 140 cm target 

≥43 m At the center of each 59.16° section of the horizontal FoV 

≥35 m Everywhere else in the 59.16° section of the horizontal FoV 

Reflector 
80% reflectivity 

53 m N/A 

5.2. Mechanical Specifications 

Table 12: Mechanical specifications8 

Description Value 

Width 245 mm 

Depth 141 mm 

Height 97 mm 

Section embedded in the vehicle 82 mm 

Section exceeding the vehicle 60 mm 

Weight 2.1 kg 

Mounting holes and measurements See Fig. 31 on page 42. 

 

7 100 klx ambient daylight. 
8 Tolerances: ±0.10 mm (linear), ±0.5° (angular). 
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Fig. 27: Dimensions (top view) 

 

Fig. 28: Dimensions (rear view) 
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Fig. 29: Dimensions (front view) 

 

Fig. 30: Dimensions (left side view) 

 

Fig. 31: Measurements and distance between mounting threads (right side view) 

4 x M6 x 1.0 x 15.00 
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5.3. Electrical Specifications 

Table 13: Electrical specifications 

Description Value 

Power supply 
11 V to 52 V 

Absolute minimum rating: 11.5 V 

Power consumption 20 W9 

PPS input voltage Logic 0: <1.2 V; logic 1: 3 V to 12 V (nominal: 5 V) 

PPS frequency range 0 Hz to 10 Hz for time synchronization 

PPS minimum pulse width 400 ns 

5.4. Environmental Specifications 

Table 14: Environmental specifications 

Description Value 

Operating temperature range −30 °C to +65 °C 

Storage temperature −40 °C to +85 °C 

5.5. Software System Requirements 

Table 15: Leddar Configurator system requirements 

Description Value 

Operating system Windows 7 and up 

Memory (RAM) 1 GB minimum 

Disk space 150 MB minimum 

Communication interface Automotive Ethernet 

  

 

9 Nominal power consumption at +20 °C. 
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5.6. Bandwidth 

Table 16: Bandwidth required for communication between sensor and network10 

Worst-Case Scenario 
Bytes per Frame 

(Decomposed in Data Elements) 
Frame Rate (FPS) 

768 x 3 = 2304 detections 

Header 16 

At 20 FPS you need 27 777 x 20 = 
555 540 bytes per second of bandwidth. 

Timestamp 12 

Frame ID 16 

Timestamp 32 bits 12 

Timestamp 64 bits 16 

Echoes sent 16 

Distances 9224 

Channel index 4616 

Amplitude 9224 

Flags 4616 

Status 9 

Total 27 777 

  

 

10 The values shown are the upper limit in case all segments have a maximum of three (3) detections. In practice, a 
lower bandwidth may be required since the sensor only sends out detections treated by the signal processing (valid 
or invalid). Characterization of the bandwidth used, in typical and worst cases, may be required for your specific 
application. 
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6. Mechanical Integration 

This section provides recommendations for the mechanical integration of the Leddar Pixell. 

See section 5.2 on page 40 for mounting information and section 7 on page 47 for information on connecting 
the sensor. 

 

It is strongly recommended not to install the sensor behind a window in order to maintain 
performance. 

As seen in Fig. 32 and Fig. 33 on next page, when installing the sensor, leave a minimum clearance of 8 mm 
on the top, sides, and bottom of the sensor. Leave an opening of 10 mm minimum at the back of the sensor 
to evacuate the heat (red arrows) properly. 

You must also leave enough space for the FoV so that there is no interference with the transmission and 
reception of light detections. The FoV integration must span further than the 15.5° (11) vertical FoV to preserve 
the transmission of the outer segment of the sensor. 

 

Fig. 32: Clearance required for FoV and around the sensor (side view) 

 

11 Typical FoV. 
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Fig. 33: Clearance size (top view) 

Fig. 33 shows the minimum opening recommended at the back of the sensor to evacuate heat properly. 

 

Fig. 34: Clearance size (rear view) 

 
Make sure to leave enough space for the connectors. 

No interference No interference 

7 500 mm2 minimum 
opening 

A = 7 500 mm2 
minimum opening 
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7. Electronic Integration 

7.1. Synchronizing the Sensors 

Integrators can synchronize the clock for all the different sensors in the system to increase the perception’s 
accuracy. 

Two functionalities have been implemented: PPS and PTP. 

7.1.1. GPS Pulse-per-Second Signal Input 

GPSs used in autonomous navigation systems will provide a clock signal that can be employed to 
synchronize various systems together. The sensor must accept a “Pulse PPS” signal input and use it as a 
time reference. 

The “Pulse PPS” signal allows each timestamp data to be synchronized with the GPS clock used in the 
navigation system. 

LeddarTech’s integration guidelines require a “Pulse PPS” synchronization signal free of data between pulses. 

7.1.2. PTP Precision Time Protocol Signal Input 

The Precision Time Protocol (PTP) is a protocol used to synchronize clocks throughout a computer network. 
The PTP is employed to synchronize networks that require precise timing but lack access to satellite 
navigation signals (GPS pulse-per-second signal). 

LeddarTech’s integration guidelines are based on the IEE 1588-2008 standard. 

7.1.3. External Trigger 

The External trigger option allows you to change the PPS input function to trigger input. The PPS input pins 
will be used to trigger the sensor acquisition. The physical trigger signal dictates the start of the acquisition 
and can be set to “Rising edge” or “Falling edge,” as shown in Fig. 35 below. 

 

Fig. 35: Acquisition Settings, Acquisition window 
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7.2. Power Connector Pinout and Wiring 

Table 17: Cable connection 

Pin # Function Description 

1 Ground Power supply ground 

2 ETH+ 
Automotive Ethernet differential pair 

3 ETH- 

4 PPS- (Input) 
Input for timestamp synchronization. Can be used as a trigger input. 

5 PPS+ (Input) 

6 V+ (11 V-52 V) Power supply 

7 Sync+ (Out) 
One pulse per second output for multi-Leddar Pixell synchronization 

8 Sync- (Out) 

Recommendations on Connector Assembly 

To assemble the harness, you need the following: 

• One (1) automotive connector (Fig. 36). Also, refer to the pin positions in Fig. 37. 

• RTV moisture-curing silicone 

• Two (2) strain reliefs (Fig. 38) 

• One (1) cable tie (Fig. 39) 

1. Follow recommended assembly practices from AMPSEAL for this connector, referring to the instructions 
named “Application Specification 114-16016” available on their website. 

2. Seal each exiting wire with RTV moisture-curing silicone. To ease this step, you can fill the whole rear 
pocket of the connector with silicone. 

3. Install the strain relief (Fig. 38). 

4. Install the black cable tie onto the strain relief, as shown in Fig. 40 on page 49. 

 

Fig. 36: TE Connectivity AMP connector – 
Automotive connector PLG 08POS F/H BLK 

 

Fig. 37: Automotive connector pin positions 
(cavity side as shown on the left) 
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Fig. 38: TE Connectivity AMP connector – 
8 position AMPSEAL strain relief 

(2 strain relief connectors required) 

 

Fig. 39: Cable tie 

 

The parts and accessories shown above are recommended by LeddarTech to ensure 
compatibility with the Leddar Pixell connector interface. LeddarTech does not offer these 
parts and accessories. Contact the appropriate vendors to obtain the parts you need. 

Once assembled, the connector will look as shown below. 

 

Fig. 40: Connector assembled 

7.3. Connecting the Sensor – Diagrams 

This section provides information on the recommended wiring options for the sensor. Refer to Table 17 on 
page 48 for more details on the pinout and wiring. 
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7.3.1. One Sensor With the Starter Kit 

 

Fig. 41: One-sensor connection 

You can now start using Leddar Configurator. See section 9 on page 54 and section 10 on page 56 for 
details. See section 11 on page 84 for more information on parts and accessories. 
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7.3.2. Multiple Sensors With Automotive Ethernet 

Here is an example of a multiple-sensor integration. The automotive Ethernet standard is point-to-point. The 
physical layer is a twisted pair cable. If you do not have an ECU directly compatible with automotive Ethernet, 
use converters or a switch that features both standard and automotive Ethernet. 

 

Fig. 42: Multiple-sensor connections 

You can now start using Leddar Configurator. See section 9 on page 54 and section 10 on page 56 for 
details. See section 11 on page 84 for more information on parts and accessories. 

To configure the PPS input in Trigger mode, refer to Table 46 on page 111. 
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8. Software Integration 

There are three ways of integrating LeddarTech’s LiDAR sensors within your applications: 

1. Developers can build their complete applications from the ground up, based on the low-level 
communication protocol definition. Refer to Appendix D on page 99 for more details on the 
communication protocol used with the Leddar Pixell. 

2. Use the Leddar SDK to accelerate your software integration and reduce the lead time associated with 
entirely building your application from the ground up. See section 8.2 below for more details. 

3. Use the RTMaps middleware for integration with a graphical interface. See section 8.3 below. 

8.1. Communication Protocol 

The Leddar Pixell uses LeddarTech’s proprietary data communication protocol (IP socket-based protocol), 
called Ipv4. 

Refer to Appendix D on page 99 for more information on the sensor communication protocol. 

8.2. Software Development Kit (SDK) 

The Software Development Kit (SDK) allows you to integrate the sensor into your system. The SDK contains 
basic functions to communicate with the sensor, which will enable you to integrate the sensor faster in your 
system. 

To obtain the software compatible with Leddar Pixell, go to www.github.com/leddartech/LeddarSDK. 

To obtain the documentation relating to the Software Development Kit, go to http://sdk.leddartech.com/. 

Leddar SDK Supported Platforms 

LeddarTech fully supports the use of its SDK on the following platforms: 

• Windows 7 and Windows 10 (32 and 64 bits) 

• Linux (Ubuntu) 32 and 64 bits 

• ARM (Nvidia Jetson TX2, Raspberry Pi) 

Limited support is also available on other platforms. Contact LeddarTech if you want to know whether a 
specific platform is supported. 

If you are not using the SDK on a supported platform, refer to Appendix D on page 99. 

If you encounter any problem or if you have questions or concerns, contact LeddarTech support at 
support@leddartech.com. 

8.3. RTMaps 

Developed by Intempora, a Leddar™ Ecosystem partner, RTMaps 4 is an asynchronous high-performance 
platform designed to overcome multi-sensor challenges and allow engineers and researchers to take 
advantage of an efficient and easy-to-use framework for fast and robust developments. 

Refer to the Application Note “Unleash the Power of LeddarTech Solid-State Scanning LiDARs with 
Intempora RTMaps” for assistance in using the package with this middleware. This Application Note can also 
be accessed at leddartech.com under Resources > Resource Library > Document Types > Application 
Note. 

  

https://github.com/leddartech/LeddarSDK
http://sdk.leddartech.com/
mailto:support@leddartech.com
https://d2euypccftd53r.cloudfront.net/prod/app/uploads/2019/06/18144133/UNLEASHTHE-POWER-OFLEDDARTECH%E2%80%99SSOLID-STATE-SCANNING-LIDARS-WITH-INTEMPORA-RTMAPS-FINAL1.pdf
https://leddartech.com/
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8.4. FibreCode Stick 

Developed by FibreCode Embedded Solutions, the FC602 USB OABR stick represents a compact hardware 
interface that connects MS Windows- and Linux-based PCs with automotive Ethernet network devices and 
switches. Automotive Ethernet network standards OABR (OPEN Alliance BroadR-Reach) and 100Base-T1 
are supported. 

The FC602 USB OABR stick functions as a seamless media converter between a standard USB 2.0 interface 
and an automotive Ethernet network. On Windows and Linux host PCs, the USB OABR stick is detected as 
a standard Ethernet device. 

See section 11 on page 84 and Appendix C on page 94 for more details on the driver installation. 
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9. Installing Leddar Configurator 

1. Download LeddarInstall.exe via the provided link. Contact LeddarTech at support@leddartech.com if 
you did not receive the link. 

2. Double-click the file to start the installation. 

3. If the Windows Security dialog box opens, click the Install button to accept the installation of the drivers 
from LeddarTech during the process. 

 

Fig. 43: Windows Security dialog box 

4. Follow the steps in the Welcome to the Leddar™ Configuration Software Setup Wizard. 

 

Refer to Appendix B on page 92 for the detailed procedure on configuring the network with a 
static IP. 

Connecting to Leddar Configurator 

To connect your sensor to Leddar Configurator, follow the steps below. 

1. On your computer desktop, click the Leddar Configurator icon ( ) to open the software. 

2. Click  to connect to the sensor. 

3. Select Public networks (…) to bypass the Windows firewall. 

 

Fig. 44: Bypassing Windows firewall window 

mailto:support@leddartech.com
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If the window above is not displayed, see Appendix A on page 90. 

4. In the Connection window, under Select a connection type, select LeddarAuto. 

The first time the sensor is connected to a computer, a few seconds are required for Windows to detect 
it and complete the installation. 

5. a) If the sensor is automatically detected, select the available sensor from the list. 

b) Otherwise, enter the IP address 192.168.0.2 and Port number 48630. 

6. Click Connect to connect to the available sensor. 

The color of items in the list indicates the status of a sensor. 

• Black: This sensor is available. No user is connected to it. 

• Blue: There is a user connected to this sensor. 

• Red: Unable to communicate. If the sensor does not respond to requests after some time, it is 
displayed in red. 

 

Fig. 45: Steps to connect to Leddar Configurator 

  

2 

3 

4a 

4b 

5 
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10. Leddar Configurator Software 

The software allows you to view the detection measurements provided by the connected sensor. The 
detections may vary based on the configuration of the parameters. 

 

The Leddar Configurator software does not display detections flagged as “invalid.” 

The main window can be resized manually or set to full-screen view. All dialog boxes that do not include a 
selection of action buttons at the bottom, such as Connect, OK, or Cancel, are dockable at the top, bottom, 
or right side of the main window. 

When a dialog box or a window is already open, a checkmark appears next to the command on the menu. 

 

<Alt> + click a segment to obtain the following information: 

• H Channel (horizontal segment) 

• V Channel (vertical segment) 

• Distance 

• Amplitude 

 

Fig. 46: Leddar Configurator software 
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10.1. Main Window 

Once connected to the sensor, the main window of Leddar Configurator displays the following menus, 
toolbar, and default 3D view. See their descriptions in the sections below. 

 

Fig. 47: Leddar Configurator main window with a 3D view example 

Table 18: Main window menus and paths 

Menu Description 

File 

Click File to access the following menu options: 

File > Replay 

File > Save Configuration 

File > Load Configuration 

File > Start/Stop Recording (<F9>) 

File > Start/Stop Data Logging 

File > Quit 

See section 10.4 on page 66 for more details. 

Menu bar 

Toolbar 

Display Parameters 
icon 
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Menu Description 

Device 

Click Device to access the following menu options: 

Device > Disconnect 

Device > Configuration > Device Name… 

Device > Configuration > Acquisition 

Device > Configuration > Network 

Device > Action > Reset to factory default configuration 

Device > Action > Update 

Device > Debug 

See section 10.5 on page 71 for more details. 

View 

Click View to access the following menu options: 

View > Serial Port Viewer 

View > State 

View > Raw Detections 

View > 2D Matrix Viewer 

See section 10.6 on page 74 for more details. 

Settings 

Click Settings to access the following menu options: 

Settings > Preferences 

Settings > Licenses 

See section 10.7 on page 82 for more details. 

Help 

Click Help to access the following menu options: 

Help > User Guide 

Help > About 

See section 10.8 on page 83 for more details. 

Table 19: Main window toolbar and Display Parameters icon 

Icon Description 

 

 

The Connect icon allows you to connect to a sensor. Once connected, the 
Connect icon will change to Disconnect. 

The Disconnect icon will then allow you to disconnect the sensor from the 
system. 

 
The Apply icon allows you to confirm and apply the changes you just made to the 
system with respect to the sensor. 

 
The Undo icon allows you to revert to the information displayed before making 
your changes or before specifying parameters, for example. 

 

The Reset Camera icon allows you to select between three different types of 
views for the signal display: 

• Bird’s-eye view 

• Top view 

• Front view 

See section 10.3.1 on page 64 for more details. 

 
Click Zoom in to zoom in the display. 
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Icon Description 

 
Click Zoom out to zoom out the display. 

 

 

Under the display view, click the three arrows up to see the Display Parameters 
section. 

Click the three arrows down to hide the Display Parameters section. 

10.2. 3D Viewer and Parameters 

Upon opening the Leddar Configurator software, the 3D view is displayed by default. 

This option allows you to view the scene in a 3D environment. A colored segment represents each detection. 
The 3D view is configurable. See below for more details. 

Click  to view and modify the color and display parameters of the 3D Viewer. Once the parameters are 
specified according to the desired criteria, you will view the detections according to these parameters. 

 

Fig. 48: 3D Viewer window 
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Fig. 49: 3D Viewer window and parameters 

See below for the description of the 3D Viewer window parameters section by section. 
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Fig. 50: 3D Viewer parameters 

Click  to hide the Display Parameters section. 

Table 20: 3D Viewer parameters 

Parameter/Feature Description Range/Value 

Points Shape 

This section allows you to select the points shape to display the 
detection scene, including the detected object. You can choose to 
view the scene with points, planes, or cubes. 

• Points refer to the same size points as appearing in the 3D 
view. 

• Planes refer to square-shaped filled segments that change 
depending on the distance. 

• Cubes refer to 3D shaped cubes appearing in the 3D view. 

Points 

Planes 

Cubes 

Sensor Position 

This section allows you to specify the X, Y, and Z axes from 
where the sensor (sensor position) collects the detected object 
using the up and down arrows or by entering the exact desired 
values in the box. 

Using the up and down arrows or entering the exact desired 
values in the box, you can select the parameter related to: 

• Yaw, i.e., how you want to display the object around the 
vertical axis 

• Pitch, i.e., how you want to display the object around the 
horizontal axis 

• Roll, i.e., how you want to display the object around the 
longitudinal axis 

X 

Y 

Z 

Yaw 

Pitch 

Roll 
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Parameter/Feature Description Range/Value 

Color Options 

This section allows you to change various parameters related to 
the color map: 

• Amplitude 

• Distance 

• Minimum color (Min Color) 

• Maximum color (Max Color) 

• Amplitude display limits 

• Distance display limits 

• Log scale 

Varies 

Amplitude 

Distance 

Select the Amplitude or Distance option depending on the way 
you want to view the detections. 

If you select Amplitude, specify the minimum color and maximum 
color, and the amplitude display limits if you want to view the 
detections. 

If you select Distance, specify the minimum color and maximum 
color, and the distance display limits within which you want to view 
the detections. 

Varies 

Min Color 

Max Color 

Indicates the range by which the color map may vary. 

Values below the specified Min Color will be blue and values 
greater than the specified Max Color will be red. 

The color of the values between these ranges will vary linearly. 

The maximum amplitude is 262 143 by default. 

Setting a value in both fields will result in a range of amplitude to 
display. 

0 to 262 143 

Amplitude 
Display Limits 

Indicates the lower and upper limits of amplitudes to display. 
Detections with an amplitude value out of the range will not be 
displayed. 

0 to 530 000 

Distance Display 
Limits 

Indicates the lower and upper limits of distances to display in 
meters or feet. Detections with a distance value out of the range 
will not be displayed. 

To set unit preferences, see section 10.7.1 on page 82. 

0 to 300 

Log Scale 
Select this option to switch from a linear scale to a logarithmic 
scale and conversely. 

N/A 

Other Options 

The Other Options section allows you to select the appropriate 
following options according to the desired criteria: 

• Display axis 

• Display FoV 

• Invert X, Y, or Z 

• Swap X, Y, or Z 

• Freeze 

• Background Color 

• Background Grid 

• Export Configuration 

• Import Configuration 

Varies 
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Parameter/Feature Description Range/Value 

Display Axis Select this option to view the axis. Varies 

Display FoV Select this option to view the FoV. N/A 

Invert X 

Invert Y 

Invert Z 

Select one of these options to invert the desired axis. N/A 

Swap X Y 

Swap X Z 

Swap Y Z 

Select these options to swap the X, Y, or Z axis ordinates. The 
coordinates will be rearranged according to the selected option. 

N/A 

 Click Freeze to view a static display of the scene. Varies 

 
Click Background Color to change the color of the background 
grid. 

Varies 

 

Click Background Grid to change the background view with one 
of the following four options: 

• No grid 

• Polar and square grids 

• Grid pattern 

• Polar grid 

Varies 

 
Click Export Config to save a 3D display configuration in .lcfg 
format. 

N/A 

 
Click Import Config to restore a 3D display configuration in .lcfg 
format. 

N/A 
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10.3. Changing the View and Orientation 

10.3.1. Display Settings 

A variety of options are available to adjust the signal display. The Reset Camera icon ( ) allows you to 
change the type of view of the signal display. Clicking the Reset Camera icon moves you through the three 
available 3D views: Bird’s-eye view, Front view, and Top view. 

   

 

Fig. 51: 3D views (Bird’s-eye, Front, and Top views, respectively) 
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You can view, move, and zoom the main window display in different ways according to the mouse cursor 
position. 

You can move up, down, and sideways by clicking and dragging the display. Use the mouse cursor to point 
somewhere in the view; click and drag it to the desired position. 

   
Fig. 52: Signal display position and rotation 

Changing the position and orientation helps you match the physical installation of the sensor. For example, 
if the sensor needs to be installed vertically or upside down for mechanical reasons, the axes can be 
reoriented to reflect its position. 

10.3.2. Detection Scene Shortcuts 

Mouse shortcuts allow you to change the sensor display. 

• <Shift> + click to pan 

• <Ctrl> + click to rotate the view in a single axis once at a time 

• <Ctrl> + mouse wheel to zoom in or out the detection scene, or click  or  in the toolbar. 

  

Moving the mouse to change the position Moving the mouse to change the orientation 
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10.4. File Menu 

Table 21: File menu options 

Option Description 

Save 
Configuration 

This option allows you to save the configuration for a specific device to a file (.lto) 
from the Save as… dialog box. 

This allows you to save settings and restore them in case of a system failure or to 
revert to earlier settings. In addition, if you have more than one sensor and you 
want to use the same configuration for all of them, save the configuration you want 
to use for all your sensors. In this case, make sure to assign a different name to all 
your sensors. 

The sensors named differently will use the same configuration. See section 10.5.1 
on page 72 for more details. 

Load 
Configuration 

This option allows you to load the device configuration previously saved in the 
system as an .lto file. Choose the desired device configuration from the Open 
dialog box. 

You can also retrieve the configuration that was stored with a record file. In case 
of system failure, you can load a sensor configuration and use this sensor configu-
ration to collect signal data according to a set of parameters (scanning, distance 
measurements, etc.) and then analyze the collected data or the information. In ad-
dition, if you have more than one sensor and you want to use the same configura-
tion for all of them, you must load the previously saved configuration that you want 
to use for all your sensors. In this case, make sure to assign a different name to all 
your sensors. 

The sensors named differently will use the same configuration. See section 10.5.1 
on page 72 for more details. 

Start Recording 

Stop Recording 

Select the Start Recording option (shortcut: <F9>) to start recording detections in 
an .ltl file that can later be reloaded and replayed. 

Select the Stop Recording option (shortcut: <F9>) to stop recording detections of 
the .ltl file. 

See section 10.4.1.2 on page 67 for more details. 

Replay 

Once you have completed a recording, you can review it by selecting Replay in 
the File menu. 

The Position slider allows you to move directly to the desired position. The 
Playback Speed slider allows you to adjust the speed of the recording playback. 

See section 10.4.1.3 on page 68 for more details. 

Start Data Logging 

Stop Data Logging 

Select the Start Data Logging option to start the log of receiving data or the event 
log of the sensor. The event log is displayed in text format. 

Select the Stop Data Logging option to stop the log of receiving data or the event 
log of the sensor. The event log is displayed in text format. 

See section 10.4.2.2 on page 71 for more details. 

Quit Select Quit to exit the Leddar Configurator software. 
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10.4.1. Recordings (.ltl File) 

Detection records provide playback of detections recorded by a device. This visual information can be useful 
for verification, troubleshooting, or training purposes. Detection records provide a full data playback stored 
in an .ltl file that you can later reload and replay. 

10.4.1.1. Setting up Recording Settings 

Under Settings > Preferences > Recording, select Recorder. 

1. Select a directory. 

2. Specify a Maximum file size (minimum 1 MB and maximum 500 MB). 

3. Select Log debug information only if requested by LeddarTech to activate troubleshooting information. 
Selecting this option activates advanced debug features and is inefficient for long recordings. 

4. Specify a Maximum record time (minutes) (minimum 1 minute and maximum 71 582 minutes). 

5. Click OK. 

The filename of the recording will be the device name followed by the date and time of the recording. 

When recording for a long period of time, an additional file is automatically created every time a recording 
exceeds 500 MB. 

You can change the name of the file by changing the device name (see section 10.5.1 on page 72) or after 
the recording. 

 

Fig. 53: Recording settings 

10.4.1.2. Recording a Scene 

To start recording the detection scene: 

1. Under Settings > Preferences > Recording, specify the maximum file size and maximum record time. 
See section 10.4.1.1 above for more details. 

2. In the File menu, select Start Recording. 
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A pop-up window appears where you can select the starting and ending lines for the recording. The selection 
ranges from 1 to 8. 

If you want to record one line only, Line 4, for example, select “4” in the Starting Line and Ending Line fields, 
respectively. 

 

Fig. 54: Recording Starting and Ending Lines 

3. Click Record to record a scene. 

A counter starts at the bottom left of the main window next to the name of the sensor. 

To stop recording the detection scene, select Stop Recording in the File menu. 

10.4.1.3. Replaying a Recording 

To access this function, disconnect from the sensor and click File > Replay. 

Once you have completed a recording, this option allows you to review the recorded *.ltl file and extract 
parts. 

1. Click File > Replay. The Record Replay window appears: 

 

Fig. 55: Record Replay window upon opening 

2. Click Browse… to select a file. 

 

Fig. 56: Record Replay window with an open file 
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Table 22: Record Replay window 

Button/Feature Description 

 
Click Browse… to select the record file of the scene that you want to view again. 
Once selected, the name of the file will appear next to the Browse… button. 

 
Click the Play button to start the recording. 

 
Click the Stop button to end the recording. 

 

 

Click the Previous or Next button to move either to the previous or to the next 
frame. 

Position 

 

Move the Position slider to go to the desired position in the recorded file. The 
indication of the position is located above the Play and Next buttons, for example, 

. 

Playback Speed 

 

Move the Playback Speed slider to change the playback speed in order to see 
the scene or the detected object more accurately. The percentage indicates the 

speed of the playback, for example, . 

Loop Select this option to automatically loop back to the beginning of the recording. 

 Click Start to tag the position to start the extraction. 

 
Click End to tag the position to end the extraction. 

 
Click Extract to extract a part of the scene and save it as an .ltl file. See section 
10.4.1.4 below for more details. 

10.4.1.4. Extracting a Scene Segment 

This feature allows you to extract a segment from a previously recorded scene. 

1. Click Browse… to select the record file to play. 

2. In the Open window, select the desired record file and click Open. 

3. Click  to start the playback. 

To extract a record file segment: 

1. Move the Position slider to the position to see the file segment start and click . 

2. Move the Position slider to the position to see the file segment stop and click . 

Alternatively: 

1. Play the record and stop it at a position of interest, then click . 

2. Restart playing the record and stop it again at a position of interest, then click . 
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3. Click  to extract and save that file segment. 

If you want to specify a different speed for the playback, enter the desired playback speed percentage 
or use the arrows up and down to specify the right percentage. 

4. Click . 

 

Fig. 57: Extracted segment example 

10.4.2. Data Logging (.txt File) 

10.4.2.1. Setting Up Data Logging 

When selecting this option, a counter will start at the bottom left of the main window next to the name of the 
sensor. 

To set up data logging file and launch data logging: 

1. To configure a .txt recording, click Settings > Preferences > Recording > Data Logger. 

2. Click  to select where to save the log and click OK. 

 

Fig. 58: Preferences window 
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The recording’s filename will be the device name followed by the date and time of the recording. You can 
change the name of the file by changing the device name (see section 10.5.1 on page 72) or after the 
recording. 

To stop data logging: 

In the File menu, select Stop Data Logging. 

10.4.2.2. Starting and Stopping Data Logging 

To access this function, click File > Start Data Logging. 

The Data Logging function allows you to output the data to a .txt file automatically. This file can be imported 
into a software application, such as Microsoft Excel, for offline analysis. 

 
It is recommended to change the name of the .txt file. 

Each line of the generated text file contains the information related to a single detection. For example: 

Time (ms) 
Segment 

Horizontal (0 to 96), Vertical (1 to 8) 
Amplitude (counts) Distance Status 

21338 7,1 700 33.61 1 

In this table: 

• Time indicates the timestamp of the detection from when the sensor was connected to the power 
supply; 

• Segment refers to the location of the detection (horizontal and vertical); 

• The Amplitude of the detection indicates the strength of the returned signal; 

• Distance indicates the distance of the detection in meters or feet, depending on the distance unit 
configured in the Preferences window; 

• Status corresponds to a flag value. 

10.5. Device Menu 

Table 23: Device menu options 

Option Description 

Device > Disconnect… Click  to disconnect the sensor from the software and return to Leddar 
Configurator. 

Device > Configuration 
> Device Name… 

Select this option to modify the name of the sensor. 

See section 10.5.1 on page 72 for more details. 

Device > Configuration 
> Acquisition > Acqui-

sition 

Select this option to manage the system time and synchronization method. 

See section 7.1 on page 47 for more details. 

Device > Configuration 
> Acquisition > Algo 

Select this option to enable or disable the demerging functionality. 

See section 10.5.2 on page 73 for more details. 
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Option Description 

Device > Configuration 
> Network 

Select this option to access and modify the network configuration. 

See section 10.5.3 on page 73 for more details. 

Device > Action > 
Reset to factory 

default configuration 
This action resets all settings to the factory default configuration. 

Device > Action > 
Update 

Select this option to update the Leddar Configurator firmware. 

See “Firmware Update” on page 76 for more details. 

10.5.1. Device Name 

To access this function, click Device > Configuration > Device Name…. 

This option allows you to view and modify the name of the sensor. When you connect to the sensor for the 
first time, a default name will be displayed. You can change the name of the sensor at any time with a 
connected device. 

1. In the Name field of the Device Name dialog box, enter the new name of the sensor and click OK. 

2. A warning message appears in red. 

3. Click  in the toolbar to save your changes. 

 

Fig. 59: Device Name window and warning message example 
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10.5.2. Demerging 

To access this function, click Device > Configuration > Acquisition > Algo. 

The Leddar Pixell integrates an algorithm that allows you to demerge pulses of operation distances higher 
than 0.8 meter (will vary with amplitude and pulse ratio). 

The Leddar Pixell pulse demerging algorithm supports the demerging of 70 to 150 pixels in one frame with 
minimal effect on frame rate. The number of pixels corresponds to a scene comprised of merged objects 
covering 20% of the total FoV. Priority is given to the central head, line 1, segment 65, and the next other 
segments on the same line, and then the next line until the maximum demerging capacity is reached 
according to the mode of operation. 

A flag has been implemented in the sensor output data, allowing you to differentiate a standard detection 
from a detection processed through the demerging algorithm. 

 

Fig. 60: Acquisition Settings, Algo window 

To activate demerging, select the Demerge enable option. 

10.5.3. Network Configuration 

To access this function, click Device > Configuration > Network. 

This window allows you to view and modify the IP configuration and communication protocol configuration. 
The network configuration is applied after a system reboot. 

The address displayed in this window is always the latest static IP used by the sensor (default: 192.168.0.2), 
even if the current address is dynamically assigned. If no DHCP server is found, the sensor reverts to this 
address. The currently assigned address (whether dynamic or static) can be found in the Connection 
window upon a new connection (see Fig. 45 on page 55). 

UDP or TCP communication mode can be selected by checking the desired option below, followed by clicking 
OK and restarting the Pixell. 
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Fig. 61: Network Configuration window 

 

A warning message will appear in the main window after changing parameters. Click  in 
the toolbar to confirm the changes. 

Table 24: Network Configuration window 

Parameter Description 

Static IP 
 No factory reset is possible if you lose or forget the static IP address. 

TCP Transmission Control Protocol (data server only) 

UDP User Datagram Protocol (data server only) 

10.6. View Menu 

Table 25: View menu options 

Menu Description 

View > Serial 
Port Viewer 

Select this option to view data related to the selected serial port. This feature is not 
available with this version. 

View > State 

Select this option to consult various sensor information such as the sensor 
temperature, CPU load, sensor serial number, software version, and sensor status. 

See section 10.6.2 on page 75 for more details. 

View > Raw 
Detections 

Select this option to view the displayed data and to define the desired detection 
parameters. 

See section 10.6.3 on page 78 for more details. 

View > 2D 
Matrix Viewer 

Select this option to view the detection scene in 2D. 

See section 10.6.4 on page 81 for more details. 
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10.6.1. Serial Port Viewer 

To access this function, click View > Serial Port Viewer. 

When no serial port is available, the window remains empty, as shown below. 

 
This feature is not available with this version. 

 

Fig. 62: Serial Port Viewer window 

10.6.2. Device State 

To access this function, click View > State. 

This window allows you to view information about the state of the sensor. 

 

Fig. 63: Device State window 
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The Measurement Rate in red indicates a significant difference between the optimum and current 
measurement rates. 

Table 26: Device State information 

• Temperature 

• Serial number 

• Software version 

• FPGA version 

• Hardware part number 

• Software part number 

• Group ID number 

• Sensor status12 

• Timers (operating time) 

• CPU load 

• Measurement rate 

Firmware Update 

To access this function, click Device > Update. 

The Code Update window allows you to update the software from an .ltb file in the host’s file system. 

 

Fig. 64: Code Update window 

Click Browse..., then select the .ltb update file provided by LeddarTech from your computer’s file system. 
Wait for the progress bar to complete, then for the sensor to reconnect. The update is then completed. 

To verify the update, click View > State. The Device State window opens, enabling you to verify the software 
version. 

 

12 See section 4.4 on page 36 for more details on the sensor statuses and alerts. 
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Fig. 65: Device State window 

If you encounter any problem or if you have questions or concerns, contact LeddarTech support at 
support@leddartech.com. 

  

Firmware version 
information 

mailto:support@leddartech.com
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10.6.3. Raw Detections 

To access this function, click View > Raw Detections. 

This window allows you to view detection values. It also provides filters to isolate segments and detection 
parameters. 

An object crossing the beam of the sensor is detected and measured. This detection is qualified by its 
segment position, distance, and amplitude. The quantity of light reflected to the sensor by the object 
generates the amplitude. The bigger the reflection is, the higher the amplitude will be. 

 

Fig. 66: Raw Detections window 
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Table 27: Raw Detections parameters 

Parameter Description Range 

Min Amplitude 

Max Amplitude 

The value entered in the Min Amplitude box shows only detections 
of amplitude higher than or equal to that value. 

The value entered in the Max Amplitude box will show only detec-
tions of amplitude lower than or equal to that value. The maximum 
amplitude is 262 143 counts by default upon first use. 

Setting a value in both fields will result in a range of amplitude to 
display. 

The signal becomes saturated from 2047 counts to the maximum 
amplitude at 530 000 counts. 

0 to 530 000 

Min Distance 

Max Distance 

Minimum and maximum distance from where to detect an object. 

The maximum distance is 100.0 by default. 
–10 to 200 

Starting Index 

The vertical (V) index and horizontal (H) index correspond to a scan 
line index. 

Select a number to display that scan line. For example: 

 

Refer to Table 7 on page 34 for more details on channel indexes. 

Starting 
Index (V) 

1 to 8 

Starting 
Index (H) 
1 to 96 

Segment (Seg) 

Seg corresponds to the segments in line and column. 

Select the segments that you want to display in the detection results. 

For example, “4,1” where 4 corresponds to a photodetector 
segment and 1 corresponds to a scan line. 

Vertical segment: 1,X 

Horizontal segment: X,1 

 

1 to 96 

Freeze 
Select the Freeze option to freeze the raw data and view the 
information. 

N/A 

Distance (m) Position (in meters) of the detected object Varies 

Amplitude Quantity of light reflected by the object and measured by the sensor. 0 to 1 048 576 

Flags 
The Flags parameter provides the status information that indicates 
the measurement type (16-bit status encoded as a bit field). 

0 to 65 535 

  



 

80 | 127 © 2021 LeddarTech Inc. 

Flag Description 

The following table allows you to know the status of the sensor. 

Table 28: Flag value description 

Bit Position Flag ID Description 

0 Measurement status 
0 = Invalid measurement 

1 = Valid measurement 

1 PULSE_MULTOBJ 

0 = Normal measurement 

1 = Measurement is the result of demerge processing (see 
10.5.2 on page 73). 

2 Reserved Reserved 

3 PULSE_SATURAT 

0 = Normal measurement 

1 = The pulse is saturated for at least 2 consecutive samples 

The signal is saturated when exceeding an 
amplitude of 2047. 

See “Saturation” in section 2. 

4 Reserved Reserved 

5 Reserved Reserved 

6 PULSE_XTALK 

0 = Normal measurement 

1 = Measurement is the result of crosstalk (“xtalk”) processing 

See “Crosstalk” in section 2. 

7 PULSE_MODE 
0 = Normal mode 

1 = Mitigation mode (due to strong reflector[s] in the FoV) 

8 PULSE_ORIGIN 
0 = Pulse from high-range acquisition 

1 = Pulse from low-range acquisition 

9 Reserved Reserved 

10 PULSE_RIPPLES 

0 = Normal measurement 

1 = Set when parasite (electronic) ripples are detected and 
processed 

See “Parasite ripple” in section 2. 

11 Reserved Reserved 

12 Reserved Reserved 

13 Reserved Reserved 

14 PULSE_RETRIEV 

0 = Normal measurement 

1 = Measurement is the result of a reconstructed echo 
from the neighboring segment 

15 PULSE_INTERFERENCE 
0 = Normal measurement 

1 = Measurement is the result of interference processing 

For example, a valid echo with saturation correction will have a flag of 9 (VALID Flag=1 + 
PULSE_SATURAT=8) 
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10.6.4. 2D Matrix Viewer and Parameters 

To access this function, click View > 2D Matrix Viewer. 

This option allows you to view the scene in a 2D environment. A colored segment represents each detection. 
The 2D Matrix Viewer is configurable and can be used simultaneously as the 3D Viewer feature. 

<Alt> + click a segment to obtain the following information: 

• H Channel (horizontal segment) 

• V Channel (vertical segment) 

• Distance 

• Amplitude 

Click  to access and configure the 2D Matrix Viewer parameters. 

 

Fig. 67: 2D Matrix Viewer window and parameters 
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Table 29: 2D Matrix Viewer parameters 

Parameter Description Range 

HFoV Horizontal FoV information Varies 

VFoV Vertical FoV information Varies 

Width 

Height 
Width and height of the FoV at the maximum theoretical range Varies 

 
Click Freeze to view a static display of the scene. N/A 

Invert Horizontal 

Invert Vertical 

To invert the data on a different axis, select the Invert Horizontal 
or Invert Vertical option. 

N/A 

Rotate Select this option to rotate the image horizontally or vertically. N/A 

Out of range BW 
Select this option to make all detections outside of color map 
settings appear in black or white. 

N/A 

Amplitude 

Select this option to display colors on the map or grid according to 
amplitude. 

The amplitude is 4096 counts by default. 

Varies 

Distance 
Select this option to display colors according to distance. 

The distance is 48.00 by default. 
Varies 

Log Scale 
Select this option to switch from a linear scale to a logarithmic scale 
and conversely. 

N/A 

 
Click Export config to save a 2D display configuration in .lcfg 
format. This feature is not available with this version. 

N/A 

 
Click Import config to restore a 2D display configuration in .lcfg 
format. This feature is not available with this version. 

N/A 

10.7. Settings Menu 

10.7.1. Preferences 

To access this function, click Settings > Preferences. 

This window allows you to change various settings related to window display and recording of data. 

 

Fig. 68: Preferences window 
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Table 30: Preferences window options and settings 

Option Description 

Windows 

Select Windows to: 

• restore the window position and size upon startup 

• restore the window layout upon connection 

Units 

Select the distance unit: 

• Meter 

• Foot 

Select the temperature unit: 

• Celsius 

• Fahrenheit 

• Kelvin 

Recorder See section 10.4.1.1 on page 67 for details. 

Data Logger See section 10.4.2.1 on page 70 for details. 

10.7.2. License Manager 

 

Do not delete or modify the content of the License Manager window. Contact LeddarTech 
support for more information. 

10.8. Help Menu 

The Help menu includes the User Guide and About options. 

10.8.1. User Guide 

To access this function, click Help > User Guide. 

The User Guide option allows you to select and consult a PDF version of a user guide directly from Leddar 
Configurator. 

If available, select a user guide from the list to open a PDF version of the selected user guide. 

10.8.2. About 

To access this function, click Help > About. 

The About option allows you to know which software version is currently used and the software part number. 
This information is beneficial when contacting LeddarTech Support. 
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11. Parts and Accessories 

Part/Accessory Part Number Qty Description 

 

PIXELL-3D-F-A2 1 x Leddar Pixell 3D flash LiDAR 

The Starter Kit socket compatibility is as follows. Refer to the table below for more parts and accessories. 

• PIXELL-SK-01-US (IEC type B) 

• PIXELL-SK-01-EU (IEC type E/F Hybrid) 

• PIXELL-SK-01-UK (IEC type G) 

• PIXELL-SK-01-CH (IEC type I) 

Table 31: Starter Kit parts and accessories 

Part or Accessory Part Number Qty Description 

Power supply13 

 

29A0014 1 x 

SDI40-12-U-P5 wall plug, universal input 

In: 90-264 VAC 

Out: 12 V 3 A, 36 W, DC plug 

2.1 mm x 5.5 mm x 9.5 mm, female, without power 
cable 

Power cord13 

 

22G0001 1 x 
312003-01, North American power cord, 1.8 m or 
2.5 m, 10 A, IEC320-C13 plug (depending on the 
country) 

Communication cable 

 

71A0047-1 1 x 
External 3 m harness power and Ethernet cable with a 
sensor connector on one side and power connector 
and Ethernet/PPS wires on the other 

 

13 Indoor use only. 
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Part or Accessory Part Number Qty Description 

Automotive Ethernet 
to USB converter13 

 

73A0019-1 1 x 

Compact hardware interface connecting MS-Windows 
and Linux-based PCs with automotive Ethernet 
network devices and switches 

Windows driver: 
Broadway2 Windows Software Package 

Linux driver: 
Broadway2 Linux Software Package 

Mounting bracket13 

 

36D0199 1 x 

Installation bracket and screws (4 x M6 x 1.0 
↧ 15.00 mm) to install the sensor on a tripod 

36D0200 2 x 

For any questions or concerns, contact LeddarTech support at support@leddartech.com. 

  

https://www.fibrecode.com/fc602-usb-oabr-broadr-reach-100base-t1-stick.html
https://www.fibrecode.com/download/broadway/WSP_Broadway_V_02_02_04.zip
https://www.fibrecode.com/download/broadway/LSP_Broadway_V_02_02_04.zip
mailto:support@leddartech.com
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12. Troubleshooting 

Problem Required Action 

Ethernet connection not 
available 

• Verify that your computer is configured with a static IP address. 

• If the cabling connection seems secure, verify that the Ethernet link 
between the control computer and the sensor is valid using the ping 
command. 

Sensor not detected in 
Leddar Configurator 

• Verify the power supply of the sensor. 

• Disconnect from Leddar Configurator, then reconnect. 

• Power cycle the sensor. 

No data returned 

• Verify that nothing obstructs the sensor windows. 

• Verify if the lasers emit NIR light using a digital camera14 or an IR laser 
viewing card, such as the VRC2 from Thorlabs Inc. 

1. Make sure that your sensor is powered properly. 

2. Run the camera application on your smartphone or turn on your 
digital camera. 

3. Center the camera’s view on the laser element of the sensor. 

4. Look at your phone or camera screen and slowly move your 
camera around the center of the laser element to try and detect if 
there is either a purple beam or haze emitted from the laser, such 
as in Fig. 69 below. 

 

Fig. 69: NIR light visible by the camera 

Optical window damaged Contact LeddarTech support. 

Sensor not sending data 
and reporting “Safe mode” 
status 

• A critical fault has occurred. Power cycle the sensor to reset the 
condition. 

• If the Safe mode status persists, contact LeddarTech Support. 

Windows shutting down Disable and enable the Ethernet connection in Windows. 

If you still encounter any problem after reading the information above or if you have additional questions or 
concerns, contact LeddarTech support at support@leddartech.com. 

  

 

14 Note that some cameras (for example, iPhone cameras) have NIR filters on their main lens and will not work for 
this verification check. 

https://www.thorlabs.com/newgrouppage9.cfm?objectgroup_id=296
mailto:support@leddartech.com
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13. Maintenance 

Maintenance must be performed by a qualified maintenance technician without the need to recalibrate or 
dismantle the sensor from the vehicle. 

 

Disconnect the sensor to prevent unintended exposure to the laser beam. 

 

Manipulation 
Avoid touching the optical surfaces as fingerprints can permanently damage 
the optical coatings. 

Cleaning the 
windows 

• Blow off dust using compressed air. 

• Clean the windows with a soft cloth and mild soap. 

Do not pressure wash the sensor. 

For any questions or concerns on how to safely perform maintenance operations on the Leddar Pixell, 
contact LeddarTech support at support@leddartech.com. 

  

mailto:support@leddartech.com
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14. Disposal 

14.1. Product Contents 

Qty Description 

1 x Leddar Pixell 3D flash LiDAR 

1 x Power supply 

1 x Communication cable 

14.2. Product Materials 

Material Description 

Plastic Top cover, lens holder 

Metal Back of the sensor and heat sink, screws, and lens holder 

Wire components USB cable 

Glass Optical lens, receiver, and emitter windows 

PCB components Printed circuit boards inside the sensor 

14.3. Disassembly Instructions 

1. Remove all the screws on the back of the product. 

2. Remove the top cover. 

3. Remove all the screws holding the PCBs. 

4. Remove the lens inside the lens holder. 

Like any electronic equipment, the Leddar Pixell 3D flash LiDAR sensor contains environmentally 
unsustainable components. Dispose of in an environmentally responsible manner. 
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15. Technical Support 

For technical enquiries, contact LeddarTech technical support at support@leddartech.com to easily: 

• follow up on your requests 

• find quick answers to questions 

• get valuable updates 

Also, see the contact information at the end of this document. 

Please have all relevant information such as part numbers, serial numbers, and pictures to facilitate support. 

  

mailto:support@leddartech.com
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Appendix A. Configuring the Windows Firewall for 
Leddar Configuration 

1. Open the Control Panel window and select Windows Defender Firewall > Advanced settings. 

 

Fig. 70: Windows Defender Firewall window 

2. Select Inbound Rules, then double-click the LeddarHost Application line that blocks the UDP protocol. 

 

Fig. 71: Inbound Rules window 
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3. In the Action section, select Allow the connection option, then click OK to confirm. 

 

Fig. 72: LeddarHost Application Properties window 
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Appendix B. Static IP Configuration With Windows 7 
and Up 

Configuring the Network Static IP 

 

You will be disconnected from the Internet if you are not connected via other means. 

1. In Control Panel > Network and Internet > Network and Sharing Center, select Change adapter 
settings. 

 

Fig. 73: Change adapter settings 

2. In the Network Connections window, double-click Ethernet. 

 

Fig. 74: Ethernet network option 
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3. In the Ethernet Properties window, select Internet Protocol Version 4 (TCP/IPv4), then click 
Properties. 

 

Fig. 75: Ethernet Properties window 

4. Select Use the following IP address: and enter an IP address different from the sensor (for example, 
192.168.000.100) in the IP address: field. 

5. Enter the same subnet mask as the sensor (255.255.255.0 by default) in the Subnet mask: field. 

 

Fig. 76: IP address and Subnet mask fields 
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Appendix C. FibreCode Driver Installation Procedure 

Install the Broadway Network Driver provided by LeddarTech. 

 

Once the Wizard is open, follow the steps below to perform the installation. 

1. Click Next. 

 

2. Select the destination folder and click Install. 
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3. Once the installation of FibreCode is completed, click Next. 

 

4. Click Finish. 
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5. After the driver has been installed, click Yes to connect the device later. 

 

Verify that the driver is installed. 

6. Open the Control Panel window and select Network and Internet > Network and Sharing Center, 
then Change adapter settings. 

 

7. In the Network Connections windows, FibreCode FC602 Stick must be visible, as shown below. 
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If you do not see the FibreCode driver’s connection, right-click a connection and select 
Properties as explained below. 

1. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties. 

 

2. Select Use the following IP address: and enter an IP address different from the sensor (for example, 
192.168.000.100) in the IP address: field. 

3. Enter the same subnet mask as the sensor (255.255.255.0 by default) in the Subnet mask: field. 
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4. Click OK. 

Verify if the connection is working by using the Command Prompt (cmd): 

 

If the ping command does not work: 

a. Disconnect and reconnect the FibreCode USB stick, or 

b. Reboot Windows. 
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Appendix D. Communication Protocol 

Introduction 

This section presents the Leddar™ Ipv4 communication protocol used with the Leddar Pixell 3D flash LiDAR 
sensor. The protocol defines a set of communication rules that provide flexibility to support several product-
specific applications. 

This protocol also offers a set of generic communication requests that may be implemented partially or 
entirely depending on the product application and available hardware. 

Architecture 

The Leddar Pixell sensor uses the IPv4 protocol. Its IP address can be set automatically using a DHCP or 
static mode. It is divided between the three servers: identification, configuration, and data server requests. 

 
All ports are currently permanent and cannot be changed. 

Protocol Concepts 

Two major protocol concepts are used by the different servers. Both concepts involve a host and a sensor 
(which is independent of the client or server side). All data transmitted over the Ipv4 communication protocol 
is in little-endian (Intel) byte order. 

Definitions 

This section provides some common definitions used in those concepts (structures, constants, etc.). 

Request Header Structure 

All commands and data sent by the host minimally consist of a request header and may be followed by data 
(specific to the request). 

Table 32: Request header definition 

Item Size (bytes) Description 

Server protocol version 2 
Protocol version specific to each server (identification, 
configuration, data) 

Request code 2 
Used to uniquely identify the request type. Codes may be 
reused for different server links. Note that request code 0 is 
invalid. 

Request size 4 Size of the complete request: header plus data. 

Total 8 N/A 

 

 

The protocol version number is specific to each server, which means that protocol 
version 1 for a given server is not necessarily equivalent to protocol version 1 for another 
server. 
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Answer Header Structure 

Some servers specify that the sensor must respond to requests with an answer. In these cases, the answer 
minimally consists of an answer header and may be followed by data (specific to the request). 

Table 33: Answer header definition 

Item Size (bytes) Description 

Protocol version 2 
Protocol version specific to each server (identification, 
configuration, data) 

Answer code 2 
Answer code used to provide feedback on the request 
execution 

Answer size 4 Size of the complete request: header plus data 

Request code 2 Code of the request the answer applies to 

Reserved bytes 6 Reserved for alignment. Must be set at 0. 

Total 16 N/A 

Table 34: Answer codes 

Error Code Name Value Description 

OK 0x0000 Request properly handled 

ERROR 0x0001 General error 

FLASH_ERROR 0x0002 Error related to flash memory read or write 

HARDWARE_ERROR 0x0003 Error caused by abnormal hardware operation 

INVALID_DATA 0x0004 The request contained invalid data. 

INVALID_REQUEST 0x0005 The request is invalid (not defined/supported). 

PROTOCOL_ERROR 0x0006 Error in the protocol (invalid header or packet structure) 

UNSUPPORTED_PROTOCOL 0x0007 
Unsupported protocol version (as specified in the 
request header) 

LIMITED_MODE 0x0008 
The device is in a limited mode of operation and 
cannot service this request. 

OUTPUT_SIZE_TOO_LONG 0x0009 
The constructed response is larger than the maximum 
supported packet size. 

MISSING_ELEMENT 0x000A The request is missing a required element. 

Device-specific ≥0x0100 Application-specific codes 
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Element Header Structure 

Some protocol concepts described later make use of elements for transmitting data. Each element has a 
header, optionally followed by data. 

Table 35: Element header definition 

Item Size (bytes) Description 

Element code 2 Unique element identifier 

Element count 2 If the element data is an array, this is the length of the array. 

Element size 4 

Size of the element data. If the element data is an array, 
this is the size of a single element data entry. The full 
element data size is “element count” x “element size.” In all 
cases, the element size excludes the element header. 

Total 8 N/A 

Protocol Concept A – Structure-Based 

A first protocol concept used by some server protocol versions is described as follows: 

Host 

→ 

Sensor 

Request header 
(8 bytes) 

Request data 
Answer header 

(16 bytes) 
Answer data 

On the Leddar Pixell, only the identification server uses this protocol concept for reasons of backward 
compatibility of the sensor discovery system. 

In this protocol concept, the request and answer data are data structures associated with the request code. 
If the data structure needs to be changed over time, a new request code will be assigned. Another way of 
supporting new data structures is to rely on the data size specified in the request header. As long as new 
structures have different sizes, the right structure definition can be loaded. 

A major issue with this protocol version is the difficulty to update the data format associated with a given 
request code. Because of this, protocol concept B is used for the configuration and data servers. 

Protocol Concept B – Element Based 

This second protocol concept is now preferred in newer products because of its flexibility. It is described as 
follows: 

Host 

Request header 
(8 bytes) 

Element 1 header 
(8 bytes) 

Element 1 
data 

Element 2 header 
(8 bytes) 

Element 2 
data 

(…) 

 

Sensor 

Answer header 
(16 bytes) 

Element 1 header 
(8 bytes) 

Element 1 
data 

Element 2 header 
(8 bytes) 

Element 2 
data 

(…) 
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Both the request and answer headers have the same format as in concept A, which prevents compatibility 
breaks if a given server updates its protocol from concept A to concept B. 

In this concept, instead of having only one set of data accompanying a given request, it is possible to have 
several chunks of data, called “elements.” Each element has a header that identifies the element and its 
accompanying data size. The element data is optional. 

Here are general rules for this protocol concept: 

1. There can be any number of elements following a request or answer header. 

2. Usually, elements can be placed in any order in a request or answer. Therefore, if a given request needs 
three elements for correct execution, the sensor should never assume a given order for them, as the 
order could change from one firmware version to another one. If a specific order is required, it is 
specifically mentioned in the request’s description. 

3. The elements code is unique and usually has an associated data format that will never change over time. 
For example, if a given element is defined as being encoded on 2 bytes, it will not change over time. If it 
later needs to be increased to 4 bytes, a new code will usually be created instead. 

4. When the sensor receives an unsupported element with a request, it should ignore that element without 
throwing any error. This is an essential rule for allowing backward compatibility over time. 

For example, let’s assume a firmware version 1 that supports a given request requiring a given element 
specified to be on 2 bytes for correct execution. Now, let’s assume a newer firmware version 2 supports 
that same request but needs the element to be on 4 bytes instead of 2 bytes. In this case, a new element 
code would be created for that new element. 

Noteworthy here is that to support all firmware versions, the host would simply have to send the request 
with both elements present. In this case, the older firmware version would simply ignore the unsupported 
element, which is on 4 bytes, while the newer firmware version would ignore the unsupported element 
code that is on 2 bytes. 

5. Following the rule above, it is very important for the host or sensor to always accept all elements data 
loads (specified by the headers) even if it does not support any element for a given request in order to 
prevent communication protocol errors. 

Supported Server Protocols 

The Ipv4 communication protocol is based on the client-server model. For all communications with a 
Leddar™ device, the device is the server. The client is typically a program running on a computer or 
processing board used for the device configuration, control, and monitoring of the Leddar device. 

Currently, the Ipv4 communication protocol defines three different kinds of client-server links that fulfill three 
separate purposes: 

• Identification 

• Configuration (also for control and status monitoring) 

• Real-time data transfer 

Each client-server link is assigned a separate port. Note that TCP and UDP communication may be held 
simultaneously on the same port and separate client-server links. The packets are directed to the program 
according to the packet type (TCP or UDP). 

The identification server is connectionless (UDP), the configuration server is connection-oriented (TCP), 
while the real-time data transfer (data server) can be of either type (see section 10.5.3 on page 73). 

Identification Server 

The identification server’s purpose is to allow a client to broadcast requests to all sensors on the network. 
This is useful when the client wants to list all sensors present on a given network. 
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The identification server on the sensor side is constantly “listening” for identification requests from clients 
and answers those requests when they are received. 

Identification Server Protocol – Version 1 (0x0001) 

There is currently only one protocol version defined in Ipv4 for the identification server. For this version, 
protocol concept A described in “Configuration Server Requests” on page 105 applies with the following 
characteristics: 

1. This server uses a UDP socket. 

2. The sensor’s listening port is 48620. 

3. Unless otherwise specified for a given request, an answer is required. 

See “Identification Server Requests” on page 105 for a list of generic requests that may be implemented. 

Configuration Server 

The configuration server supports one (1) connection at a time. Once connected, it listens for requests and 
answers them when processed. 

Once connected to the configuration server, the client may send requests and wait for the answer before 
sending a new request. The configuration server cannot execute several requests in parallel. 

Also, the configuration server connection must be kept alive by the client by sending at least one request 
within 60 seconds after its last request. Typically, when the client has no special request to send, a 
CFG_REQUEST_ECHO or CFG_REQUEST_UPDATE request is sent for keeping the connection alive. 

Any protocol error will make the configuration server terminate the connection and listen for a new 
connection. 

Configuration Server Protocol – Version 2 (0x0002) 

This configuration server protocol is based on the protocol concept B described in “Data Server Requests” 
on page 105 with the following characteristics: 

1. This server uses a TCP connection type. 

2. The connection port is 48630 (by default). 

3. Unless otherwise specified for a given request, an answer is required. 

See “Configuration Server Requests” on page 105 for a list of generic requests supported by the Leddar 
Pixell. See “Communication Examples” for configuration modification examples. 

TCP Data Server 

The data server also supports one connection at a time and is used for real-time data transfer from the device 
to the client. 

Typically, the data to be sent to the client must be configured through a request to the configuration server 
(CFG_REQUEST_SET / ELEM_DATA_LEVEL). 

Data Server Protocol Version 3 (0x0003) 

This data server protocol is based on the protocol concept B described in “Data Server Requests” on 
page 105 with the following characteristics: 

1. This server uses a TCP connection type. 

2. The connection port is provided by the configuration server. 
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3. The host sends requests (LT_COMM_DATASRV_REQUEST_SEND_ECHOES and LT_COMM_ 
DATASRV_REQUEST_SEND_STATES). 

4. The sensor answers with the corresponding data. See Table 44 and Table 45. 

As previously mentioned, the packets transmitted by the data server will consist of a request header followed 
by a group of element headers and data. The request code identifies the type of data that is included in the 
packet. 

See “Data Server Requests” on page 105 for a list of generic requests that may be implemented. See 
“Communication Examples” for configuration modification examples. 

UDP Data Server 

The data server supports one client at a time and is used for real-time data transfer from the device to the 
client. 

Typically, the data to be sent to the client must be configured through a request to the configuration server 
(CFG_REQUEST_SET / ELEM_DATA_LEVEL). 

UDP Data Server Protocol Version 3 (0x0003) 

This data server protocol is based on the protocol concept B described in “Data Server Requests” on 
page 105 with the following characteristics: 

1. This server uses a UDP socket. 

2. The host’s listening port is provided by the configuration server. 

3. The sensor sends the corresponding data as soon as it is available. 

4. The format of the sent data is identical to a TCP data server answer (see Table 44 and Table 45). 

5. The sensor stops sending when the connection with the configuration server is terminated. 
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Identification Server Requests 

The following table defines generic requests that are available on a Leddar Pixell. 

For descriptions of constants and structures, see “Constant, Structure, and Data Type Definitions.” 

 

For all requests listed below, only relevant request and answer elements are provided. Depending on the actual product 
firmware version, there might be additional elements sent by the product. These additional elements should simply be 
ignored as they are present either for backward compatibility purposes or reserved for LeddarTech’s internal use. 

Table 36: Identification server requests 

Short Name 
Request 

Code 
Description 

Request 
Data 

Answer 

IDT_REQUEST_IDENTIFY 0x0011 

This request allows the identification of all devices present on the 
network. All devices supporting this request and listening on the 
network will answer with a structure including identification 
information. 

N/A 
struct IdtAnswerIdentifyLCAuto 

See Table 37. 

Configuration Server Requests 

The following table defines generic requests that are available on a Leddar Pixell. 

For descriptions of constants and structures, see “Constant, Structure, and Data Type Definitions.” 

 

Only relevant requests and elements are provided below. Depending on the actual product firmware version, there might be 
additional available requests or elements. For example, the CFG_REQUEST_GET_CONFIG request might return several 
additional elements not documented below. These additional requests or elements should simply be ignored as they are 
present either for backward compatibility purposes or reserved for LeddarTech’s internal use. You should never attempt to 
send undocumented requests or elements to the device. Trying to do so may cause unpredictable device behavior or even 
permanent failure. 



 

106 | 127 © 2021 LeddarTech Inc. 

Table 37: Configuration server requests 

Short Name 
Request 

Code 
Description Request Element Answer Element 

CFG_REQUEST_GET 0x0002 

This is a generic request for retrieving vari-
ous data from the device. The server will 
return all elements data requested in 
ELEM_LIST. 

ELEM_LIST = 0x0070 See Table 46 and Table 47. 

CFG_REQUEST_SET 0x0003 

This is a generic request for setting various 
data in the device. The server will set a 
value for all elements provided with the 
request. 

Any value set through this request is usu-
ally lost on a device reset, with the excep-
tions below. 

ELEM_DATA_LEVEL=0x106E See Table 46. 

CFG_REQUEST_ECHO 0x0006 
This is an empty request. It is used to keep 
alive the connection with the configuration 
server. 

N/A N/A 

CFG_REQUEST_UPDATE 0x0008 
This request returns the device status. It 
can be used instead of CFG_REQUEST_ 
ECHO to keep the connection alive. 

N/A See Table 43. 

CFG_REQUEST_GET_DEV
ICE_INFO 

0x7000 
This request returns all device information 
data kept in non-volatile memory. 

N/A See Table 47. 

CFG_REQUEST_GET_CALIB 0x7002 
This request returns the channel, azimuth, 
and elevation angles for calibration. 

LT_COMM_ID_AUTO_CHANNEL_
ANGLES_AZIMUT=0x2580 

LT_COMM_ID_AUTO_CHANNEL_
ANGLES_ELEVATION=0x2581 

See Table 48. 

CFG_REQUEST_GET_CON
FIG 

0x7006 
This request returns the shadow copy of all 
configuration data kept in non-volatile 
memory. 

N/A See Table 46. 
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Short Name 
Request 

Code 
Description Request Element Answer Element 

CFG_REQUEST_SET_CON
FIG 

0x7007 

This request sets the shadow copy of some 
or all configuration data kept in non-volatile 
memory. New data is not written to non-
volatile memory until CFG_REQUEST_ 
WRITE_CONFIG is requested. 

Most of the configuration data enter into 
force as soon as their values are set in the 
shadow copy, with the exceptions below. 

Elements that configure the network pa-
rameters (ELEM_IP_MODE, ELEM_IP_ 
ADDRESS, ELEM_IP_GATEWAY, and 
ELEM_IP_NETMASK) do not enter into 
force at this time. 

Same as answer elements of 
CFG_REQUEST_GET_CONFIG. 

Not all elements have to be present; 
only those that need to be modified 
must be present. 

N/A 

CFG_REQUEST_WRITE_C
ONFIG 

0x7008 
This request writes configuration data cur-
rently stored in the shadow copy to non-
volatile memory. 

N/A N/A 

CFG_REQUEST_RESTORE
_CONFIG 

0x7009 
This request restores the shadow copy with 
configuration data currently stored in non-
volatile memory. 

N/A N/A 

CFG_REQUEST_RESET_C
ONFIG 

0x7011 

This request forces all device configuration 
data to be reset to their default factory 
values in the shadow copy and the non-
volatile memory. 

N/A N/A 

Data Server Requests 

The following table defines generic requests that are available on a Leddar Pixell. 

For descriptions of constants and structures, see “Constant, Structure, and Data Type Definitions.” 

 

For all requests listed below, only relevant request and answer elements are provided. Depending on the actual product 
firmware version, there might be additional elements sent by the product. These additional elements should simply be 
ignored as they are present either for backward compatibility purposes or reserved for LeddarTech’s internal use. 
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Table 38: Data server requests 

Short Name 
Request 

Code 
Description 

Request 
Element 

Answer Element 

DATA_REQUEST_SEND_E
CHOES 

0x0020 
This request asks for the last detection 
echoes. 

N/A 

See Table 44. 

LT_COMM_ID_FRAME_ID 

LT_COMM_ID_TIMESTAMP 

LT_COMM_ID_AUTO_TIMESTAMP64 

LT_COMM_ID_AUTO_NUMBER_DATA_SENT 

LT_COMM_ID_AUTO_ECHOES_AMPLITUDE 

LT_COMM_ID_AUTO_ECHOES_DISTANCE 

LT_COMM_ID_AUTO_ECHOES_CHANNEL_INDEX 

LT_COMM_ID_AUTO_ECHOES_VALID 

LT_COMM_ID_STATUS 

DATA_REQUEST_SEND_S
TATES 

0x0002 This request asks for the last states. N/A 

See Table 45. 

LT_COMM_ID_TIMESTAMP 

LT_COMM_ID_SYS_TEMP 

LT_COMM_ID_CPU_LOAD_V2 

Constant, Structure, and Data Type Definitions 

This section provides element, constant, structure, and data type definitions referenced in this document. 

Constants 

Table 39: Constant definitions 

Constant Name Value 

LT_COMM_DEVICE_NAME_LENGTH 64 

LT_COMM_PART_NUMBER_LENGTH 16 

LT_COMM_SERIAL_NUMBER_LENGTH 32 

LT_COMM_FIRMWARE_VERSION_LENGTH 32 

LT_COMM_ALERT_MSG_LENGTH 32 
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Structures 

Table 40: struct IdtAnswerIdentifyLCAuto 

Field Name Data Type Description 

mHeader 
LtComLeddarTechPublic::sLtCommAnsw

erHeader 
Structure header - 16 bytes 

mMacAddress struct MacAddress. See Table 42. See Table 42. 

mDeviceType uint16_t Device type 

mPartNumber[LT_COMM_PART_NUMBER_LENGTH] char[16] Hardware part number 

mSoftPartNumber[LT_COMM_PART_NUMBER_LENGTH] char[16] Software part number 

mSerialNumber[LT_COMM_SERIAL_NUMBER_LENGTH] char[32] Serial number 

mFirmwareVersion[LT_COMM_FIRMWARE_VERSION_LENGTH] char[32] Firmware version 

mDeviceName[LT_COMM_DEVICE_NAME_LENGTH] char[64] Device name – UTF-8 encoded 

mSensorState uint32_t Sensor state 

mDataPort uint16_t Port number to reach to get Leddar data 

Table 41: struct IpAddress 

Field Name Data Type Description 

ADDRESS uint8_t[4] IP address 

RESERVED uint8_t[4] Reserved 

Table 42: struct MacAddress 

Field Name Data Type Description 

ADDRESS uint8_t[6] MAC address 

RESERVED uint8_t[4] Reserved 
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Table 43: struct sLtCommElementAlert 

Field Name Data Type Description 

CODE uint64_t Alert code 

TIMESTAMP uint64_t 
Alert timestamp in seconds since 00:00:00 UTC 
on January 1, 1970 

MESSAGE char[LT_COMM_ALERT_MSG_LENGTH] Alert default message 

CUSTOM_MESSAGE char[LT_COMM_ALERT_MSG_LENGTH] Alert custom message 

UID uint8_t Alert unique ID 

PADDING uint8_t[15] Reserved 

Elements 

The following tables define elements referenced in this document. If the element is an array (element count different from 1), the element data type 
column provides the data type of a single entry in the array. See section 2 on page 17 for more details. 

Table 44: Detection structure (sends echoes) 

Element Name 
Element 

Code 
Element Data 

Type 
Description 

LT_COMM_ID_FRAME_ID 0x1092 uint64_t Unique identifier number for the current detections 

LT_COMM_ID_TIMESTAMP 0x1050 uint32_t 
Elapsed time in milliseconds (ms) since unit power-up when the detections 
occurred 

LT_COMM_ID_AUTO_TIMESTAMP64 0x2721 uint64_t 
Elapsed time in µs since UNIX Epoch time (00:00:00 on January 1, 1970) 
when the detections occurred. 

LT_COMM_ID_AUTO_NUMBER_DATA_SENT 0x2501 uint32_t[2] 
Index of the first detection sent and the number of detections sent by the 
data server. The first channel index is number 99. 

LT_COMM_ID_AUTO_ECHOES_DISTANCE 0x2703 uint32_t Echo distance 

LT_COMM_ID_AUTO_ECHOES_CHANNEL_INDEX 0x2700 uint16_t Index of the echo channel for 3D sensors 

LT_COMM_ID_AUTO_ECHOES_AMPLITUDE 0x2702 uint32_t Echo amplitude 

LT_COMM_ID_AUTO_ECHOES_VALID 0x2701 uint16_t Bit field with various information 

LT_COMM_ID_AUTO_ECHOES_TIMESTAMP_UTC 0x2704 uint64_t 
Elapsed time in µs since UNIX Epoch time (00:00:00 on January 1, 1970) 
when each waveform occurred 

LT_COMM_ID_STATUS 0x0004 uint8_t Status of the ongoing command 
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Table 45: State structure (sends states) 

Element Name 
Element 

Code 
Element Data 

Type 
Description 

LT_COMM_ID_TIMESTAMP 0x1050 uint_32 Timestamp of related data in ms 

LT_COMM_ID_CPU_LOAD_V2 0x104A float CPU load in percentage 

LT_COMM_ID_SYS_TEMP 0x1011 LtFixedPoint 
System (laser) temperature in temperature scale (divide value by 
temperature scale). A raw value of 0x7FFFFFFF means that there is no 
available temperature. 

LT_COMM_ID_CPU_TEMP 0x1012 LtFixedPoint 
CPU temperature in temperature scale (divide value by temperature scale). 
A raw value of 0x7FFFFFFF means that there is no available temperature. 

LT_COMM_ID_AUTO_PMIC_TEMP 0x2720 LtFixedPoint 
PMIC temperature in temperature scale (divide value by temperature 
scale). A raw value of 0x7FFFFFFF means that there is no available 
temperature. 

Table 46: Configuration elements 

Element Name 
Element 

Code 
Element Data 

Type 
Description 

LT_COMM_ID_DEVICE_NAME 0x22 char The device name is defined as byte. 

LT_COMM_ID_IPV4_IP_ADDRESS 0xF01 struct IpAddress Ethernet address (IPv4) 

LT_COMM_ID_AUTO_SYSTEM_TIME 0x116B uint8_t Set system time. 64-bit integer representing microseconds since Epoch UTC 

LT_COMM_ID_AUTO_TIME_SYNC_METHOD 0x116C uint8_t Time synchronization method to be used: 0 = none, 1 = PTP, 2 = PPS 

Table 47: Constant elements 

Element Name 
Element 

Code 
Element Data Type Description 

LT_COMM_ID_HW_PART_NUMBER 0xF03 
char 

[LT_COMM_PART_NUMBER_LENGTH] 
Hardware part number 

LT_COMM_ID_SERIAL_NUMBER 0xF00 
char 

[LT_COMM_SERIAL_NUMBER_LENGTH] 
Device serial number 

LT_COMM_ID_IPV4_ETHERNET_ADDRESS 0x610038 struct MacAddress MAC address. See Table 42. 

LT_COMM_ID_TEMPERATURE_SCALE 0x1017 uint32 Temperature scale for fixed-point value 
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Element Name 
Element 

Code 
Element Data Type Description 

LT_COMM_ID_DISTANCE_SCALE 0x1003 uint32 Distance scale for fixed-point value 

LT_COMM_ID_AMPLITUDE_SCALE 0x1002 uint32 Amplitude scale for fixed-point value 

LT_COMM_ID_FILTERED_SCALE 0x1004 uint32 Filtered scale for fixed-point value 

LT_COMM_ID_AUTO_CHANNEL_NUMBER_HORIZ
ONTAL 

0x1020 uint16 Number of horizontal channels 

LT_COMM_ID_AUTO_CHANNEL_NUMBER_VERTI
CAL 

0x1021 uint16 Number of vertical channels 

LT_COMM_ID_MAX_ECHOES_PER_CHANNEL 0x1024 uint16_t Max. number of echoes on the same channel 

LT_COMM_ID_HFOV 0x01F0 float Sensor horizontal FoV 

LT_COMM_ID_VFOV 0x01F1 float Sensor vertical FoV 

LT_COMM_ID_SOFTWARE_PART_NUMBER 0x10FC char[16] Software part number 

LT_COMM_ID_FIRMWARE_VERSION_V2 0x10EF uint16_t[4] Full firmware version: major.minor.release.build. 

LT_COMM_ID_FPGA_VERSION 0x610016 
char 

[LT_COMM_FPGA_VERSION_LENGTH] 
FPGA version 

LT_COMM_ID_DEVICE_TYPE 0x610018 uint16_t See PROTOCOL_IDT_DEVICE_TYPE_... 

LT_COMM_ID_ECHO_AMPLITUDE_MAX 0x108C uint32_t Max. possible echo amplitude value 

Table 48: Calibration elements 

Element Name 
Element 

Code 
Element Data Type Description 

LT_COMM_ID_AUTO_CHANNEL_ANGLES_AZIMUT 0x2580 LtFloat[NumberOfChannels] 
Elevation angles in degrees from the center of 
the FoV to the center of each channel 

LT_COMM_ID_AUTO_CHANNEL_ANGLES_ELEVA
TION 

0x2581 LtFloat[NumberOfChannels] 
Azimuth angles in degrees from the center of the 
FoV to the center of each channel 
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Communication Examples 

Example 1: Finding Online Sensors With the Identification Server 

Host: Broadcast a request to the sensor identification server. The host broadcasts this request through a UDP connection type on port 48620. 

 

Fig. 77: Broadcast request to find online sensors 

Table 49: Identification request packet 

Request header 

Item Value 

Server protocol version Identification server protocol – Version 1 = 0x0001 

Request code IDT_REQUEST_IP_CONFIG = 0x0011 

Request size 8 bytes = 0x00000008 

Sensors: All online sensors that receive the broadcast request send an identification answer packet to the host. The host will receive a stack of 
identification answers and must parse all sensors information for identification. 
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Fig. 78: Available sensor answers by an identification answer packet 

Refer to “Configuration Server Protocol Version 2” and Table 39. 
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Table 50: Identification answer packet 

 Item Value 
A

n
s
w

e
r 

h
e

a
d

e
r Protocol version Identification server protocol – Version 1 = 0x0001 

Answer code OK = 0x0000 

Answer size 264 bytes = 0x00000108 

Request code IDT_REQUEST_IP_CONFIG = 0x0011 

Reserved bytes 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 

A
n

s
w

e
r 

d
a
ta

 

mMacAddress 8 bytes structure. See Table 42. 

mDeviceType 2 bytes 

mPartNumber[LT_COMM_PART_NUMBER_LENGTH] 16 bytes of hardware part number string 

mSoftPartNumber[LT_COMM_PART_NUMBER_LENGTH] 16 bytes of firmware part number string 

mSerialNumber[LT_COMM_SERIAL_NUMBER_LENGTH] 32 bytes of serial number string 

mFirmwareVersion[LT_COMM_FIRMWARE_VERSION_LENGTH] 32 bytes of firmware version number string 

mDeviceName[LT_COMM_DEVICE_NAME_LENGTH] 64 bytes (32 words) of UTF-8 encoded 

mSensorState 4 bytes 

mDataPort 2 bytes 

  



 

116 | 127 © 2021 LeddarTech Inc. 

Example 2: Get Detections From a Connected Sensor 

Before receiving detections from the sensor, unlock the data server to send detections. 

The host sends a “Set sensor data level” request to the connected sensor via the configuration server to get detections data. The host sends this request 
to the connected sensor through a TCP connection type to the configuration server. 

 

Fig. 79: Host sends a request to unlock data server 

Table 51: Set sensor data level request packet 

 Item Value 

Request header 

Server protocol version Configuration server protocol – Version 2 = 0x0002 

Request code CFG_REQUEST_SET = 0x0003 

Request size 20 bytes = 0x00000014 

Element header 

Element code ELEM_DATA_LEVEL = 0x106E 

Element count 1 element = 0x0001 

Element size 4 bytes = 0x00000004 

Element data ELEM_DATA_LEVEL field Activate segment raw detections = 0x00000010 

Sensor 

Host Configuration 
request packet 

Configuration 
server (TCP) 

Data server (TCP 
or UDP) 

Identification 
server (TCP) 
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Fig. 80: Connected sensor sends a confirmation answer back to host 

Table 52: Set sensor data level answer packet 

 Item Value 

A
n

s
w

e
r 

h
e

a
d

e
r 

Protocol version Configuration server protocol – Version 2 = 0x0002 

Answer code OK = 0x0000 

Answer size 16 bytes = 0x00000010 

Request code CFG_REQUEST_SET = 0x0003 

Reserved bytes 

0x00 

0x00 

0x00 

0x00 

0x00 

0x00 

Once the step above is completed, the host can receive detection packets from the connected sensor data server. To read detections according to the 
refresh rate, the host needs to send data requests periodically to read detections. 

  

Host 
Configuration 
answer packet 

  

Sensor 

Configuration 
server (TCP) 

Data server (TCP 
or UDP) 

Identification 
server (TCP) 
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Fig. 81: Loop to get detection data periodically 

Table 53: Request data request 

 Item Value 

Request header 

Server protocol version Data server protocol - Version 3 = 0x0003 

Request code DATA_REQUEST_SEND_ECHOES = 0x0020 

Request size 8 bytes = 0x0008 

Element header 

Element code ELEM_DATA_LEVEL = 0x106E 

Element count 1 element = 0x0001 

Element size 4 bytes = 0x00000004 

Element data ELEM_DATA_LEVEL field Activate segment raw detections = 0x00000010 

  

Data 
(states/echoes) 

Host 
Request data 

 

Sensor 

Configuration 
server 

Data server 

Identification server 

Loop 
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Table 54: Data detection packet for n detections 

 Item Value 

Answer header 

Server protocol version Data server protocol version 3 = 0x0003 

Request code LT_COMM_DATASRV_REQUEST_SEND_ECHOES = 0x0020 

Request size 212 bytes = 0x000000D4 

Element header 

Element code LT_COMM_ID_FRAME_ID = 0x1092 

Element count 1 element = 0x0001 

Element size 8 bytes = 0x00000008 

Element data LT_COMM_ID_FRAME_ID field Frame unique identification number = 0x0000000000000000 

Element header 

Element code LT_COMM_ID_TIMESTAMP = 0x1050 

Element count 1 element = 0x0001 

Element size 4 bytes = 0x00000004 

Element data LT_COMM_ID_TIMESTAMP field Acquisition timestamp = 0x00000000 

Element header 

Element code LT_COMM_ID_AUTO_TIMESTAMP64 = 0x2721 

Element count 1 element = 0x0001 

Element size 8 bytes = 0x00000008 

Element data LT_COMM_ID_AUTO_TIMESTAMP64 field Acquisition timestamp = 0x0000000000000000 

Element header 

Element code LT_COMM_ID_AUTO_NUMBER_DATA_SENT = 0x2501 

Element count 2 elements 

Element size 4 bytes per element = 0x00000004 

Element data LT_COMM_ID_AUTO_NUMBER_DATA_SENT field 
Index of the first detection 
n - number of detections sent by the data server 

Element header 

Element code LT_COMM_ID_AUTO_ECHOES_DISTANCE = 0x2703 

Element count n elements 

Element size 4 bytes per element = 0x00000004 

Element data LT_COMM_ID_AUTO_ECHOES_DISTANCE field 
Array of n distances words (4 bytes word) scaled at ELEM_DISTANCE_SCALE. See 
Example 3. 

Element header 

Element code LT_COMM_ID_AUTO_ECHOES_CHANNEL_INDEX= 0x2700 

Element count n elements 

Element size 1 byte per element = 0x00000001 

Element data ELEM_ECHOES_CHANNEL_INDEX field Array of n segments indexes bytes. See section 2 on page 17. 

Element header 

Element code LT_COMM_ID_AUTO_ECHOES_AMPLITUDE = 0x2702 

Element count n elements 

Element size 4 bytes per element = 0x00000004 

Element data LT_COMM_ID_AUTO_ECHOES_AMPLITUDE field 
Array of n amplitudes words (4 bytes word) scaled at LT_COMM_ID_FILTERED_SCALE. 
See Example 3. 

Element header 

Element code LT_COMM_ID_AUTO_ECHOES_VALID = 0x0004 

Element count n elements 

Element size 1 byte per element = 0x00000001 

Element data LT_COMM_ID_AUTO_ECHOES_VALID field Array of n flags bytes 
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 Item Value 

Element header 

Element code LT_COMM_ID_AUTO_ECHOES_TIMESTAMP64 = 0x2704 

Element count n elements 

Element size 8 bytes per element = 0x00000008 

Element data LT_COMM_ID_AUTO_ECHOES_TIMESTAMP64 field Array of n detection timestamps 

Element header 

Element code LT_COMM_ID_STATUS = 0x2701 

Element count n elements 

Element size 1 byte per element = 0x00000001 

Element data LT_COMM_ID_STATUS field 0x01 

For detailed information about detection, see section 2 on page 17. 

  



 

54A0049_7.0_EN / Leddar Pixell – User Guide 121 | 127 

Example 3: Get Constant Values From a Connected Sensor 

In the following example, we want to know LT_COMM_ID_FILTERED_SCALE and LT_COMM_ID_DISTANCE_SCALE constant values to interpret 
incoming detection data. Requests sent by host and sensor answers will be described below. 

The host sends a request to the connected sensor via the configuration server to get a list of constant values. 

 

Fig. 82: Host sends a request to the configuration server 

Table 55: Get elements list 

 Item Value 

Request header 

Server protocol version Configuration server protocol – Version 2 = 0x0002 

Request code CFG_REQUEST_GET = 0x0002 

Request size 20 bytes = 0x00000014 

Element header 

Element code ELEM_LIST = 0x0070 

Element count 2 elements = 0x0002 

Element size 2 bytes per element = 0x00000002 

Element data List of elements 
0x1004 (LT_COMM_ID_FILTERED_SCALE) 

0x1003 (LT_COMM_ID_DISTANCE_SCALE) 

  

Host 
Configuration 

request packet 

  

Sensor 

Configuration 
server 

Data server 

Identification 
server 
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The connected sensor sends a confirmation answer to the host. 

 
Fig. 83: Confirmation sent to host 

Table 56: Constant values answer packet 

 Item Value 

Answer header 

Protocol version Configuration server protocol – Version 2 = 0x0002 

Answer code OK = 0x0000 

Answer size 40 bytes = 0x00000028 

Request code CFG_REQUEST_GET = 0x0002 

Reserved bytes 

0x00 

0x00 
0x00 
0x00 

0x00 

0x00 

Element header 

Element code LT_COMM_ID_FILTERED_SCALE = 0x1004 

Element count 1 element = 0x0001 

Element size 4 bytes = 0x00000002 

Element data LT_COMM_ID_FILTERED_SCALE 0x00200000 

Element header 

Element code LT_COMM_ID_DISTANCE_SCALE = 0x1003 

Element count 1 element = 0x0001 

Element size 4 bytes = 0x00000002 

Element data LT_COMM_ID_DISTANCE_SCALE 0x00010000 

 

Host Configuration 
answer packet 

  

 

Sensor 

Configuration 
server 

Data server 

Identification 
server 
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Appendix E. Converting Leddar Pixell Flash LiDAR 
Sensor’s Angular Data and Distance Reporting and 
Mapping to Real-World Coordinates Protocol 

Each Leddar Pixell™ Cocoon LiDAR sensor is thoroughly calibrated on a dedicated production bench both 
in angular positions and in absolute distance using various traceable targets and carefully selected scenes 
to reach the required accuracy with precise angular mapping. The sensor comes with accessible internal 
data providing the angular mapping done in production. This section explains how to transform this basic 
internal mapping to precise Cartesian coordinates to map the “real world” as seen by the Leddar Pixell. 

Mapping the Space Around the Platform with Sensor’s Echoes 

The Leddar Pixell sensor reports echoes using a distance and segment number where the detection has 
occurred for each echo in the list. The distance is a direct line-of-sight distance between the object detected 
and the sensor. To position this echo in space around the platform on which the sensor is installed, different 
ways of mapping the space could be used, as shown in Fig. 84 below. 

 

Fig. 84: Coordinates with two well-known reference systems 

The red dot could be located in space using either Cartesian coordinates {x, y, z} or spherical coordinates 
{R, θ, ϕ}. The following equation set could be used to move from one to the other. The reference point of the 
Leddar Pixell sensor is the origin 0, 0, 0, with the x-axis pointing forward and the y-axis pointing to the left. 

x = Rcosθ cosϕ 
Equation 1: Coordinate transformation for x 

y = Rsinθ cosϕ 
Equation 2: Coordinate transformation for y 

z = Rsinϕ 
Equation 3: Coordinate transformation for z 
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Mechanical Positions of the Reference Point for the Leddar Pixell 

The Leddar Pixell sensor is calibrated in production relative to a preferred mechanical reference point rather 
than the mounting holes in order to reduce variability (Fig. 85 and Fig. 86). 

 

Fig. 85: Top view of the sensor showing the reference point 

 

Fig. 86: Side view of the sensor showing the reference point 
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Information Returned From the Leddar Pixell 

The Leddar Pixell sensor returns echoes tagged with a global segment number (0-767) and a distance (see 
section 4.3 on page 28). For each segment number, there is a general angular mapping stored in the sensor 
based on production data for a target at maximum range. A transformation should be applied to find the 
position (x, y, z) in space according to the distance of the echoes and the segment number. 

Azimuth u and elevation v angles for each segment car be read once at start-up and used in the conversion 
equations (see section “Constant, Structure, and Data Type Definitions.”) 

 

Diagram showing the three sub-fields of view 

From the segment number (0-767) of an echo reported by the sensor, its field of view of origin can be found 
using the mathematical function modulo with 96 as argument (remainder of the division by 96). A result from 
this function between 0-31 points to the left field, between 32-63 points to the central field, and between 64-
95 to the right field of view. This sorting is needed to select the right constants in the table below. For 
example, a global segment number of 505 represents local segment 25 in the left field of view (remainder of 
505 divided by 96). 

Mapping Using Opto-Mechanical Parameters of the Leddar Pixell 

The following table lists translation values to transform the relative position of the internal sensors toward 
the external mechanical reference point. 

Table 57: Opto-mechanical constants for each field of view 
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Next, the field of view specific distance Ru can be evaluated using the reported distance R' from the echo, 

the Bx, By, and u, v derived from the segment number of the echo of interest. 

Ru = R' - Bx sin u cos v - By cos u cos v + Dsin v 
Equation 4: Ru calculation 

Transformation to Cartesian Coordinates 

From the corrected distance Ru based on actual distance of echo, fixed opto-mechanical parameters Bx, By, 

and D and internal angles u, v stored in the sensor specific for each segment, the Cartesian coordinates 

can be calculated. 

x = By + Rucos u cos v 
Equation 5: Transformations to Cartesian x 

y = Bx+ Rusin u cos v 
Equation 6: Transformations to Cartesian y 

z = - Ru sin v 
Equation 7: Transformations to Cartesian z 

Those transformations should be applied to all echoes reported by the sensor. 

 

The way the angle v is reported by the sensor requires a minus sign in the z-axis 
transformation equation to conform to the universal x,y,z axis definition. 

Contact LeddarTech support for sample Python code. 
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