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Document Conventions 
This document uses the following conventions. 

 

Name of Menu > 
Name of Window 

Shows the access path to menus under each section of Leddar™ Configuration.  

Arial bold The name of buttons, menus, and dialog boxes are presented in bold. 

 

Notes contain helpful suggestion and references to information included within 
this user guide. 

 

Warnings refers to a warning or an important information to follow. 
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 Label Explanation and Safety Information  

 

Table 1: Explanation of Labels on the Sensor 

Label 
Location on 
the Sensor 

Description 

Model 
  

Serial Number 
 

On the back of 
the sensor 

Part number (PN) starting with 
75A and Serial Number (SN).  
 
This information is useful when 
contacting LeddarTech support. 

 

1.1. Regulatory Compliance  

Table 2: Regulatory Compliance 

Ingress Protection IP67 

Ocular Safety IEC 62471 2006 criteria: Exempt lamp classification 

FCC 

Part 15, Subpart B, Class A 
 
This device complies with part 15 of the FCC Rules. Operation is 
subject to the following two conditions: (1) This device may not cause 
harmful interference, and (2) this device must accept any interference 
received, including interference that may cause undesired operation. 

ICES-003 
Class A 
This Class A digital apparatus complies with Canadian ICES-003. 

CE Yes 
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 Introduction 

2.1. Definitions 
 

Table 3: Definitions 

Term Definition 

Active grid 

Sensing area of a sensor. The active grid measures the range of detected 
objects and must be centered on the zones that need to be monitored. It is 
represented by an overlay of the live video window (Traffic configuration 
only).  

Amplitude Measure of the signal strength. 

AR Anti-reflective 

Area of interest The area that needs to be monitored. 

Camera 
The camera in the sensor that provides video and images used for viewing 
the detection area (area of interest). 

Channel Synonym of “segment”. See the definition of the word segment. 

Crosstalk 
Phenomenon by which a signal transmitted in one segment creates an 
undesired effect in an adjacent segment. 

Depth of the 
detection zone 

Distance along the y axis (road) within which the sensor will detect a 
vehicle. 

Detection 

Object detected in one segment. 

Detections include at least the following data: Segment identification, 
distance measurement, and the intensity of the backscattered light of the 
object. 

FOV Field of View. 

Opening angle The angle of the detection zone. 

Time of Flight 
Refer to section 2.2 Underlying Principles and LiDAR Fundamentals for 
more details. 

Segment 
A segment is defined by a horizontal index in the FOV. Synonym of 
“channel”. 
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2.2. Underlying Principles and LiDAR Fundamentals 

Created by LeddarTechTM Inc., Leddar™ (light-emitting diode detection and ranging) is a unique 

sensing technology based on LED illumination (infrared spectrum) and the time-of-flight of light 

principle. The LED emitters illuminate the area of interest and the multi-segment sensor receiver 

collects the backscattered light and measures the time taken for the light to return to the sensor.  

A photodetector array is used and provides multiple detection and ranging segments. Full-

waveform analysis enables detection and distance measurement of multiple objects in each 

segment as illustrated in Figure 1, provided that foreground objects do not fully obscure objects 

behind them. 

 

Figure 1: Time of Flight 
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2.3. Key Factors for Best Sensor Performance 

The following factors are important to consider for obtaining the best operating performance. 

 

Table 4: Key Factors for Best Performance 

Key Factors Description 

Size of the target 
The larger the target, the higher is the range. 

The smaller the target, the lower is the range. 

Reflectivity of the target 
With a high surface reflectivity, the range is higher. 

With a low surface reflectivity, the range is lower. 

Position of the target within 

the FOV 

With centered channels (segments), the range is higher. 

With outer channels (segments), the range is lower. 
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 Description 

This user guide is intended to provide information on and describe the LeddarTM T16 Solid-State 

LiDAR Traffic Sensor (hereinafter referred to as “Leddar T16”) for developers, integrators and/or 

engineers.  

The LeddarTM T16 Traffic Sensor is a 2D solid-state LiDAR that is specifically designed for traffic 

management systems from city to highway applications. Packaged in a weatherproof housing, the 

Leddar T16 offers cost efficient and highly accurate detection for various Intelligent Transportation 

System (ITS) applications, such as electronic tolling, traffic monitoring and traffic law enforcement. 

At the heart of the sensor resides the patented Leddar digital signal processing technology, which 

provides superior detection, location and measurement capabilities for all types of traffic, including 

vehicles, pedestrians and cyclists. The Leddar T16 measures both the distance and angular 

positioning for each detected target. Its collected data enables functionalities, such as vehicle 

profiling, speed measurement, and traffic data collection.  

The Leddar T16’s flash illumination emitted by its LED sources covers the sensor’s complete field 

of view. Capturing the return echoes of these diffused light pulses through 16 independent active 

detection elements at a high acquisition rate, the Leddar T16 Traffic Sensor continuously provides 

rapid and accurate detection and ranging in the entire beam without any moving mechanical parts. 

The returned signals are digitized and processed through innovative algorithms, allowing the 

reliable detection and measurement of a wide range of objects under the most challenging 

environmental conditions, such as rain, snow and fog. 

Keep this user guide for future reference.  

3.1. Equipment Designation and Description 

 Table 5: Equipment Designation 

 

 

This document refers to all models described below unless otherwise mentioned. 

 

 

  

 

Family Name Leddar T16 

Model Solid-State LiDAR Traffic Sensor 

Configurations  Traffic and Tolling Sensors 
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Table 6: Leddar T16 Sensor Traffic and Tolling Configurations 

 

Leddar T16 
Traffic 

Options 

9° (75A0030-1) 

• Pan and Tilt 

• Camera 

• Enclosure 
sunshade 

19° (75A0021-1) 

26° (75A0022-1) 

36° (75A0023-1) 

 

Leddar T16 
Tolling 

Options 

9° (75A0025-1) • AR coated window 

• Lens shield 

• No enclosure 
sunshade 

• No pan and tilt 

• No camera 

19° (75A0026-1) 

26° (75A0027-1) 

36° (75A0028-1) 

48° (75A0029-1) 

 

The Leddar T16 Sensor comes with the following software and accessories.  

• LeddarTM Configuration and Software Development Kit (SDK) 

• Ethernet connector kit. Refer to Appendix B for more details. 
 

Table 7: Ethernet Cable Description 

Ethernet Connector Kit Description 

 

Cat5e RJ45 shielded connector (with load bars), 
IP67 industrial modular connector and yellow strain 
relief boot. 

  



 

Page 19 of 109  Leddar T16 – User Guide 

3.1.1. Key Components 

Receiver Emitter 

• Receiver Lens 
 

• Light Emitter 

• Diffuser lens 

 
 
Figure 2, Figure 3, and Figure 4 below show the Leddar T16 Sensor key components. 
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Figure 2: Front View of the Leddar T16 Traffic Sensor 

 

 

 

Figure 3: Front View of the Leddar T16 Tolling Sensor 

LED emitters (8) 

Receiver Camera 

Enclosure

sunshade 

LED emitters (8) 

Receiver 
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Figure 4: Back View of the Leddar T16 Traffic Sensor 

 

 

 

Figure 5: Back View of the Leddar T16 Tolling Sensor 

 

 * Brass inserts (two on the back and one on each side of the Tolling Sensor) serve to fix 

the optional enclosure sunshade only.  

Ethernet 

connector 

Ethernet 

connector 

Protective 

vent 

Enclosure 

sunshade 

Brass 

inserts (4)* 
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3.1.2. Distance Measurement 

The red line indicates the distance that is measured from the screw located on the sides of the 

Leddar T16 Sensor as shown in Figure 6. 

 

 

Figure 6: Distance Measurement with the Leddar T16 Sensor 

 

The blue dashed lines illustrate one segment and the solid line indicates the distance measured by 

the sensor in that segment. 
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 Specifications 

4.1. General Characteristics 

 

Table 8: Leddar T16 Characteristics 

 

Table 9: Test Conditions and Detection Range (Traffic) 

 
1. Retro-reflector reference target corresponds to a 5 cm x 7 cm band of retro-reflective tape. 
2. White reference target corresponds to a 20 cm x 25 cm Kodak Greycard with 90% reflectivity. 
3. Gray reference target corresponds to a 20 cm x 25 cm Kodak Greycard with 18% reflectivity. 

 

Number of Segments 16 

Horizontal x Vertical FOV 

48° x 7.5°  

36° x 5.9° 

26° x 4.2°  

19° x 3.0°  

9° x 1.6° 

Resolution 3.00°, 2.25°, 1.63°, 1.19°, 0.56° 

Wavelength 940 nm 

Photodetector Array Size 1 x 16 

Measurement Rate Fixed at 196 Hz 

Accuracy ± 5 cm 

Leddar T16 Traffic  Detection Range (m) 

 

 

Configuration 

Horizontal 
FOV (°) 

Vertical 
FOV (°) 

Retro-
reflector1 

White 90% 
Reflectivity2 

Gray 18% 
Reflectivity3 

NCAP 
Pedestrian 

40% 

75A0030-1 9 1.6 49 39 19 49 

75A0021-1 19 3.0 49 36 18 47 

75A0022-1 26 4.2 49 18 12 27 

75A0023-1 36 5.9 49 15 8 20 
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Table 10: Test Conditions and Detection Range (Tolling) 

 
1. Retro-reflector reference target corresponds to a 5 cm x 7 cm band of retro-reflective tape. 
2. White reference target corresponds to a 20 cm x 25 cm Kodak Greycard with 90% reflectivity. 
3. Gray reference target corresponds to a 20 cm x 25 cm Kodak Greycard with 18% reflectivity. 

 

4.2. Mechanical Specifications 

Table 11: Leddar T16 Mechanical Specifications 

  

Leddar T16 Tolling Detection Range (m) 

 

 

Configuration 

Horizontal 
FOV (°) 

Vertical 
FOV (°) 

Retro-
reflector1 

White 90% 
Reflectivity2 

Gray 18% 
Reflectivity3 

NCAP 
Pedestrian 

40% 

75A0025-1 9 1.6 49 36 17 46 

75A0026-1 19 3.0 49 32 16 42 

75A0027-1 26 4.2 49 17 11 24 

75A0028-1 36 5.9 49 13 7 18 

75A0029-1 48 7.5 49 11 6 15 

 Leddar T16 Traffic Leddar T16 Tolling 

Height  226 mm / 9 in. 208.7 mm / 8.2 in. 

Length  386 mm / 15.2 in. 277 mm / 10.9 in. 

Width  259 mm / 10.2 in. 252.4 mm / 9.9 in. 

Weight 3 kg (6.6 lbs) 2.3 kg (5 lbs) 

Mounting Threads  M6 x 1.0 

Mounting Compatible with standard traffic hardware 
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4.2.1. Leddar T16 Traffic Dimensions 

 

 

 

Figure 7: Leddar T16 Traffic Sensor Dimensions 

 

 

 

4.2.2. Leddar T16 Tolling Dimensions 

 

Figure 8: Leddar T16 Tolling Sensor Dimensions 
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4.2.3. Distance Screw 

Figure 9, Figure 10, and Figure 11 below shows the measurements between the mounting 

threads of the Traffic and Tolling Sensors. 

 

Figure 9: Leddar T16 Traffic Top View – Measurements Between Mounting Threads 
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Figure 10: Leddar T16 Traffic Bottom View – Measurements Between Mounting Threads 
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Figure 11: Leddar T16 Tolling Bottom View – Measurements Between Mounting Threads 
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4.3. Electrical Specifications 

Table 12: Leddar T16 Electrical Specifications 

Power Supply IEEE 802.3at PoE+ (Power over Ethernet Plus), 56 VDC 

Power Supply Tolerance 

54 V to 57 V (56 V nominal)  

 

It is strongly recommended not to exceed this 

range as there is a surge protection at 58 V. 

Power Consumption (total) 
15 W (without heater) 

30 W (with heater) 

 

4.4. Environmental Specifications 

 Table 13: Leddar T16 Environmental Specifications 

4.5. Software System Requirements 
 

Table 14: LeddarTM Configuration System Requirements 

 

  

Operating Temperature 

Range 
−40° C to + 60° C (−40° F to +140° F) 

Humidity 100% 

Water Tightness IP67 

Operating System Windows 7 and up 

Memory 1 GB 

Disk Space 150 MB 

Communication Interface 100BASE-T Ethernet 
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 Installing the Leddar T16 Sensor 

This section provides information and procedures to install and start the Leddar T16 Sensor. 

5.1. Installing and Orienting the Sensor 

This section presents how to install and orient the sensor. The mounting bracket can be attached 

to the top or bottom of the Leddar sensor as shown in the examples below. 

       

   

Figure 12: Mounting Position Examples 

Required tools and materials 

• 10 mm wrench 

• Mounting brackets (of customer-supplied) 

To install and orient the sensor: 

1. Use the provided hardware to attach the sensor to the mounting bracket. The supplied lock 
washers must be installed between the bolt head and the bracket. Do not over tighten. The 
recommended torque is 60 in.-lb. (6 Nm). 

 
2. Orient the sensor so that the first segment is located on the side of the detection zone and that 

the active grid (green) is centered in depth with two reference marks (blue circle) you have 
placed on the side of the road (see Figure 13). 
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Figure 13: Orienting the Sensor with Reference Marks 

 
The sensor has three position controls: pan, tilt, and roll (see Figure 14). 

The pan and tilt are adjustable using the sensor motor (Traffic configuration only); the roll can only 

be adjusted by hand using the mounting bracket. 

These adjustments vary according to the side of the road on which the sensor is installed. 

 

Figure 14: Sensor Position Adjustments 

Refer to section 7.3.4 Orientation Control to know how to change the sensor orientation. 
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5.2. Connecting the Leddar T16 Sensor 

Once LeddarTM Configuration is installed, you can connect the sensor. 

The sensor is in DHCP mode by default.  

 

Refer to Appendix A (part A or part B) for the detailed procedure on how to configure the 

network with either a static IP or DHCP connection.  
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 Installing LeddarTM Configuration 
 

1. Download LeddarInstall.exe via the provided link or LeddarTech’s support portal. 

2. Double-click the file to start the installation. 

3. If the Windows Security dialog box opens, click the Install button to accept the installation of 

the drivers from LeddarTech during the process. 

  

Figure 15: Windows Security Dialog Box 

The first time the sensor is connected to a computer, about 30 seconds are required for 

Windows™ to detect it and complete the installation. 

 

4. Follow the steps in the Welcome to the LeddarTM Configuration Software Setup Wizard. 

5. On your computer desktop, click the LeddarTM Configuration icon  to open the software. 

 

Refer to Appendix A (part A or part B) for the detailed procedure on how to configure the 

network with either a static IP or DHCP connection. 
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6.1. Connecting to LeddarTM Configuration 

1. Open Leddar™ Configuration. The following window appears: 

 

Figure 16: Leddar™ Configuration Opening Window 

2. Click  to connect to the sensor. 

 

The first time the sensor is connected to a computer, about 30 seconds are required for 

Windows™ to detect it and complete the installation. 

 

3. In the Connection window, select a sensor in the list. Information about that sensor will 
appear under the list box. 
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The sensor list displays all the sensors that are currently recognized by the network. 
 
The color of items in the list indicates the status of a sensor.  
 

• Black: This sensor is available, and no user is connected to it. 

• Blue: There is a user connected to this sensor. 

• Red: Incapable of communicating. After a certain delay, if the sensor does not respond to 
requests, it is displayed in red. 

 

Figure 17: Connection Window 

4. a) If the sensor is automatically detected. Click on the available sensor in the list. 

b) Otherwise, enter the IP address 192.168.0.20 and Port number 48630. 

5. Click Connect to connect to the available sensor. 

6. To disconnect from the sensor, click  in the toolbar or go to Device > Disconnect. 
 

7. To quit Leddar™ Configuration, go to File > Quit. 
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Table 15: Connection Window Information 

Connection Details 
and Feature 

Description 

Status Message/State 

The status message is the connection status for a sensor, which 

indicates for example if a sensor is available or in use. The most 

common status messages are: 

• Waiting for connection 

• Connected 

• Connected and busy 

• Running 

• Running | Connected 

• Running | Connected | Busy 

Serial Number The serial number of the sensor as attributed by LeddarTech. 

Versions 

FPGA: Firmware version of the sensor. 

Software: Software version of the sensor. 

CRC: Software Cyclic Redundancy Check for integrity 
validation. 

Part Numbers 
Indicates the hardware and software part numbers of the 
sensor as attributed by LeddarTech. 

Ethernet Address 
Also called the Ethernet MAC address, this is a unique identifier 
of the sensor on the network. 

Mode - Local Broadcast 

Local Broadcast enumerates the sensors by sending a directed 

broadcast to the local subnet broadcast address. 

For example, if the IP address of the computer is 192.158.50.20 

and the subnet mask is 255.255.255.0, the local broadcast 

address 192.168.50.255 will be used. 

This address will enumerate local sensors; additionally, in a 
wide area network (WAN) the routers can be configured to route 
this directed broadcast, enabling sensors on a remote subnet 
to be enumerated. 
 



 

Page 37 of 109  Leddar T16 – User Guide 

Connection Details 
and Feature 

Description 

Mode - Unicast 

Unicast enumerates the sensors by sending unicast messages 

to every address defined by the IP Address and Subnet Mask 

boxes. 

For example, if 192.168.60.0 is entered as an IP address and 
255.255.255.0 as a subnet, then unicast messages will be sent 
to every address from 192.168.60.1 to 192.168.60.254 to verify 
if there is a sensor present. If there is, then the sensor will 
appear in the connection list. 

Mode - Address 

Address is used to connect to a precise IP address when too 

many addresses are present in the network connection used. 

It is also used to connect to sensors located behind a router 
acting as a network address translation (NAT) gateway.  

Mode - NAT 

The network address translation (NAT) feature is typically used 
to access sensors via the Internet, where the individual sensors 
share a single public IP address. To access sensors behind a 
NAT gateway, prior configuration of the gateway is required to 
forward the appropriate ports to the individual sensors. Up to 
10 sensors can be supported. 
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 LeddarTM Configuration 

The LeddarTM Configuration software allows the user to view the detection measurements provided 

by the connected sensor. The detections may vary based on the configuration of the parameters. 

The main window can be resized manually or set to full-screen view.  
 

When a dialog box or a window is already open a checkmark appears next to the command on the 

menu. 

 

Figure 18: Opened Window Check Mark Example 

 

When parameters such as the name of the sensor or acquisition settings are modified, a warning 

message in red appears in the main window. Click  in the toolbar to save your changes. 

 
 

Figure 19: Warning Message Example 
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7.1. Main Windows, Menus and Buttons 
 

Once connected to the sensor, the main window of LeddarTM Configuration displays the following 

menus, toolbar and view. See their description below. 

 

Figure 20: Leddar™ Configuration Traffic Configuration Main Window 
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Figure 21: Leddar™ Configuration Tolling Configuration Main Window 
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Table 16: Main Window Menus 

Menu Description 

File 

Click File to access the following menus: 

File > Record Replay 

File > Load Configuration 

File > Save Configuration As 

File > Start/Stop Recording 

File > Import Configuration  

File > Start/Stop Data Logging 

File > Quit 

Refer to section 7.2 File Menu for more details. 

Device 

Click Device to access the following menus: 

Traffic Configuration Menu 

Device > Disconnect 

Device > Apply Changes  

Device > Undo Changes 

Device > Configuration > Name 

Device > Configuration > Acquisition Settings 

Device > Configuration > Network 

Device > Configuration > Orientation 

Device > Configuration > Video 

Device > Action > Start/Stop Live Update 

Device > Action > Take Snapshot 

Tolling Configuration Menu 

Device > Disconnect 

Device > Apply Changes  

Device > Undo Changes 

Device > Configuration > Name 

Device > Configuration > Acquisition Settings 

Device > Configuration > Network 

 

Refer to section 7.3 Device Menu for more details. 

View 

Click View to access the following menus: 

Traffic Configuration Menu 

View > Device State 

View > Image  

View > Active Grid  
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View > Raw Detections 

View > Raw Detections Graph 

Tolling Configuration Menu 

View > Device State 

View > Raw Detections 

Refer to section 7.4 View Menu for more details. 

The d-tec Virtual Channels option is not compatible with the 

Leddar T16 Sensors. 

Settings 

Click Settings to access the following menus: 

Settings > Record 

Settings > Data Logger 

Settings > Preferences 

Settings > Access Levels 

Refer to section 7.5 Settings Menu for more details. 

Help 

Click Help to access the following menus: 

Help > User Guide 

Help > LeddarTM SDK Guide 

Help > About 

Refer to section 7.6 Help Menu for more details. 
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Table 17: Main Window Toolbar 

Button Description 

 

 

 

The Connect button allows you to connect to a sensor.  

Once you are connected, the Connect button will change for the 
Disconnect button.  

The Disconnect button will then allow you to disconnect the sensor from 
the system.  

 

The Apply button allows you to confirm and apply the changes you just 
made to the system related to the sensor.  

 

The Undo button allows you to come back to the information displayed 
before making your changes or before specifying parameters, for 
example. 

 

The Camera button is used to take a high-resolution snapshot. You can 
also take a snapshot by going to Device > Action > Take Snapshot 
Taking a snapshot replaces the live video with a static image.  

To return to the live video, click  or go to Device > Action > Stop 
Live Update. 

 
Click the stop button or go to Device > Action > Stop Live Update to 
stop the continuous update of images and results. 

 
Click the video camera button or go to Device > Action > Start Live 
Update to start continuous update of images and results. 

 

The fit-to-window button is available with the Tolling configuration only. 

Click the fit-to-window button to adjust the sensor view to the window 

when the  button is not selected.  

 

The scaling button is available with the Tolling configuration only. 

Click the scaling button to get the original ratio of the display.  

 

This button is available with the Tolling configuration only. 

Click Zoom in to zoom in the display. 

 

This button is available with the Tolling configuration only. 

Click Zoom out to zoom out the display. 

 



 

54A0043-2EN 032019 © LeddarTech Inc.   Page 44 of 109 

7.2. File Menu 

Table 18: File Menu Options  

Option Description 

Load Configuration 

This option allows the user to load the sensor configuration previously 

saved in the system as a *.lto file (LeddarTM Configuration file). Choose 

the wanted sensor configuration from the Open dialog box.  

You can also get the configuration that was stored with a record file. In 

case of a system failure, you can load a sensor configuration and use 

this sensor configuration to collect signal data according to a set of 

parameters (scanning, distance measurements, etc.); and then, analyze 

the collected data or the information. In addition, if you have more than 

one sensor and you want to use the same configuration for all your 

sensors, then, you must load the previously saved configuration you want 

to use for all your sensors. In this case, make sure to rename all your 

sensors with a different name. The sensors named differently will use the 

same configuration. Refer to section 7.3.1.1 Device Name and How to 

Change it. 

To load a configuration, go to File > Load Configuration. 

Save Configuration 
As… 

This option allows the user to save the configuration for a specific sensor 

to a *.lto file (LeddarTM Configuration file) from the Save as dialog box.  

This allows the user to save their settings and restore them in case of a 

system failure or to revert to earlier settings. In addition, if you have more 

than one sensor and you want to use the same configuration for all your 

sensors, save the configuration you want to use for all your sensors. In 

this case, make sure to rename all your sensors with a different name. 

The sensors named differently will use the same configuration. Refer to 

section 7.3.1.1 Device Name and How to Change it. 

To save a configuration, go to File > Save Configuration As. 

Start Recording  

 

 
Stop Recording 

Start Recording (shortcut F9): This option allows you to start recording 

detections in a *.ltl file that can later be reloaded and replayed. 

Stop Recording (shortcut F9): This option allows to stop recording 

detections of the *.ltl file.  

Refer to section 7.2.1.2 How to Record a Scene for more details. 
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Option Description 

Import 
Configuration 

To import a *.ltl file, go to File > Import Configuration. 

Record Replay 

Once you have completed a recording, you can review it by selecting 

Replay in the File menu. 

The Position slider lets you move directly to a desired position.  

The Playback Speed slider lets you adjust the speed of the recording 

playback. 

Refer to section 7.2.1.3 How to Play a Recording for more details. 

Start Data Logging 

 

 
Stop Data Logging 

Start Data Logging: Select this option to start the log of receiving data 

or the event log of the sensor. The event log displays under a text format. 

Stop Data Logging: Select this option to stop the log of receiving data 

or the event log of the sensor. The event log displays under a text format. 

Refer to section 7.2.2.2 How to Start and Stop Data Logging for more 
details. 

Quit Select Quit to quit LeddarTM Configuration software. 

 

7.2.1. Recordings (.ltl file) 

Detection records provide a playback of detections recorded by a sensor. This visual information 

can be useful for verification, troubleshooting, or training purposes. Detection records allow for a 

full data playback stored in a *.ltl file that you can later reload and replay.  

7.2.1.1. How to Edit Recording Settings 

Click Settings > Record, the Record Settings window opens. 

Detection records provide a playback of detections recorded by a sensor. This visual information 

can be useful for verification, troubleshooting, or training purposes. 
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Figure 22: Record Settings Window 

1. Choose a directory where you want to save the record file. 
 

2. Indicate a Maximum file size. 
 

3. Only check Debug 1, Debug 2, and Debug 3 if requested by LeddarTech to activate 
troubleshooting information. If activated, data acquisition rate (Hz) decreases.  
 

4. Indicate a Maximum record time. Click OK.  

The file name of the recording will be the sensor name followed by the date and time of the 
recording. The user can change the name of the file by changing the device name (refer to section 
7.3.1.1 Device Name and How to Change it) or after the recording. 

 

The video section is not available with the Tolling configuration and will be grayed out. 
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7.2.1.2. How to Record a Scene 

To start recording the detection scene: 

1. Under Settings menu > Preferences > Recording tab, indicate a maximum file size and a 

maximum record time. Refer to section 7.2.1.1 How to Edit Recording Settings for more 

details. 

2. In the File menu, select Start Recording (shortcut F9). 

When selecting this option, a counter will start at the bottom left of the main window next to the 

name of the sensor. 

To stop recording the detection scene: In the File menu, select Stop Recording (shortcut F9). 

 

7.2.1.3. How to Play a Recording 

To access this menu, disconnect from the sensor and click File > Replay.    

The Record Replay dialog box offers the same functions as a regular video player: there is a stop 

button, play button, and frame-by-frame forward and backward buttons. 

The Start, End, and Extract buttons allow you to select a portion of the recording and extract it for 

further reference or analysis. 

Once you have completed a recording, this option allows the user to review the recorded *.ltl file 

and to extract parts of this file. 

1. Click File > Replay. The Record Replay window appears: 
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Figure 23: Record Replay Window at Opening 

2. Click Browse to select a *.ltl file.  

 

Figure 24: Record Replay Window with File Open 
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Table 19: Record Replay Window 

Button/Feature Description 

 

Click Browse to select the record file of the scene that you want to 

view again. 

Once selected, the name of the file will appear next to the Browse 

button. 

 
Click the play button to start the recording. 

 
Click the stop button to end the recording. 

 

 

Click the previous or next buttons to either move to the previous 

frame or move to the next frame. 

Position 

 

Move the Position slider to go to a desired position in the recorded 

file. 

The indication of the position is located above the stop and play 

buttons, for example: . 

Playback Speed 

 

Move the Playback Speed slider to change the speed of the playback 

to see the scene or the detected object more accurately. The Playback 

Speed slider lets you adjust the speed of the recording playback; faster 

is to the left.  

Loop Check this option to automatically loop back to the beginning of the 

recording.  

 

 

 

The Start, End, and Extract buttons allow you to select a portion of 
the recording and extract it for further reference or analysis. 

Click Start to tag the position to start the extraction. 

Click End to tag the position to end the extraction. 

Click Extract to extract a part of the scene and save it as a *.ltl file. 

Refer to section 7.2.1.4 How to Extract a Scene Segment for more 

details. 
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7.2.1.4. How to Extract a Scene Segment  

This feature allows you to extract a segment from a previously recorded scene. 

 

1. Click  to select the record file to play. 

2. In the Open window, select the desired record file and click Open. 

3. Click  to start the playback. 

 
To extract a record file segment:  
 

1. Set the Position slider to the position where you want to see the file segment start and click  

.  

2. Set the Position slider to the position where you want to see the file segment stop and click 

.  

Another option:  

1. Play the record and stop it at a position of interest and click .  

2. Restart playing the record and stop it again at a position of interest and click .  

3. Click  to extract and save that file segment.  

If you want to specify a different speed for the playback, type the desired playback speed % or 
use the up and down arrows to specify the correct percentage (%). 
 

4. Click . 

 

Figure 25: Extracted Segment Example 
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7.2.2. Data Logging (.txt file) 

7.2.2.1. How to Setup Data Logging 

To setup data logging file and launch data logging: 

1. To configure a .txt recording, go to the Settings > Data Logger. 

2. Click  to select where to save the log and click OK. 

 

Figure 26: Data Log Settings Dialog Box 

The file name of the recording will be the sensor name followed by the date and time of the 
recording. The user can change the name of the file by changing the sensor name (refer to section 
7.3.1.1 Device Name and How to Change it) or after the recording. 

 

7.2.2.2. How to Start and Stop Data Logging 

To access this option, click File > Start Data Logging. 

The data logging function allows the user to output the data to a .txt file. This file can be imported 

in a software application, such as Microsoft Excel, for off-line analysis. 

When selecting this option, a counter will start at the bottom left of the main window next to the 

name of the sensor. 

To stop data logging, click File > Stop Data Logging. 
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7.3. Device Menu 

Table 20: Device Menu Options 

Option Description 

Device > Disconnect Click  to disconnect the sensor from the software and 

come back to Leddar™ Configuration. 

Device > Apply Changes 

Select this option to confirm the changes to the settings or click 

 in the toolbar. 

Device > Undo Changes 

Select this option to undo the changes to the settings or click 

 in the toolbar. 

Device > Configuration > 

Name  

Select this option to view and modify the name of the sensor. 

Refer to section 7.3.1.1 Device Name and How to Change it 

for more details. 

Device > Configuration > 

Acquisition Settings 

Select this option to access and modify the acquisition settings.  

Refer to section 7.3.2 Acquisition Settings for more details. 

Device > Configuration > 

Network 

Select this option to access the network settings. 

Refer to section 7.3.3 Network Settings for more details. 

Device > Configuration > 

Orientation 

This option is available with the Traffic configuration only. 

Select this option to move the camera to change its orientation. 

Refer to section 7.3.4 Orientation Control for more details. 
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Option Description 

Device > Configuration > 

Video 

This option is available with the Traffic configuration only. 

Select this option to set the video parameters. 

Refer to section 7.3.5 Video Settings for more details. 

Device > Action > 

Start/Stop Live Update 

This option is available with the Traffic configuration only. 

Select this option to start or stop the live update or click  

to start or  to stop the update in the toolbar. 

Refer to section 7.3.6 Action for more details. 

Device > Action > Take 

Snapshot 

This option is available with the Traffic configuration only. 

Select this option to take a snapshot or click  in the toolbar. 

Refer to section 7.3.6 Action for more details. 

 
 

7.3.1. Configurations 

The following sections allow the user to configure settings such as the name of the sensor, 

acquisition settings, network configurations, orientation control, and video adjustment. 

7.3.1.1. Device Name and How to Change it 

To access this menu, click Device > Configuration > Device Name. 

This option allows the user to view and modify the name of the sensor. 

When you connect to the sensor the first time, a default name will display. The user can change 

the name of the sensor at any time with a connected sensor. 

1. In the Device Name dialog box, in the Name field, type the new name of the sensor and click 

OK. 
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Figure 27: Device Name Dialog Box 

 

2. A warning message in red appears.  

3. Click  in the toolbar to save your changes. 

 

7.3.2. Acquisition Settings 

To access this menu, click Device > Configuration > Acquisition Settings. 

This menu allows the user to set the acquisition parameters for detection of objects or people. To 

apply new acquisition settings, click  in the toolbar. 

 

 

Figure 28: Acquisition Settings Dialog Box 
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Table 21: Acquisition Settings Window 

Parameter Description Range 

Crosstalk 
Removal 

Inter-segment interference noise removal. 

Crosstalk is a phenomenon inherent to all multiple segments 
time-of-flight sensors. It causes a degradation of the distance 
measurement accuracy of an object when one or more objects 
with significantly higher reflectivity are detected in other 
segments at a similar distance. 

Enable 
Disable 

Static Noise 
Removal 

 
When selected, this parameter enhances measurements by 
subtracting the constant electronic noise present at the 
beginning of signals. 

Enable 
Disable 

Pulse Width 
Compensation 

 

The objects in the sensor field of detection create a signature 

in the full-waveform signal called pulses. The pulse detector 

analyzes the full-waveform signal to recognize these pulses 

and compute their distance. By nature, time-of-flight sensor 

using full-waveform analysis can detect several distinct objects 

with a single photodiode element. 

The detected pulses have specific amplitudes based on their 
distance from the sensor and on the reflectivity of the objects. 
It is well known that pulses of small amplitudes do not lead to 
accurate and precise distance measurements. Consequently, 
the algorithm removes all pulses with amplitudes under a given 
threshold. This threshold depends on the acquisition settings 
of the sensor. 

Enable 
Disable 

Overshoot 
Management 

 
When selected, this parameter improves the detection of 
false measurements caused by specific signal shapes. For 
example, this may occur when strongly reflecting objects are 
present in the field of view. 

Enable 
Disable 

Saturation 
Compensation 

When selected, this parameter activates the advanced 
distance computation algorithm for very strong (saturated) 
signals. This computation uses slightly more computing power 
to enhance the quality of the distance measurements of 
saturated light pulses. 

The algorithm classifies the detected pulses based on their 
shape. The sensor determines which pulses are saturated and 
which have a normal shape. Saturated pulse occurs when the 
signal backscattered by the object is so strong that the full-
waveform signal is clipped. If not treated, this phenomenon 
creates an important degradation of the distance 
measurement accuracy. It is why a saturation compensation 
algorithm is executed when saturated pulses are detected.  

Enable 
Disable 
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Parameter Description Range 

Echoes 
Crosstalk 
Removal 

 
When selected, this parameter can further increase accuracy 
by removing secondary echoes that might still be present in 
adjacent segments after applying the first stage of crosstalk 
removal. 

Enable 
Disable 

Temperature 
Compensation 

 
The signal processing algorithm also embeds an advanced 
temperature compensation scheme which attenuates the 
distance measurement drift over large and sudden sensor 
temperature changes. The temperature compensation also 
ensures optimal accuracy over the full operating temperature 
range. 

Enable 
Disable 
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7.3.3. Network Settings 

To access this menu, click Device > Configuration > Network. 

This window allows the user to view and modify the IP configuration and communication protocol 

configuration. The network configuration applies after a system reboot. 

 

Figure 29: Network Settings Configuration Window 

 

Table 22: Network Configuration Window 

Parameter Description 

IP Address The IP address attributed to the sensor. 

Subnet Mask 
This defines and identifies the local network within which DHCP 

addresses will be attributed to sensors. 

Gateway Address 

By default, this is the same as the Server Address. However, a distinct 

gateway address is required if you need to access another subnet, that 

is one or more sensors that are not on the local network. 

Ethernet PHY Mode 

 
There are five Ethernet PHY modes available: 
 

• Auto-Negotiation 

• 10 Mbps Half-Duplex 

• 10 Mbps Full-Duplex 

• 100 Mbps Half-Duplex 

• 100 Mbps Full-Duplex 

Address Mode 

There are two address modes available: 

• DHCP (Dynamic Host Configuration Protocol) 

• Static 

Refer to Appendix A (part A or B) for more details. 
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7.3.4. Orientation Control (Pan/Tilt Adjustment) 

To access this menu, click Device > Configuration > Orientation. 

 

This menu is available with the Traffic configuration only. 

This feature allows the user to adjust the orientation of the sensor. 

In the Orientation Control dialog box, use the arrows to move the sensor so that the active grid is 

centered on the zones to monitor. 

The Step Size field sets the move, in degrees, for each click on an arrow button (0.1 to 

1.0 degrees). 

 

Figure 30: Orientation Control Window 

The start of the first lane line must match the physical delimitation of the first lane and the reference 

line must be perpendicular to the road; this means that they both should line up with the reference 

mark and the marking or object it was aligned with. 

 

Figure 31: Active Grid Application Example 
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7.3.5. Video Settings 

To access this menu, click Device > Configuration > Video. 

This menu is available with the Traffic configuration only. 

Video activation and settings choices can affect the detection performance in real time. 

 

Figure 32: Video Settings Window 

 

Table 23: Video Settings 

Parameter Description 

Camera Intensity 

Select the Manual checkbox to manually change the 

camera intensity with the Position slider. If you clear the 

checkbox, the intensity will adjust itself automatically. 

  

For a darker image, move the position slider to the left and 
for a lighter image move the position slider to the right. 

Bit rate (kbps) 1 to 4000 kilobits per second 
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Parameter Description 

Real bit rate (kbps) Real bit rate in kilobits per second. 

Low speed connection (WAN) Select this option to get a low speed connection. 

High speed connection (LAN) Select this option to get a high-speed connection. 

Resolution 320 x 240 QVGA (Quarter Video Graphics Array display 

standard)  

 

7.3.6. Action 

To access this menu, click Device > Configuration > Action. 

This menu is available with the Traffic configuration only. 

This menu allows you to start or stop a live update (Device > Action > Start/Stop Live Update) 

or take a snapshot (Device > Action > Take Snapshot). 

You can also use shortcuts by clicking the following buttons in the toolbar. 

 

Table 24: Action Buttons Description 

Button Description 

 

Click the stop button or go to Device > Action > Stop Live 
Update to stop the continuous update of images and results. 

 

Click the video camera button or go to Device > Action > 
Start Live Update to start continuous update of images and 
results.  

Video activation and settings choices can affect the   
detection performance in real time. 

 

The Camera button is used to take a high-resolution 
snapshot. You can also take a snapshot by going to Device > 
Action > Take Snapshot Taking a snapshot replaces the live 
video with a static image.  

To return to the live video, click the video camera button or go 
to Device > Action > Stop Live Update. 

 



 

Page 61 of 109  Leddar T16 – User Guide 

7.4. View Menu 

Table 25: View Menu Options 

  

Menu Description 

View > Device State  
Select this option to view sensor information.  
 
Refer to section 7.4.1 Device State for more details. 

View > Image 

This option is available with the Traffic configuration only. 
 
Select this option to get a live view from the camera sensor.  
 
Refer to section 7.4.2 Image Activation for more details. 

View > Active Grid 

This option is available with the Traffic configuration only. 
 
Select this option to get the sensor detection zone overlay 
on the live view from the camera sensor.  
 
Refer to section 7.4.3 Grid Activation for more details. 

View > Raw Detections 

Select this option to view the displayed raw data and define 

the desired detection parameters.  

Refer to section 7.4.4 Raw Detections for more details. 

View > Raw Detections Graph 

This option is available with the Traffic configuration only. 
 
Select this option to view the detection scene in 2D.  
 
Refer to section 7.4.5 Raw Detections Graph for more 
details. 
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7.4.1. Device State 

To access this menu, click View > Device State. 

This window allows the user to view information about the sensor. 

 

Figure 33: Device State Dialog Box 

 

Table 26: Device State Information 

 

Parameter Description 

Temperature This section indicates the temperature of the sensor and of its chip. 

Timers & Load 

This feature gives information in number of days, hours, minutes, and 

seconds about two types of activities of a sensor. The first line indicates 

how long it has been since the last sensor reset; the second line indicates 

how long it has been since the last power cut or outage. 

 

The CPU load indicates how much of the sensor processor capacity is in 

use. 

Serial Number The serial number of the sensor as attributed by LeddarTech. 

Versions 

FPGA: the firmware version. 

Software: the software version of the sensor. 

CRC: Software Cyclic Redundancy Check for integrity validation. 
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Parameter Description 

Part Numbers 
This provides the Hardware and Software part numbers of a sensor, as 

attributed by LeddarTech. 

Ethernet 

Address 

Also called the Ethernet MAC address, this is a unique identifier of the 

sensor on the network. 

 

 

7.4.2. Image Activation 

To access this menu, click View > Image. 

This menu is available with the Traffic configuration only. 

This option allows the user to activate or deactivate the camera of the sensor and get a live view. 

When the image is activated, you can take a snapshot of the live image by clicking  and the 

image will freeze. 

 

7.4.3. Grid Activation 

To access this menu, click View > Active Grid. 

This menu is available with the Traffic configuration only. 

This option allows the user to activate or deactivate the grid that appears on the main window. 

To change the color of the grid, go to Preferences and select LeddarTM T16. Refer to section 

7.5.3 Preferences for more details. 
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7.4.4. Raw Detections 

To access this menu, click View > Raw Detections. 

This window allows the user to view detection values. It also provides filters to isolate segments 

and detection parameters.  

An object crossing the beam of the sensor is detected and measured. This detection is qualified by 

its segment position, distance, and amplitude. The quantity of light reflected to the sensor by the 

object generates the amplitude. The bigger the reflection is, the higher the amplitude will be. 

 

 

Figure 34: Raw Detections Window 
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Table 27: Raw Detections Parameters 

Parameters Description Range 

Min Amplitude 

 

 

 

Max Amplitude 

The value entered in the Min Amplitude box shows 

only detections of amplitude higher or equal to that 

value.  

The value entered in the Max Amplitude box will 

show only detections of amplitude lower or equal to 

that value. The maximum amplitude is set at 1024.0 

by default. 

Setting a value in both fields will result in a range of 

amplitude to display. 

0.0 to 1024.0 

Min Distance 

 

Max Distance 

The minimum and maximum distance from where to 

detect an object.  

 

Maximum distance is set at 100.0 by default. 

0 to 200 

Segment 

 

Select the segments that you want to display in the 

detection results.  

 

 
 

1 to 16 

Freeze 
Check the Freeze box to freeze the raw data and view 

the information. 

Enable 

Disable 

Distance (m) Position of the detected object. Varies 

Amplitude 
Quantity of light reflected by the object and measured 

by the sensor. 
0 to 128 

Flags 

The Flags parameter provides the status information 

that indicates the measurement type (8-bit status 

encoded as a bit field). See Table 28. 
1 to 255 
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Table 28: Flag Value Description 

 

Bit position Bit = 0 Bit = 1 

0 Invalid measurement Valid measurement 

1 Reserved Reserved 

2 Reserved Reserved 

3 Reserved Saturated 

4 Reserved Reserved 

5 Reserved Reserved 

6 Reserved Reserved 

7 Reserved Reserved 
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7.4.5. Raw Detections Graph 

To access this menu, click View > Raw Detections Graph. 

The Raw Detection Graph window is available with the Traffic configuration only.  

The raw detections graph window allows the user to view the segments. 

 

Figure 35: Raw Detection Graph Example 
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The measurements are represented in a symbolic graph containing the 16 segments (white lines) 

originating from the sensor. Detections are drawn as arcs in their corresponding segments. Only 

valid measurements are displayed. A more detailed description of the measurements can be 

obtained in the Raw Detections dialog box (refer to section 7.4.4 Raw Detections). 

The X and Y numbers displayed at the bottom are the mouse cursor position coordinates. 

The display in the main window can be panned, viewed and zoomed in different ways. Panning 

and zooming is done according to the mouse cursor position.  

You can move up, down, and sideways by clicking and dragging the display.  

The window opens with default scale settings. 

 

7.4.5.1. Setting Scale Areas and Detection Points 

The horizontal and vertical scales can be changed manually by entering new values in the fields 

accessible by clicking the areas shown in Figure 36, Figure 37, Figure 38, and Figure 39 below.  

Click next to the desired number to change the vertical and horizontal scales independently.  

To apply the changes, click anywhere in the main window.  

See Figure 40 and Figure 41 below to view detection points information examples. 
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Figure 36: Vertical Scale Setting Areas (Traffic Configuration) 
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Figure 37: Vertical Scale Setting Areas (Tolling Configuration) 
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Figure 38: Horizontal Scale Setting Areas (Traffic Configuration) 



 

54A0043-2EN 032019 © LeddarTech Inc.   Page 72 of 109 

 

Figure 39: Horizontal Scale Setting Areas (Tolling Configuration) 
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You can hover the mouse on a segment to get the following information:  

• Segment  

• Distance (in meter) 

• Amplitude  

 

Figure 40: Detection Point Coordinates (Traffic Configuration) 
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Figure 41: Detection Point Coordinates (Tolling Configuration) 

 

7.4.5.2. Detection Scene Short Keys  

Short keys allows you to pan or zoom the display of the detection scene.  

 

Mouse wheel: to zoom in or zoom out vertically and horizontally (Traffic and Tolling configurations). 

Mouse click: to move the detection scene vertically and horizontally (Traffic and Tolling 

configurations). 

Shift + mouse wheel: to resize the detection scene horizontally (Traffic and Tolling configurations). 

Ctrl + mouse wheel: to resize the detection scene/enlarge the segments (Traffic configuration 

only). 
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7.5. Settings Menu 

The Settings menu includes the Record, Data Logger, Preferences and Access Levels. 

7.5.1. Record Settings 

To access this menu, click Settings > Record. 

 

Figure 42: Recording Settings Window 

 

Table 29: Recording Settings 

Feature Description 

Record Directory 

The record directory is the folder to which all record files will be 
saved. These files are in a proprietary format, with extension *.ltl, 
and can only be opened and viewed with the Leddar™ 
Configuration software. 

Maximum File Size Record files can be quite large. Set the maximum file size as 
needed. The recording stops for the current file once it reaches the 
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Feature Description 

maximum file size and automatically switches the recording to 
another file. This is to keep record files of manageable sizes. 

Video 

This option is available with the Traffic configuration only. 

This feature is needed to record the live images with the data. 
When not selected, only the data will be recorded. 

Video activation and the debug mode set for recording 
can affect the detection performance in real time. 

Debug 
These check boxes are reserved for the use of LeddarTech 
technicians. 

 

Record Video As 

This option is available with the Traffic configuration only. 

Two types of video recordings can be used: JPEG Images records 
a series of JPEG images and MPEG Stream records an MPEG 
video format. 

The MPEG stream format is recommended when using a local 
area network (LAN) connection. The quality is as good as the 
JPEG images but generates a smaller file size. 

The JPEG image format is recommended when recording 
remotely through a wide area network (WAN) connection. 
Reducing the JPEG image quality can help reduce file size by 
compressing the JPEG images that are contained in the record. A 
level of 75% to 80% usually provides acceptable image quality and 
a reasonable file size. 

Maximum Record Time 
The value entered as the Maximum record time determines the 
length of the time for recording. At the end of that period, recording 
will stop even if the file size has not reached its maximum. 

 

Refer to section 7.2.1.1 How to Edit Recording Settings for more details. 

 

7.5.2. Data Logger 

To access this menu, click Settings > Data Logger. 
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Figure 43: Data Logger Dialog Box 

 

Refer to section 7.2.2.2 How to Setup Data Logging for more details. 

 

7.5.3. Preferences 

To access this menu, click Settings > Preferences. 

This menu allows the user to change various settings related to window display. 

 

Figure 44: Preferences Options Window 

 

With the Tolling option, Leddar T16 does not appear in the General menu. 
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Table 30: Preferences Window Options and Settings 

Option Description Range 

Units 

The units that are applied to distances displayed in the 
Leddar™ Configuration software. 

Meter 

Foot 

Temperature 

Unit 
The units for displaying temperatures of sensors. 

Celsius 

Fahrenheit 

Kelvin 

Error Log 

Select Show error log to display error messages that are 
logged during the current session. Error messages are 
displayed in the Error Log box. 
 

Enable 
Disable 

Network 

Select the network timeout, in seconds, to decide how long 
you want to wait for an operation before your request for 
that operation is canceled (timed out) on a network. 

2 to 30 seconds 

LeddarTM 

Configuration 

The main window size can be manually set, and the 

preferences selected before connecting to a sensor. 

When Fixed aspect ratio is selected, you can enlarge the 

Leddar™ Configuration main window while keeping the 

display height and width ratio. 

When both features are selected, you can resize the 

Leddar™ Configuration main window while keeping the 

display height and width ratio. 

N/A 

LeddarTM T16 

This option is available with the Traffic configuration only. 

Select this option to change the color and opacity of the 

grid. 

When the Fit image to window (no zoom) feature is 

selected it resizes the image, so it fits the main window 

size. When cleared, it provides a zooming feature: Clear 

the check box, click the display, and then use the mouse 

wheel to zoom in and out. 

Opacity: 

0 to 255 
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7.5.4. Access Level 

To access this menu, click Settings > Access Level. 
 
You can also change license by double-clicking on User located at the bottom of the main 
window. 
 
The Leddar™ Configuration software has two access levels: The User operation mode (by default 
at startup) for normal use and the Technician operation mode which is password protected for 
approved personnel use only. 

 
In the Enter Master Password dialog box, type the password provided by LeddarTech.  
 
 

 

Figure 45: Enter Password Dialog Box 

 

For more information on licenses, contact LeddarTech Support at support@leddartech.com. 

 

  

mailto:support@leddartech.com
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7.6. Help Menu 

The Help menu includes User Guide, LeddarTM SDK Help, and About options. 

7.6.1. User Guide 

To access this menu, click Help > User Guide. 

The User Guide option allows the user to select and consult a PDF version of a user guide directly 

from Leddar™ Configuration.  

Select a user guide in the list to open a PDF version of the selected user guide. 

7.6.2. LeddarTM SDK Help 

To access this menu, click Help > LeddarTM SDK Help. 

The Leddar™ SDK is an interface to allow programmers to integrate sensors in their products.  

C language interface available for Windows platforms. 

For more information, open the SDK help. 

7.6.3. About 

To access this menu, click Help > About. 

The About option allows the user to know which software version is currently used and the software 

part number. These can be used when contacting LeddarTech support. 
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 Communication Protocol 
 

The Leddar T16 Sensor uses LeddarTech’s proprietary communication protocol (TCP/IP socket-

based protocol called Ipv4). 

Refer to the Communication Protocol User Guide provided by LeddarTech for more information 

about the communication protocol of the sensor. 
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 Troubleshooting 

 

Problem Action to Take 

No power 

Verify that your sensor is connected. 

Verify that your sensor is connected to an appropriated 
PoE+ port. 

The optical window is damaged Contact LeddarTech Support. 

The Ethernet connection is not 
available 

Verify that your computer is configured with a static IP 
address. 

Verify that the cable is well secured in the Ethernet port. 

If the cabling connection seems secure, verify that the 
Ethernet link between the control computer and the sensor 
is valid using the ping command. 

The sensor is not detected in 
Leddar™ Configuration 

Verify that the power supply of the sensor. 
 
Verify that the sensor is detected by your network board. 
 
Use the appropriate Ethernet connection mode and 
addressing in function of your network architecture. 

The sensor is not detected by 
your network board 

Verify if the LEDs of your Ethernet port are blinking. 

The LEDs Ethernet port is not 
blinking 

Verify the setting of your Network board. The IP setting shall 
be set as in Appendix A. 
 
Verify if the Ethernet cable is well connected.  

 

    

In the case of failure of the Leddar T16, please contact LeddarTech Support at 

support@leddartech.com. 

mailto:support@leddartech.com
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 Maintenance 

Following this maintenance guideline will ensure optimal performance of the product.  

 

Manipulation 
Avoid touching the optical surface as fingerprints can permanently 
damage optical coatings.  

Cleaning of  
the optics 

1. Remove dust using blow dry compressed air. 
 

2. Clean using lens tissue or isopropanol. 

 

 
 To safely perform maintenance operations of the Leddar T16 Sensor, please contact 
LeddarTech Support at support@leddartech.com. 

 

mailto:support@leddartech.com
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 Warranty 
 

PLEASE READ CAREFULLY 
V2.0 2018-06-01 

LeddarTech® Limited Warranty 

1. Application. This limited warranty (this “Warranty”) from LeddarTech Inc. (“LeddarTech”) applies to 

all LeddarTech products referenced on the LeddarTech website at leddaretch.com (each, a “Product”).  

This Warranty does not apply to any prototype units of the Product.   

2. Limited Product Warranty.  Subject to the terms and conditions of this Warranty, LeddarTech 

warrants to any purchaser of a Product (“Customer”) that the Product will be free from defects in material 

and workmanship, when used in accordance with the specifications sheet and User Guide provided by 

LeddarTech for such Product.  LeddarTech shall not be liable under this Warranty if the alleged problem 

in the Product was caused by misuse, negligence, improper installation or testing of the Product, 

unauthorized attempts to disassemble the Product for repair or any other reason, or by accident, fire, or 

other hazard or the combination of the Product with any third party product (a “Combination Product”).  

No representative of LeddarTech or its authorized resellers are authorized to make any change or 

modification to this Warranty or express any other warranties with respect to the Products. 

3. Warranty Period.   The Warranty is valid for a period of 12 months (the “Warranty Period”) from the 

shipment date to customer of any Product sold by LeddarTech and/or its authorized resellers. 

4. Warranty Procedures.  Any claim under this Warranty must be submitted in writing by Customer to 

LeddarTech promptly after discovery of occurrence of a suspected defect in materials or workmanship, 

and in any case prior to the expiry of the Warranty Period, describing with reasonable specificity such 

defect. Timely notification will permit Customer to obtain a Return Authorization Number (RMA) from 

LeddarTech’s Customer Service Department which will indicate return procedures and terms and 

conditions of such returns.  A proof of purchase of the Product, such as an invoice or a receipt certifying 

the validity of the Warranty, must be presented in order to obtain Warranty coverage.   

The Product or part shall be returned to LeddarTech, accompanied by the Return Authorization Number 

with prepaid shipping charges. Customer must insure the shipment or accept the risk of loss or damage 

during the shipment. Customer shall also pay any tariff or duty applicable to the return of the defective 

part or Product. 

LeddarTech shall be entitled to require delivery by Customer of whatever proof it requests to evaluate 

the validity of the claim. Customer agrees that any claim under this Warranty will be subject to 

LeddarTech’s determination of validity and if LeddarTech determines the claim is valid, any such claim 

is expressly limited, at the option of LeddarTech, to either: (i) reimbursing the purchase price of the 

Product found to be defective, (ii) repairing at no cost any defective Product or parts thereof, or (ii) 

replacing the defective Product.  This Warranty is the sole remedy of Customer for any defect in the 

Product.  LeddarTech will be responsible for returning any repaired or replacement Product to Customer. 

If after evaluation by LeddarTech the defect is not covered by this Warranty, LeddarTech may provide a 

quote to Customer for the cost of repair of the Product.  Any such Product or part shall be shipped back 

to Customer at Customer’s cost. 
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The original Warranty Period shall not be extended by any replacement, but the remaining Warranty 

Period shall continue in effect and be applicable under the terms and conditions of this Warranty to the 

replaced Product.  

5. Disclaimer. THE WARRANTY IS GIVEN IN LIEU OF ALL OTHER WARRANTIES, LIABILITIES OR 

OBLIGATIONS OF LEDDARTECH, EXPRESSED AND IMPLIED, INCLUDING WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT 

AND ANY IMPLIED WARRANTIES ARISING FROM COURSE OF DEALING, USAGE OF TRADE, OR 

COURSE OF PERFORMANCE.   

6. Limitation of Liability.  LEDDARTECH, ITS PARENT COMPANIES, SUBSIDIARIES AND 

AFFILIATES, THEIR OFFICERS, DIRECTORS, EMPLOYEES AND AGENTS, SUCCESSORS AND 

ASSIGNS (“LEDDARTECH PARTIES”) SHALL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, 

INCIDENTAL, EXEMPLARY, PUNITIVE OR CONSEQUENTIAL DAMAGES, INCLUDING WITHOUT 

LIMITATION, LOSS OF PROFITS, LOSS OF USE, DOWNTIME, LOSS OF DATA, FAILURE TO 

DETECT ANY FLAW IN ANY SUBJECT MATTER OF ANY TEST, LOSS OF GOODWILL, DELAY IN 

PERFORMANCE, BUSINESS INTERRUPTION, PRODUCT LIABILITY OR ANY CAUSE OF ACTION 

IN CONNECTION WITH THE USE OR HANDLING OF THE PRODUCTS BY CUSTOMER OR ANY 

PERSON AUTHORIZED BY CUSTOMER.  Some jurisdictions do not allow exclusion or limitation of 

consequential or incidental or special damages, so the above limitations or exclusions may not apply to 

you.  This warranty gives you specific legal rights, and you may also have other rights, all of which vary 

from jurisdiction to jurisdiction. 

7. Indemnification. Customer shall defend, indemnify and hold harmless the LeddarTech Parties 

(“Indemnified parties”) from any third party claims, demands, lawsuits, damages, liabilities, including 

attorney's fees and court costs, judgments and settlements of every kind  (“Claims”) arising out of, 

connected with, or resulting from any acts, duties, obligations or omissions of Customer or that may be 

made for injuries (including death) to persons or damage to property, including theft, and resulting in 

whole or in part in connection with the use, installation, removal, replacement, manipulation and/or repair 

of the Products and any Combination Product. 

8. Software.  All software embodied in or used in connection with the Products is provided to Customer 

subject to the terms and conditions of the End-User License Agreement to which Customer must agree 

to be bound as part of the installation of the said software. Warranties, if any, for the software are 

contained in such separate End-User License Agreement. 

9. Entire Agreement.  This document contains the entire agreement of the parties regarding the subject 

matter of the Warranty and supersedes all previous communications, representations, understandings 

and agreements, either oral or written, between Customer and LeddarTech. 

10. Governing Law: This Warranty shall be governed by and is to be interpreted in accordance with the 

laws of Quebec and the laws of Canada applicable therein without reference to its conflict of law 

provisions and excluding the United Nations Convention on Contracts for the International Sale of 

Goods. The parties agree that the Courts having jurisdiction in the judicial district of Quebec (Province 

of Québec) shall have exclusive jurisdiction to hear any litigation resulting from the interpretation, 

application or execution of this Warranty. 

LeddarTech’s Customer Service Department can be reached during regular business hours 

(Monday to Friday, 8:30 a.m. to 4:30 p.m. Eastern Time) by calling (418) 653-9000 or 

1 855 865-9900.  Visit www.leddartech.com  
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  Technical Support 

For technical inquiries, please contact LeddarTech technical support by registering online at 

https://support.leddartech.com to: 

 

• Follow up on your requests 

• Find quick answers to questions 

• Get valuable updates 

Or by contacting us at: 

 

• + 1 418 653 9000 

• + 1 855 865 9900 

• support@leddartech.com 

8:30 a.m. - 5:00 p.m. Eastern Standard Time 

To facilitate the support, please have in hand all relevant information such as part numbers, serial 

numbers, pictures (if possible). 

 

 

LeddarTech Inc. 
4535, boul. Wilfrid-Hamel, #240 
Quebec QC G1P 2J7 
Canada 

 

www.leddartech.com 

  

https://support.leddartech.com/
mailto:support@leddartech.com
http://www.leddartech.com/
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Appendix A. Static IP and DHCP Configuration 
Under Windows 7 and Up  

 

Part A – Configuring the network for static IP mode.  

 

You will lose internet connection if you are not connected via other means. 

 

1. In Control Panel > Network and Internet > Network and Sharing Center, select 

Change adapter settings. 

 

Figure 46: Change Adapter Settings 
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2. In the Network Connections window. Double-click on Ethernet. 

 

Figure 47: Ethernet Network Option 
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3. In the Ethernet Properties window, select Internet Protocol Version 4 (TCP/IPv4), 

then click on Properties. 

 

Figure 48: Ethernet Properties 
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4. Select Use the following IP address and insert an IP address different than the sensor, 

for example: 192.168.000.100 in the IP address field. 

5. Insert the same subnet mask as the sensor (255.255.255.0 by default) in Subnet Mask 

field. 

 

Figure 49: IP Address and Subnet Mask 

 

Refer to section 6 Installing LeddarTM Configuration once the configuration is done. 
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Part B – Configuring the network for DHCP mode 

1. Connect the Ethernet cable (POE+ connection) into the Ethernet port of the sensor and the 

other end of the Ethernet cable to your computer or switch. See Figure 50. 

 

Figure 50: Sensor Connection to POE+ Switch 
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2. In the network connections, make sure that the TCP/IPV4 is set to automatic.  

 

Figure 51: Ethernet Properties 

 

Figure 52: IP Address and Subnet Mask 

 

Refer to section 6 Installing LeddarTM Configuration once the configuration is done. 
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Appendix B. Making Connectors for the 
Ethernet Cable 

 

A Cat 5e RJ45 Ethernet cable must link the sensor to a network or a computer. You must install a 

connector at both ends of the Ethernet cable. To do so, use the supplied RJ45 connector kits. 

See Figure 53 and Figure 61. 

 

 Figure 53: RJ45 Industrial Modular Connector Kit for the Sensor Side of the Ethernet Cable 

 

Required tools and materials 

Tools Material 

1. RJ45 crimp tool 
2. 18 mm, open-end wrench 
3. Cutter 

If customer supplied: shielded Cat 5e 
cable (Belden 7929A recommended) 
 

 

To make the Ethernet cable connectors: 

1. Strip the cable jacket to approximately 1 in. (25 mm) and feed the cable through the plug 

housing (IP67 industrial modular connector). 

 

LeddarTech is not responsible of water infiltration if the IP67 industrial modular 

connector is not used. 
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Figure 54: Ethernet Cable with the Jacket Stripped and Plug Housing 

 

2. Untwist wire pairs and separate them. 

 

 

Figure 55: Twisted Pairs 

 

3. Align the wires according to the T568B standard (see Figure 56). 
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Do not remove the insulation of individual wires. 

    1     2      3     4     5     6      7     8                                   1 

1: White-orange 
2: Orange 
3: White-green 
4: Blue 
5: White-blue 
6: Green 
7: White-brown 
8: Brown 

 

Figure 56: Cat 5e T568B Wiring Diagram 

 

 

4. Cut the wires and insert them in the load bar. 

 

Figure 57: Wires in the Load Bar 

 

5. Slide the load bar until it sits against the cable jacket and cut the wires to approximately 

1/4 in. (5 mm). 

 

6. Trim the remaining wire tips and retract the cable to leave about 1/32 in. (1 mm) of wire. 
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Figure 58: Trimming the Wires 

 

7. Insert the load bar inside the RJ45 plug all the way until the wire tips are seated against 

the inside wall of the plug housing. 

 

 

 

Figure 59: Inserting the Load Bar and Wires in the RJ45 Plug 
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8. Crimp the connector with the crimp tool. 

 

Figure 60: Crimping the RJ45 Plug 

 

9. Depress the connector tab and pull the cable until the connector is fully seated inside the 

plug housing.  

 

10. Hold the plug in position and rotate the cable fitting clockwise until tightened to a torque 

of 20 lbs-in. (2 Nm). 

 

11. Install the sensor as described in Section 5 Installing the Leddar T16 Sensor. 

 

12. Connect the Ethernet cable to the sensor as follows: 

 

a) Align the tab of the RJ45 connector with the upper slot of the RJ45 jack on the 

sensor. 

b) Align the three pins of the plug housing ring with the three notches of the receptacle 

on the sensor. 

c) Press and rotate the plug housing until the pins “click” into the notches. 

 

13. Using another RJ45 connector and the strain relief for the computer or network side 

make the cable connector as explained in steps 1 through 8. 
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In step one, instead of using the plug housing, use the yellow strain relief (see Figure 61). 

 

 

Figure 61: RJ45 Strain Relief Connector Kit for the Other End of the Ethernet Cable 

 

14. Repeat steps 1 through 13 for other sensors.  
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Appendix C. Procedure to Use LeddarCDemo 
(SDK Code Example) with the 
Leddar T16 Sensor 

 

1. When installing the Leddar™ Configuration software, you must select both products below. 

 

2. You should have the code Examples in your Documents folder in your computer 

C:\....Documents\LeddarTech as you can see below.  
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3. Copy paste all the DLL files from the C:\Program Files\LeddarTech\xtec to LeddaCDemo 

folder. Copy all the DLL files from here: 

 

 

 



 

Page 103 of 109  Leddar T16 – User Guide 

4. Paste the DLL files to the LeddarCDemo folder here:  
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5. Open the LeddarCDemo.vcxproj with Visual Studio and compile the Main.c 

 

 

6. The DOS window below appears: 
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Click 3. List Sensors to find the sensor with the address 192.168.0.10. 
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Click option 1. Connect, then option 1. Read Data. 
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Note: The code example below reads only 8 segments. 
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LEDDARTECH INC. 

4535 Wilfrid-Hamel Blvd, Suite 240  
Quebec City QC  G1P 2J7 
Canada 
 

Tel.: +1 418 653-9000 

Canada or USA toll free: +1 855 865-9900 

Fax: 1-418-653-9099 

8:30 a.m. - 5:00 p.m. EST 

support@leddartech.com 

www.leddartech.com 

 

© 2019 LeddarTechTM Inc. All rights reserved. 
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