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0. Preliminaries

0.1 Welcome

Welcome to AxiDraw! 

This is the user guide for the AxiDraw V3 family of personal writing and drawing 
machines.  This guide is here to help you get started. There is a lot here–covering 
how you set up and use the machine, and pointing you towards additional re-
sources for the future.

This guide covers operation of the following AxiDraw models:
• AxiDraw V3
• AxiDraw V3 XLX
• AxiDraw V3/A3
• AxiDraw SE/A3 

0.2 This guide is a work in progress!

This guide is a continuing work in progress, and we want to suggest you to check 
back occasionally for the latest version of this manual, and to check that you have 
the latest version of the software.

Recent changes to this guide include updates to the current software version, 
which is v1.7.8, additions to the sections about text, and about vectorizing images.

You can download the latest version of this at http://axidraw.com/guide

Look at the front cover of the guide to find the date and version number of the 
guide that you are looking at.

http://axidraw.com/guide
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1. Introducing the AxiDraw

The AxiDraw is a simple, modern, precise, and versatile pen plotter, capable of 
writing or drawing on almost any flat surface. It can write with your favorite foun-
tain pens, permanent markers, and other writing implements to handle an end-
less variety of applications. Its unique design features a writing head that extends 
beyond the machine, making it possible to draw on objects bigger than the ma-
chine itself.

The AxiDraw is an extremely versatile machine, designed to serve a wide variety 
of everyday and specialized drawing and writing needs. You can use it for almost 
any task that might normally be carried out with a hand-held pen.

It allows you to use your computer to produce writing that appears to be hand-
made, complete with the unmistakable appearance of using a real pen (as op-
posed to an inkjet or laser printer) to address an envelope or sign one’s name. 
And it does so with precision approaching that of a skilled artist, and — just as 
importantly — using an arm that never gets tired.
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1.1 Credits and History:
The AxiDraw project has been active since 2014, when it was first created by Dr. 
Lindsay Robert Wilson of IJ Instruments Ltd. in the UK. 

Early AxiDraw units had a different de-
sign. It had a smaller format with a chas-
sis made from machined Delrin plastic. It 
had two independent timing belts, one 
driven by a stepper motor on the base, 
and the other by a stepper motor on the 
moving carriage. For software, it used a 
modified version of the WaterColorBot 
driver developed at Evil Mad Scientist.

AxiDraw V2
In 2015, Wilson began collaborating with 
Windell Oskay and Lenore Edman of Evil 
Mad Scientist Laboratories towards a new 
AxiDraw model that would be principally 
designed and manufactured in the USA. 

This second-generation AxiDraw was en-
larged to reach twice the travel area, to 
cover a full page of A4 or US Letter paper. 
Its geometry was changed to use a single 
drive belt, with two larger stepper motors 

stationary on the base. Its major components would now be made of aluminum 
(machined or stamped and folded), and the new pen holder could be mounted 
vertically or at 45° to the paper. 

AxiDraw V3
The third generation, AxiDraw V3, is a full 
redesign of the machine for higher perfor-
mance. While previous models had steel 
shafts and linear ball bearing slides, this new 
version features custom aluminum extrusions 
with rolling wheels. The vastly increased stiff-
ness of the structures allow the machine to 
operate at roughly twice the speed of the previous version, without a loss in quality.

The AxiDraw V3 family is currently available in several models that differ principal-
ly in available travel area: AxiDraw V3, AxiDraw V3 XLX, and the AxiDraw V3/A3. 
There is also a Special Edition, AxiDraw SE/A3, which features a base machined 
from a solid block of aluminum.

AxiDraw, 2014

AxiDraw V2, 2016

AxiDraw V3
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2. Checking out your AxiDraw

Here are the parts that come with AxiDraw:
 
1. The AxiDraw itself 
2. Clip Easel and binder clips (4 on AxiDraw V3, 8 on larger models)
3. Plug-in power supply 
4. USB cable
5. Hex drivers and wrenches

Sizes include 2 mm, 2.5 mm, and 3 mm hex drivers, and low-profile 8 mm 
and 10 mm wrenches. Of these, only the smallest (2 mm) hex driver is 
used in normal operation. 

6. Not shown: Extra rubber feet (AxiDraw V3 and V3 XLX only)
Normally not needed. But, just in case a rubber foot gets bumped off of 
the base during shipping, these are spares.

7. Not shown: Rubber bands 
These can be used to add a little extra pen force if needed.
See the last chapter, AxiDraw Tips and Tricks.

8. Not shown: Special accessories included only with AxiDraw SE/A3
The SE/A3 also includes an XL pen clip and an italic pen adapter.
These are available separately for use with other AxiDraw models.

To learn more about available AxiDraw accessories, please visit: emsl.us/902 

3. Power
supply

4. USB Cable

2. Clip Easel
(Binder clips)

1. AxiDraw

5. Hex drivers and wrenches

2.1 Parts and accessories
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Let us look at the different parts of the AxiDraw. We will refer to these parts 
by name throughout this guide. These features are common to each model of 
AxiDraw, though appearences may vary slightly. For example, the AxiDraw V3/
A3 and SE/A3 have extended “outrigger” feet, and the AxiDraw SE/A3 base is 
colored black and covers the two motors.

Pen holder

Central strut

Base; central strut

Left motor & cover

Right motor
& cover

Cable Guides
(not handles!)

Carriage (X-axis part)

2.2 AxiDraw Anatomy

Pen holder

Top ViewCarriage (Y-axis part)

Timing (drive) belt
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§2.2, AxiDraw anatomy, continued:

Top View

Detail: Left side of base 

Rubber
Feet

Power Jack

EBB
Cover

Stepper motor
Pause Button

“EBB” Control board

USB Port

Home Position Indicator

Detail: Pen holder

Pen-lift 
servo motor

Vertical slide

Thumbscrew

Pen Clip

Pen Clip
Screws

Vertical shafts

Note: AxiDraw ships with its pen clip disconnected; see the next section.  

Y Carriage
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The pen-lift motor cable and the pen clip are disconnected for shipping.

Locate the disconnected cable end
on the left hand side of the base.
 
 

The cable has three wires: Black, red, and white. 

Plug its connector into the bottom three pins on 
the EBB Control Board as shown. The black wire 
faces back, towards the edge of the board.

2.3 Unboxing
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The pen clip is also
disconnected for shipping.

2 mm ball-end
hex wrench

Thumbscrew

Vertical slide
(Appearance may vary; see next page.)

Thread the black plastic thumbscrew into the pen clip.

Attach the pen clip to the vertical slide with the two small black M3 screws, using 
the 2 mm hex wrench, which has a ball end for easier access. The pen clip may be 
attached either in a vertical or diagonal orientation, depending on what kind of a 
writing implement you are using. (Continues on next page.)

Pen clip

M3 Screws
for pen clip

§2.3, Unboxing, continued:
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Your vertical slide may have either two or four threaded holes for the pen clip. 
Both styles have the same function, but they do look a little bit different. In either 
case, use exactly two screws to attach the pen clip in place.

Current production two-hole slide with the pen clip mounted in the diagonal 
(left) and vertical (right) configurations. 

Older AxiDraw units may have a four-hole slide, with only two holes in the pen 
clip. Here it is shown with the pen clip mounted in the diagonal (left) and ver-
tical (right) configurations. 
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2.4 Safe handling of the AxiDraw

1). Lifting: Lift AxiDraw by the central strut of the base, or by the stepper 
motors if necessary. Do not lift by the cables, cable guides, carriages, or pen 
holder. The AxiDraw SE/A3 has a handle milled into the back of the central 
strut, to provide an additional lifting point in the middle of the machine.

2). Heat: Please note that the two stepper motors may get warm. This is nor-
mal, but it is helpful to be aware of it. They should not get too hot to touch.

3). Moving parts: AxiDraw has exposed moving parts. Keep fingers, hair, and 
other things that could get caught, crushed, or tangled safely away from the 
belt and the pinch points between the moving carriage, the pen holder, and 
the motor covers.

! Warning: Keep fingers away from pinch
points while AxiDraw is operating.
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3: Overview: Getting Started with AxiDraw

In brief, here are the steps to getting started with the AxiDraw:

1) Install the software.
2) Open or create the artwork that you would like to plot.
3) By hand, move the carriage to the upper-left Home Corner.
4) Connect power and USB cables.
5) Check pen-up and pen-down heights.
6) Set up your pen and paper. 
7) Begin plotting from within the AxiDraw software.

Part 4 of this guide goes through the first item on the list: Installing the soft-
ware.  Parts 5 through 8 go through setting up your AxiDraw for use. Part 9 walks 
through making your first plot, and various options available while plotting. Part 
10 talks about designing for AxiDraw. It is followed by sections on various tips 
and tricks for using your machine. 
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4: Software for AxiDraw

4.1 Installing software
You will need to install software on your computer to operate the AxiDraw. 
Current instructions and download links are available at:  http://axidraw.com/sw

From there, follow the directions specific for your operating system:
• For Mac and Windows, there are easy installers that you can download.
• For Linux, one or more manual steps are required.

The software that you will install includes Inkscape, the superb (and free) drawing 
program, and a set of extensions that operate the AxiDraw from within Inkscape. 

4.2 Inkscape and the extensions
Once you have installed the software, launch Inkscape. The AxiDraw software will 
appear in the menu at Extensions > AxiDraw.  All machine control is performed 
from within the AxiDraw Control panel. A second extension, Hatch Fill, is provid-
ed as well, to help with filling in shapes.

4.3 Aside: Alternative software and APIs
RoboPaint is an alternative driver software available for painting and drawing 
robots. It requires a separate install process, but does support AxiDraw.

Programming is not required to operate the AxiDraw. In the case that you 
would like to program it or remotely send data to it, we do have interfaces and 
documentation available. All of our software is open source.

For more information about RoboPaint or our APIs, please see the documen-
tation on our wiki site at http://axidraw.com/docs

Beyond these options, a stand-alone command line version of our (otherwise) 
Inkscape-based software is in development, and available in beta to AxiDraw 
users. If you would like early access, please contact us directly: 
	 https://shop.evilmadscientist.com/contact

http://axidraw.com/sw
http://axidraw.com/docs
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5: The Home Corner

Before you start plotting, the pen holder must be moved to the Home Corner. 
This is as far left and as far back as it will go: where the pen holder is closest to the 
left side of the base, that is when the pen holder is closes to the engraved label 
“Home”, and the USB port.

Home Position
Indicator

Home
Corner

When a plot finishes, the AxiDraw will return to its Home Corner automatically, 
leaving it ready for the next plot.

Slide the carriage to the Home Corner by 
hand. You can move it diagonally by holding 
the solid block of metal behind the verti-
cal side of the pen holder. Do not push the 
vertical side of the pen holder directly.

The carriage should only be moved when 
the power to the motors is off. If it does 
not move easily, turn off the motors so that 
you are not trying to force them. 
 
To do so, use the “Raise pen, turn off motors” command in the Setup tab of Axi-
Draw Control (see page 22). If necessary, you can also physically disconnect 
the AxiDraw from power. 
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6: Workholding
 
Whatever workpiece the AxiDraw is to write or draw upon – whether that is pa-
per, wood, or cookies – needs to be reasonably fixed in place so that it does not 
move while plotting. 

6.1 Printing on large workpieces 
For large workpieces such as the 
large poster board shown here, the 
AxiDraw may be placed directly on 
top of the workpiece.  Other ex-
amples of large workpieces that 
AxiDraw can sit upon might include 
things like fabric, wooden surfaces, 
or large whiteboards.

With some awkwardly shaped workpieces (framed art, irregular objects, etc.), you 
may need to prop up the base of AxiDraw to make it tall enough to reach.

6.2 Workholding with the Clip Easel
A simple board with clips, the Clip Easel, is included with the AxiDraw for holding 
smaller workpieces – principally different shapes and sizes of paper – that are not 
large enough to be held down by the AxiDraw itself. This is a great way to mount 
paper when getting started with the AxiDraw.

The AxiDraw V3 Clip Easel is 9 × 12 inches (about 23 x 30 cm) in size, with rubber 
feet and four small binder clips. (Larger easels are included with the larger-sized 
AxiDraw models.) You can mount different sizes of to it, including US letter size 
(or A4) paper, and smaller sizes including envelopes, cards, and invitations. With 
smaller paper, you can also potentially mount several pieces at the same time. 
The clips can be positioned as needed to hold the paper flat, and avoid the areas 
where you will be writing. 
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A

C

B

D

The examples shown above are:
A) A certificate to be filled out (Letter size, landscape orientation)
B) Mailing address (#10 envelope, landscape orientation)
C) A formal invitation (6 ⅜ × 8 ⅞ inch, portrait orientation)
D) A page of mixed text and drawing (Letter size, portrait orientation)

In every case, line up the corner of the paper with the upper left corner of the 
Clip Easel, such that the corner of the paper is closest to the Home Corner.

If your document is wider than it is tall (or square), it is said to be in landscape 
orientation, and your paper should be oriented as in examples A and B above. If 
is taller than it is wide, it has portrait orientation; turn your paper “sideways” as 
in examples C) and D) above. (This default behavior can be overridden. See “9.7 
Advanced options” on page 37.)

6.3 Using multiple Clip Easels
A common technique is to use more than one clip easel, such that you can quick-
ly swap out your completed workpiece for the next one. The key advantage is that 
one page can be plotting while you unclip and clip the next page. You can use 
tape marks or hard end stops on your table (like a carpenter’s square) to facilitate 
quick alignment.

§6.2, Workholding with the Clip Easel, continued
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7: Connecting Power and USB

In the next section, when setting the pen heights, it is necessary to plug in the 
AxiDraw. When it is time to do so, connect the power and USB cables to the 
AxiDraw as shown above. Connect the USB cable to any available USB port on 
your computer.

The plug-in power adapter included with the AxiDraw (9 V dc, regulated, center 
positive) works with worldwide mains power (100-240 V ac). Outside of the US, 
it may require an inexpensive plug-shape adapter.

Once your cables are connected, make sure that the AxiDraw has room to move. 
As the carriage moves (left to right, back and forward), it is important that it can-
not get caught on stray cables.

USB Cable

Power Adapter Cable

A second method can be used when your workpieces are substantially smaller 
than the working area of your machine. For example, if you are labeling small 
note cards with the AxiDraw, or if you are plotting two side-by-side letter (A4) 
size pages with the AxiDraw V3/A3 or AxiDraw V3 XLX. Using two small easels 
side by side, you can designate one “A” and one “B”, and alternate plotting on the 
“A” or “B” side. If you change out each side when it finishes, you can plot contin-
uously without ever pausing to swap out the paper.

6.4 Moving beyond the Clip Easel
While the Clip Easel is versatile, its use is entirely optional. Paper can be also held 
in place with tape, clamps, tacks, paper clips, magnets, other types of clipboards,  
the weight of the AxiDraw itself, or by other means that you see fit.

If your AxiDraw is used as a single-purpose machine (that is, if you use the same 
pen and paper size consistently), you may prefer to make a workholding solution 
tailored for your specific application. In some cases, making a fixture that is per-
manently mounted to a tabletop or work surface can save you a great amount 
of time.
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8: Pens and Getting Ready for Printing 

In this section we will discuss different types of pens, configuring the pen angle, 
the pen-up and pen-down positions, setting the pen height, and how to set the 
paper position relative to the pen.

8.1 Pen choices
The pen holder on the AxiDraw fits pens up to ⅝ inch (16 mm) in diameter. The 
maximum recommended pen weight is 1.6 oz (45 g). The design is such that the 
pen rests on the surface by its own weight. That allows it to ride over surfaces 
that are textured or otherwise uneven, however it also means that the pen holder 
does not apply much if any downward pressure. 

Good choices for pens include fountain pens, permanent markers, rollerball pens, 
technical pens, (small-bodied) whiteboard markers, liquid chalk markers, and oth-
er writing and drawing instruments that do not require significant pressure. While 
we refer to writing and drawing instruments as “pens” to be concise, other instru-
ments such as automatic pencils, chalk, charcoal, and brushes can also work well 
in many cases. Others, like traditional ball point pens, may work poorly because 
they require a substantial amount of downward pressure to operate.

8.2 Setting the pen angle
The pen may be mounted vertically or diagonally at 45° to the paper by mounting 
the Pen Clip in either the vertical or angled position.

To detach the pen clip, loosen and remove the two black M3 screws on the front 
of the pen clip, using the 2 mm hex wrench, which has a ball end for easy access.  
Use the same two screws to reattach the pen clip, either in the vertical or diago-
nal orientation. (See pictures starting on page 11.)

The 45° angle position is optimal for use with fountain pens, but will work well 
with most rollerball and fine point markers. The vertical position is more suited 
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to markers with fatter tips or writing instruments that require more downward 
pressure. The vertical orientation is usually the best choice when making plots 
where you will need to switch between pens (for example with different colors) 
while maintaining the pen in the same location.

8.3 Inserting a pen
You can insert a pen – or other writing instrument that you are using – into the 
pen clip and tighten it in place with the thumbscrew. 

Take care to only apply gentle force with the thumbscrew: You need merely to 
immobilize the pen, so stop turning once you encounter moderate resistance.

When using any ink-based pen (whether rollerball, fountain pen, or permanent 
maker), it is helpful to “bleed” out the tip before writing.  Try it by hand on a piece 
of scratch paper, and make sure that ink is actually flowing. 

Note on fragile or delicate pens: If you choose to use fragile pens (such as high-
end fountain pens with celluloid barrels), exercise great care when inserting the 
pen. You may wish to wrap the barrel in a thin, soft cloth to avoid scratching, and 
use little or no pressure from the thumbscrew. Moderately priced fountain pens, 
like the Lamy Safari shown above, tend to be quite tough, and require little special 
treatment.
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8.4 Pen up and pen down positions
In this step we will check the pen-up and pen-down positions. 

First, connect power and USB to the AxiDraw. (See “7: Connecting Power and 
USB” on page 19). Then, within Inkscape, open up AxiDraw Control. If the 
AxiDraw software is installed, you can find it in the menu bar at:
	 Extensions > AxiDraw > AxiDraw Control

Click on the Setup tab:

Select the Toggle pen between UP, DOWN action, and click the Apply button. If 
your software is all installed correctly and everything is hooked up correctly, the 
pen lift motor will alternately move to the up or down positions each time that 
you press Apply. (If it does not move, check that you have correctly hooked up 
the pen-lift motor cable. See section “2.3 Unboxing” on page 10.)

Pen upPen down
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§8.4, Pen up and pen down positions, continued

The pen-up and pen-down heights may each be adjusted between 0 and 100% to 
suit your needs. Higher percentage values lift the pen higher.

The factory-default values of 60% (up) and 30% (down) are a good starting point. 
Try also adjusting them to a different set of values (say, 70% and 30%, respective-
ly) and apply, to see that the positions change when you adjust them.  The pen 
holder should visibly move up and down as you raise and lower the pen holder.

Pen up gap: 
1/8 - 1/4 inch

(3-6 mm)
above paper

While in the pen-up position, insert your pen and position it above your paper. 

The vertical position of your pen should be approximately 1/8 to 1/4 inch (3 - 6 
mm) above the surface of the paper. You can physically adjust the position of the 
pen with the thumbscrew, and/or change the positions from the Setup tab of 
AxiDraw Control.

Toggle also to the pen-down position. With the pen down, the pen should rest 
on the paper by its weight. If it does not, you may need to lower the pen-down 
position. (While testing, you can protect the paper that you will be writing upon 
with another sheet of paper, to avoid writing on your actual workpiece.)

Finally, return the pen holder back up, to position your paper for printing.

Once you are familiar with the process of inserting the pen and setting the 
height, this process reduces to two steps:

1) Raise the pen holder to the pen-up position (if it is not already there).
2) Insert your pen into place.
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Plotting on large surfaces (where the AxiDraw sits directly on the surface): 
Position the AxiDraw such that the pen tip is at the upper left corner of the area 
that you intend to plot upon.  The software will treat the corner of the page in 
your Inkscape document as Home Corner for the purpose of plotting.

Here is how the “page” printed above looks from within Inkscape:

8.5 Positioning your paper
With your pen at the Home Corner, and the pen at an appropriate height, it is 
time to position the paper with respect to the AxiDraw.  The printable area starts 
at the Home Corner, and extends down and to the right from that point.
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Plotting on everything else ( letters, envelopes, invitations, and smaller items):  
Position the paper with its upper-left corner directly underneath the tip of the 
pen.  Square the paper up so that its top edge is parallel to the X-Shafts of the 
AxiDraw.

As we discussed earlier (page 18), documents that are taller than wide are usually 
turned “sideways”, as in B above. Whether vertical or horizontal, it is always the cor-
ner of the paper closest to the Home Corner that one aligns below the tip of the pen.   
 
For comparison, here are how those two documents look on the computer when 
setting up to print:

 
The absolute position of your paper with respect to the AxiDraw will vary, de-
pending on the paper, the pen that you use, as well as the pen length if it is 
mounted at 45°. For any given pen and paper setup, it is likely to remain relatively 
consistent. (See “6.4 Moving beyond the Clip Easel” on page 19.)

§8.5, Positioning your paper, continued

A

A B

B
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9: Plotting with the AxiDraw

9.1 Making your first plot
In this section we will walk through the steps to make your first plot on the Axi-
Draw. Finish installing the AxiDraw software (§4) before beginning here. In addi-
tion to what comes with the AxiDraw, you will need pen and paper.

Download the set of AxiDraw example files from http://axidraw.com/ex   

The download is a small zip archive of example files. Open (unzip) the archive, and 
from within Inkscape open up the file called AxiDraw_First.svg. Once open, the 
document should look approximately like this:

If you cannot see the full page outline when you first open the file, select from 
the menu View > Zoom > Page, or type the number ‘5’ on your keyboard.

8.6 Summary

Your AxiDraw is now ready for use. To recap, the steps so far are:

1)  Move the pen holder to the Home Corner (if it is not already there).
2) Connect Power and USB cables.
3) Use the setup tab to move the pen holder to the “pen-up” position.
4) Insert your pen, just above the paper.
5) Position your paper with its corner beneath the tip of the pen. 

http://axidraw.com/ex
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If you have not done so already, get the AxiDraw set up to print:
1)  Slide the pen holder to the Home Corner.  (See §5)

2) Plug in the power cable and connect the USB. (§7)

3) Using the software, toggle the pen down and back up.  (§8.4)
	 • From the menu, select Extensions > AxiDraw > AxiDraw Control
	 • In the Setup tab, use the Toggle pen between UP, DOWN option. 

4) Clip a piece of paper to the Clip Easel. (§6.2)
	 • Align the paper to the upper left of the Clip Easel, closest to Home.

5) Clip in your pen, with height just above the paper. (§8.4)

6) Position the paper with its upper-left corner beneath the pen tip. (§8.5)
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§9.1, Making your first plot, continued

You are now set up to print.  Last thing: Check the area around the AxiDraw, and 
make sure that the carriage has room to move, both in front of and behind the 
base.

Finally, switch to the Plot (first) tab of AxiDraw Control, and click Apply to begin.

The AxiDraw should now begin printing your document, and will return back to 
the Home Corner, with pen up, when it finishes.
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9.2 Plotting multiple copies

The Copies to Plot option on the Plot tab allows you to plot the same document 
multiple times, with an optional delay between copies.  

Setting the number of copies:
Enter the number of copies that you would like to plot in the Copies to Plot box. 
The default value (1 copy) will only plot the page once. 

Setting the delay between pages:
The value of Seconds of delay between copies in the Timing tab of AxiDraw Con-
trol sets how long the AxiDraw will pause between pages when plotting multiple 
copies. This delay is intended to allow time for you to swap out the paper be-
tween copies. The default value is 15 seconds, but it can be set anywhere from 0 
(no added delay) to 3600 seconds (1 hour).

Plotting continuously:
If Copies to Plot is set to 0 (zero), then the AxiDraw will plot continuously (with 
the same delay between pages) until you press the physical pause button on 
the left side of the AxiDraw. (See section “9.3 Pausing, resuming, and canceling 
plots” on page 30 for more about pausing.)  

For ease of use, it is recommended to press the button during the delay between 
plots, while the AxiDraw is resting at the home position. 
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9.3 Pausing, resuming, and canceling plots
To pause or stop while plotting, press the pause button: the raised silver-colored 
button located on the left hand side of the AxiDraw. (See “Detail: Left side of 
base” on page 9.) The AxiDraw will stop plotting and raise the pen after fin-
ishing the current line segment. 

Note: You must physically press the pause button to stop a plot in progress. (Ink-
scape has a “Cancel” button, but it does not actually stop running extensions.)

Once paused, you can make adjustments in the settings (for example, to the pen 
height or plotting speed), before resuming, if you choose to do so.

To resume a plot after pausing, open the Resume tab of AxiDraw Control, select 
the Resume action and click Apply.  To instead return the carriage to the Home 
Corner, select the Return to Home Corner option and Apply. The plot can still 
be resumed after moving back to Home (if, and only if, moved by this command).

If you instead want start a new plot (from the Plot or Layers tab), you must re-
turn the carriage to Home before beginning, just like any other time that you are 
starting a plot. Failure to do so will cause a loss in position control.

You can also move the carriage Home by hand. To do so, use Raise pen, turn 
off motors in the Setup tab (See “8.4 Pen up and pen down positions” on page 
22) to unlock the motors so that the carriage can be moved. You will need 
to return Home manually in any event where there is a loss of position control.
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9.4 Plotting with multiple layers and colors
By default, the AxiDraw will plot all visible paths on your drawing. However, if 
you have a document with multiple layers, you can use AxiDraw Control to plot a 
single layer, or some set of layers. 

Open the Layers window in Inkscape (shown at right) 
by selecting from the menu: Layer > Layers...

You can add, remove, re-order and rename layers with-
in the Layers window, and the various commands in 
the Layers menu can also move objects between lay-
ers. The little “eye” buttons, to the far left of the layer 
names, can be used to hide and show individual layers.  
 
Hidden layers are not plotted, and this is one of the 
simplest ways to plot only certain parts of your doc-
ument.

A second method of using layers is with the Layers tab of AxiDraw Control: 

When you click Apply with the Layers tab open, the AxiDraw will plot only the 
layer or layers that have a name beginning with the number entered there (under 
Plot only layers beginning with). The only requirement for using this feature is 
that you begin each layer name with an integer in the range 0 through 1000.  

After plotting from the Layers tab, you can stop to change any settings that you 
wish to, or switch to a different pen. This makes it possible to plot drawings with 
portions drawn with different colors and (for example) different speeds.
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For example, if you have three layers with the names,
1 - Red circles
1 - Red squares
2 - Blue stars

Then you could plot the two red layers with a red pen by specifying “1” in the Plot 
only layers beginning with field. You can then change the pen to blue and plot 
the blue layer by specifying “2” in that field. Click the Apply button each time to 
begin plotting of the selected layers.

The set of layers shown in the Layers panel on the previous page corresponds to 
the example shown below:  A birthday party invitation with six colors and six lay-
ers. You can see how it appears in Inkscape, as well as printed on the page using 
six ultra-fine point Sharpie markers.

§9.4, Plotting with multiple layers and colors, continued
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Plotting multiple copies from the layers tab
The Copies to Plot option in the Layers tab allows you to plot the same layer or 
set of layers multiple times, in the same fashion as plotting multiple copies from 
the Plot tab. (See “9.2 Plotting multiple copies” on page 29). 

The delay time between subsequent pages is set by the Seconds of delay be-
tween copies parameter in the Timing tab of AxiDraw Control. (This is the same 
parameter that controls the delay between pages when using the Plot tab.) And, 
you can plot continuously (until paused) by selecting “0” (zero) for the number 
of Copies to Plot.

Additional Layer Control features
Beyond control with the Layers tab, there are additional commands and parame-
ters that can be specified through the layer name. 

You can use properly formatted codes to specify the pen-down height and the 
speed for printing specific layers. There are also special codes that can introduce 
a timed delay while plotting or force a programmatic pause (as though you had 
pressed the pause button to halt a plot). These types of codes are rarely used  in 
everyday plotting, but can be useful in developing specialized applications

One additional, and particularly useful, feature is that any layer with a name start-
ing with a percentage sign “%” is said to be a documentation layer, and will not 
be plotted.

The Layer Control features are always active, and can be used (for example) 
whether you are plotting from the Plot or Layers tab of AxiDraw Control.

The complete syntax for AxiDraw Layer Control can found at:
	 https://wiki.evilmadscientist.com/ALC

https://wiki.evilmadscientist.com/ALC
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9.5 The Timing tab and basic speed control
The Timing tab of AxiDraw control lets you set the basic movement speeds for 
the AxiDraw. The three parameters at the top under the Movement speeds head-
ing set the speeds used for the horizontal (XY) carriage motion.

The first item in the list, Writing/Drawing speed, sets the maximum speed that 
will be used when the pen is down. The second, Pen-up movement speed, sets 
the maximum speed that will be used when the pen is up, traveling between two 
points. 

The default value for these two speeds are 25% and 75%, respectively.  You can 
adjust these speeds. Keep in mind that the quality of printing that you can achieve 
is always a trade-off between speed and neatness.

The Acceleration parameter controls how quickly the pen will approach these 
maximum  speeds, and is typically more important in practice than the speed 
limits. 
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Everyday use:
Most of our sample drawings and tests are made with a medium speed that is a 
compromise between speed and precision. This is a good balance for fine-point 
permanent markers and wide-nibbed fountain pens:

Writing/Drawing speed: 30%
Pen-up movement speed: 75%
Acceleration: Standard

Working with precision:
When working with fine point pens and tuning for higher precision (with writing 
or drawing) a good starting point might be:

Writing/Drawing speed: 15%
Pen-up movement speed: 60%
Acceleration: Slow

Working at high speeds:
When using wide-tipped permanent markers or other writing implements that 
make broad marks, one might go as high as:

Writing/Drawing speed: 90%
Pen-up movement speed: 100%
Acceleration: Maximum

There are additional factors besides speed that influence precision. These factors 
include the pen lift and lowering speeds, the weight of your pen, where on the 
page you are plotting, and so forth. The “right” speed to use for any given appli-
cation is one that gives you high enough output quality at an acceptable rate.
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9.6 Pen lift speeds
The lower half of the Timing tab has a heading Pen lift and lowering speeds. 
These control the vertical motion between the heights that are set in the Setup 
tab (page 22).

The pen raising and lowering speeds can each be selected from a pop-up menu, 
with options Maximum, Standard, Slow, or Very slow. 

The AxiDraw will pause its horizontal motion while raising or lowering the pen, 
until the vertical movement is complete. These pauses are meant to prevent 
the machine from making pen-up movements until the pen is actually clear of 
the paper, and to prevent pen-down movements from beginning until the pen is 
touching the paper.  

If you are trying to increase the speed of your plots, be aware that the total verti-
cal travel distance is a very important factor in how long pen lifting and lowering 
takes. Thus, try to decrease the vertical range first, and look at the delays next. 

Slower, gentler movements are possible, and will both lead to neater writing and 
prolong the life of the pen-lift motor as well as your pen tip.

As an advanced option, you can optionally add an additional delay after raising or 
lowering the pen, to adjust the behavior of one or both of these vertical motions. 
These additional delays can be set under the Options tab of AxiDraw Control.
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9.7 Advanced options
The Options tab of AxiDraw Control has several advanced settings that do not 
normally need to be changed, but that you may wish to know about.

Auto-rotate page when printing (Default: on)
Documents taller than wide (those in portrait orientation) will normally be rotat-
ed sideways when plotted. (See page 18 for examples.) Uncheck this box to 
print documents only in the orientation with which they appear on the screen.

Use constant speed when pen is down (Default: off)
When checked, disable acceleration and move the pen only at a constant speed 
when it is down. This will give neater performance for certain types of paths, but 
creates more vibration when going around curves. It gives more uniform but less 
“natural” ink flow.

Report time elapsed (Default: off)
When checked, a dialog box will report the elapsed time and pen-travel distance 
after each plot finishes. This option is particularly useful in preview mode.

Optional delays (Default: 0): 
These delays are discussed in the previous section.

Motor resolution (Default: ~2870 DPI)
The two options are for native resolution of about 1435 or 2870 steps per inch 
(56 or 113 steps per mm). They do not change the effective resolution of your 
plot; both are finer than what can be resolved with pens. The 1435 DPI option is 
slightly faster, while the 2870 DPI option is slightly smoother, giving a neater plot.
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9.8 Preview Mode
An additional feature located in the Options tab is offline preview mode. When 
enabled, preview mode will cause the AxiDraw software to simulate plotting only. 
That is to say that everything will work normally, with the very large exception 
that the software not attempt to communicate with the AxiDraw over USB.

Preview mode can be very useful to test workflows or see how the AxiDraw will 
handle a document, even without the AxiDraw present.
 
If you simulate plotting a document with preview mode enabled (for example by 
pressing Apply with the Plot or Layers tab active) the software will parse the doc-
ument and work through the process of computing how the page will be plotted. 
Notably, if any errors are encountered, they will be reported in the usual way.

If the Report time elapsed option is enabled when you simulate plotting, then the 
software will provide an estimate of the total plotting time that will be required.

An additional option available within preview mode is Preview mode rendering. 
Preview mode rendering can be enabled from a pop-up menu, with options 
None, Pen-down movement, Pen-up movement, and All movement. If an op-
tion other than None is selected, then either the pen-down movement, pen-up 
movement or both will be simulated and drawn on your page in a documentation 
layer. (Documentation layers will not be plotted. For more about documentation 
layers, see “Additional Layer Control features” on page 33.)

If you have chosen to render a preview, then you can use the Layers panel (avail-
able in the menu at Layer > Layers...)  to hide, show, or remove the preview layers. 
Each time that you render a new preview it will overwrite the old one.

Preview mode rendering is only available when preview mode is enabled.

Certain modes and commands (other than plotting) that are primarily designed 
to communicate with the AxiDraw over USB — including those in the Setup and 
Manual tabs — are disabled while in preview mode.
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Here is how the example file AxiDraw_First.svg renders when you click Apply 
from the Plot tab with preview mode enabled and the All movement preview 
mode rendering option selected:

The pen-down movement is shown in blue, and the pen-up movement is shown 
in light red.

And, here is how those previews appear in the Layers panel:

The pen-down drawing and pen-up drawing are rendered as separate sublayers 
within the Preview layer, so that you can hide one, the other, or both. Since they 
are documentation layers, these layers will not plot on the AxiDraw, nor will their 
contents be rendered as part of future preview renders.
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9.9 Manual Controls
The Manual tab of AxiDraw Control allows you to manually execute select, ba-
sic commands and utilities. Select the operation to perform with the Command 
drop-down list, and then click the Apply button. For the two motor walking com-
mands, you can also specify the distance to move the AxiDraw carriage.

The manual commands are as follows:

Walk Carriage (X), or (Y) 
Move (“walk”) the carriage in the X or Y direction by the distance specified.  The 
distances are specified in inches (1 inch = 2.54 cm) and may be positive or neg-
ative.  The Home Corner is the X=0, Y=0 position, and positive moves in both X 
and Y are away from the home corner.

An important note is that no limit checking is performed when manually com-
manding a move from the Manual tab. Take care not to run the AxiDraw into its 
physical limits. If you are unsure, you can always disable the motors and move the 
carriage Home by hand.

Raise the Pen, Lower the Pen
These two commands move the pen to the pen-up or pen-down position.
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Enable Motors, Disable Motors
These two commands either energize the two stepper motors or turn power off 
to them. The carriage can be moved by hand only when the power to these mo-
tors is off. 

Enter EBB Bootloader Mode
Command the EBB to enter “bootloader” mode. This utility mode is sometimes 
used in reprogramming the firmware. If you should accidentally enter this mode, 
disconnect the AxiDraw from both power and USB to reset it.

Strip plotter data from file
The AxiDraw software stores certain configuration data within your document. 
While having that data there does not cause any known issues, this command can 
strip that data from the file, should that need arise.
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9.9 Model and Version

The Version tab of AxiDraw Control lists the current version number of the Axi-
Draw software on your computer. If your software version is older than the ver-
sion shown here (1.7.x), we do highly encourage you to update to the current 
version.  (See “4.1 Installing software” on page 15.)

The AxiDraw Model pop-up menu allows you to select which AxiDraw model you 
are using. If you are using one of the larger models, be sure to select that from 
the pop-up menu in order to access the full plotting area of the machine. For the 
AxiDraw SE/A3, please select “AxiDraw V3/A3” from the pop-up menu.

If you click Apply with this tab selected, it will query the EBB (the AxiDraw con-
trol board), and report its firmware version number. AxiDraw is currently shipping 
with firmware version 2.5.5.  In case of USB communication difficulties, this com-
mand may be useful to verify that the EBB is talking to your computer. 

If your EBB reports a firmware version older than 2.4.6, we do advise that you up-
date to a newer version. Please visit http://AxiDraw.com/sw and see the section 
“Firmware Update”.

http://AxiDraw.com/sw
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9.10 Plotting away from home
Occasionally, it is the case that the subject that one is writing – for example a 
name, initials, return address, or signature – is both small compared to a page of 
paper and needs to be positioned precisely.

One approach is to treat this as a normal page, and to position the text on your 
document carefully. It can help to place a separate “sacrificial” piece of paper 
over your workpiece to check if you have your artwork lined up in the right plac-
es.

A separate approach is to line up your artwork to the Home Corner in your doc-
ument, and to place the area of the document where you wish to print right 
underneath the tip of the pen.  For signing the valentine card above – where the 
entire text consists of two words – one could position the position to start writ-
ing (the upper-left corner of the word “me”) directly beneath the pen tip.

Extending this idea further, you can even “plot away from home” by starting out 
not at the Home Corner, but from some midway point (a “virtual” home corner) 
where the pen can reach to other parts of the document.  For example, one 
could manually walk the carriage to X=3 inches, and you could use that as the 
starting point for your plot. After each plot, the carriage would return home to 
that position.  Use great care when using this method that your drawing does not 
exceed the now more limited range available from that position.
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10: Designing for AxiDraw

10.1 General considerations
The AxiDraw is a pen potter, which is fundamentally a single function device. Its 
sole function is to guide a pen (or other implement mounted in the pen holder) 
along the set of vector lines, curves, and paths that you ask it to follow. All oth-
er things that the machine is ultimately capable of – such as drawing graphics, 
writing text, or signing documents – are expressions of this basic function. It is 
capable of drawing essentially anything that can be composed from a set of lines. 

Certain object types are automatically treated as paths, for example circles and 
rectangles. Other types of objects that are made of curves – like text – may need 
to be converted from (editable) text into simple paths before plotting. You can 
convert a selected object to a path by using the menu option Path > Object to 
Path.

When designing in Inkscape, it is recommended to create new documents by 
using an A4 or US Letter sized template. You can create a file from a template 
by selecting File > Templates, and then selecting A4, A4 Landscape, Letter, or 
Letter Landscape.

Objects that are not paths
The AxiDraw does not directly plot objects that are not made of paths. This in-
cludes pictures (raster or bitmap images, such as .jpg, .gif, .png files), and effects 
such as fills, gradients, and background colors. These kinds of things require con-
version to paths before plotting. That is straightforward in some cases, and not in 
others. One notable example is that you can create solid fills by using the Hatch 
Fill extension included with the AxiDraw software.

Importing graphics
The native file format of the AxiDraw is SVG (“scalable vector graphics” – a stan-
dard interchange format). You can create artwork directly in Inkscape. Many 
other graphics programs including Adobe Illustrator and CorelDRAW can also 
export SVG directly. Inkscape can import artwork in formats including .eps, .dxf, 
.ai, .cdr, .pdf, and others. 

It is worth noting that the file type itself is not always a reliable indicator of wheth-
er or not the file suitable for use on the AxiDraw. For example, a PDF document 
with text from Adobe Illustrator will generally work very well, but it is also possible 
to create a PDF that contains nothing but a picture in JPG format. In the latter 
case, the image still isn’t vector graphics, even though it’s tucked into a PDF file.



45

10.2 Visualizing paths in your document
To see all of the paths in your document, select all in your drawing (From the 
menu: Edit > Select all in all layers). Then, open the Fill and Stroke panel (Object 
> Fill and stroke). 

In the Fill tab, select “No paint” (the “X”). In the Stroke paint tab, select “Flat 
Color”. And, in the Stroke style tab, select a consistent width, say 0.020 inches 
or 0.5 mm.

This procedure generally provides a good preview of how the AxiDraw will view 
your page. It is only a preview, not a precise representation of how plotting will 
work. For example, it shows the outlines around objects even if they are not yet 
converted to paths.

For a more exact preview of how your document will plot, you may wish to try 
preview mode with rendering enabled, see “9.8 Preview Mode” on page 38.
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10.3 Fonts, characters, and languages
To reiterate, the AxiDraw is a single-function device designed to trace the vector 
paths that you provide to it. The document that you prepare may include any 
number and variety of different text and graphical elements, so long as they are 
converted to paths before you plot them.

As its sole function is to follow paths, the AxiDraw itself does not use fonts (built-
in or otherwise) nor does it have knowledge about any written languages. Thus, 
it has no preference for one language over another, and is equally happy to write 
in English, Japanese, or Arabic, so long as you can provide suitable input. Similarly, 
you can use fonts in any typeface style or character set– including foreign lan-
guages and including fonts that resemble handwriting.

Most fonts (e.g., truetype, opentype fonts) that are installed on your computer 
are accessible directly from within Inkscape. You can create and edit 
text objects in Inkscape by selecting the text tool, which you can select 
by clicking the icon shown here, or by using F8 on your keyboard. You 
can select between available fonts using the Text and Font panel, acces-

sible in the menu at Text > Text and Font....

To convert your editable text into paths that can be plotted, select them and 
choose from the menu Path > Object to Path. You may wish to save a separate 
copy of your document before converting to paths, in case you wish to edit the 
text again later. 

This example was made using the font “Savoye LET” on a Mac. 
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10.4 About outline fonts
All modern computer fonts — those found in formats including truetype, post-
script, and opentype — are outline fonts. In outline fonts, each character in the 
font file describes a vector outline shape, which will be filled in by tiny pixels when 
displayed on your screen or rendered by an inkjet or laser printer. 

Things are different when you wish to use a pen plotter. As described in the pre-
vious section, you can easily convert outline font text into a set of paths for plot-
ting, and then plot it with the AxiDraw. When you do so, the machine will follow 
the actual vector shape contained in that font file, which is that outline. 

Below is a sample of text written in a common handwriting-like font:

The upper part of the sample shows the text filled in, as it will typically appear on 
your screen, or when printed on a laser printer. The lower part shows the outline: 
The actual vector shapes contained within the font file, and how the output will look 
when printed with a pen plotter.

Now, if you had picked that handwriting-like font with the intent of creating hand-
writing-like output on the AxiDraw, this is probably not what you had intended.

The cause of this perhaps unexpected behavior is that one could easily (though 
mistakenly) assume that a handwriting-like font contains handwriting like strokes. 
The letters “t” and “x” both look like they could be made up of two strokes that 
overlap, and the “O” looks like it could be a single loop. However, in order for 
outline fonts to render correctly on your screen, the “t” and “x” are instead com-
posed of a single complex shape, while the “O” consists of two concentric loops. 

To be quite explicit: there is no absolutely data contained within an outline font 
that represents or corresponds to the visually apparent centerline of the char-
acters. This fact is consistent for all standard computer fonts, and will present no 
unexpected behavior, so long as you are aware of it. 

Outline Font Example



48

§10.4, About outline fonts, continued

Suggestions for handwriting-like output:
When trying to achieve output close to that of natural handwriting, an “outlined” 
effect is generally not desirable. To mitigate it, pick handwriting-like fonts that 
have a thin and consistent stroke width. If a font is available in multiple weights, 
you’ll want to pick the lightest one available. This, combined with the use of a 
medium or broad nib pen can often make it so that the two sides of the outline 
blend together. 

Using a broad-point pen, particularly a broad-nibbed fountain pen, is the one of 
the most effective ways to make a document look closer to hand written. It is also 
helpful to pick a larger font size, closer to that of natural handwriting (perhaps 18 
pt) as a starting point. Humans tend to write much larger than usual typed work 
when writing by hand.

If you would like to create a custom handwriting font based on your own hand-
writing, there are free services online (such as http://calligraphr.com) that can 
build fonts based on samples that you provide. Even so, note (1) that these are 
standard (outline) fonts, and the advice above still applies. In most cases (2), 
fonts automatically generated from your handwriting tend to be rather crude as 
compared to high-quality hand-crafted fonts.

Suggestions for block and display output:
The “opposite” case from handwriting occurs when you are working with text 
that has large block letters, display text, or other instances with characters that 
have a wide cross section. Text like this will have a very visible outline, which you’ll 
usually want to fill in with ink. 

The best way to do this is to use the Hatch Fill method, as described “10.9 Fill-
ing text and shapes” on page 52. When you apply a hatch fill, it will create a 
back-and-forth pattern for the pen to follow, to fill in the shape. While it may be 
counterintuitive to fill in text this way, it is much closer to how outline fonts are 
intended to be used: The outline is filled in with ink.  
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10.5 Stroke fonts 
In addition to regular computer fonts (outline fonts), pen plotters like the Axi-
Draw can in some cases make use of a second class of specialized fonts, called 
stroke fonts, or engraving fonts. In stroke fonts, each visible character is defined 
by strokes of non-zero width, as opposed to the area within an outline. 

While they do have some severe disadvantages, stroke fonts are ideal for use 
with pen plotters, since they plot efficiently (for example, the “o” is one loop, 
not two). They are particularly suited for handwriting-like applications, because 
the characteristics of the fonts (having a centerline) more closely mimic how 
humans write. 

The following sample of text is rendered with a stroke font, using a special appli-
cation called Hershey Text. The second line is identical to the first, except that 
we have colored the individual paths (strokes) within each character so that you 
can tell them apart:

As you can see, characters like the “t” and “x” here are composed of two inter-
secting strokes. Similarly, a letter “o” in this font consists of a single loop. This 
particular stroke font is a single-stroke font, since each visible line is made up of 
only a single path. Some other stroke fonts instead use multiple strokes to con-
struct wider characters, e.g., bold fonts.

There two severe disadvantages to stroke fonts. First, since they are not regular 
computer fonts, they generally cannot be used in the same ways as other fonts. 
You can’t, for example, install them as regular fonts on your computer nor use 
them in word processors or graphics applications. Second (and mostly because 
of that first reason) there are at present very few available stroke fonts. Despite 
these problems, stroke fonts are still worth mentioning, because in the few cases 
where you can use them, they are worth the effort.

10.6  Hershey Text
Inkscape includes a small application that we developed called Hershey Text, 
which is capable of typesetting short snippets of text in a small number of stroke-
based fonts that it includes. 



50

§10.6 Single stroke fonts & Hershey Text, continued

When you use Hershey Text, it takes editable text (that is, text that you type) and 
renders it into a set of vector paths that the pen can follow. Once you have ren-
dered text into paths, it can no longer be edited as though it were text: As ren-
dered, it is a set of paths (lines and curves) that can be edited with Inkscape’s path 
editing tools. 

You can find Hershey Text in the menu at Extensions > Render > Hershey Text.
In addition to rendering short snippets of text, you can use Hershey Text to gener-
ate a table of the single-stroke font faces that are available to use. 

Besides the fact that Hershey Text renders paths (not editable text) there are two 
important limitations on the set of included Hershey fonts:

(I): The set of fonts is limited. It cannot (at present) be expanded. 

(II): The set of characters within each font is limited, essentially to basic ASCII  
       (English) characters. It cannot at present be expanded.

Future versions of Hershey Text will use a new file format that will allow extended 
character sets and the addition of custom font faces.

Additional single-stroke font resources
Beyond Hershey Text, we are currently developing a new piece of software called 
Hershey Advanced, which can convert a full page of paragraph text into stroke 
fonts, using the same engine. It is available in beta to AxiDraw users. If you would 
like early access to this software, please contact us directly:  
	 https://shop.evilmadscientist.com/contact

Links to many other sources of single stroke fonts can be found at the IJ instru-
ments Single Line Fonts page (Short URL: http://bit.ly/1SweD6c )

http://bit.ly/1SweD6c
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10.7 Capturing signatures and handwriting

The best way to transform some handwritten text – whether a signature or a full 
page of text — into something that the AxiDraw can plot is to use direct hand-
writing capture, or what you might refer to as “real-time” capture. 

In direct capture, you use your computer to record each stroke as it is written, 
and then save the resulting set of paths as a vector artwork file. This method can 
also be used when replicating handwriting. For example when replicating histori-
cal signatures, it is necessary to trace along the strokes of existing writing and to 
capture those strokes as you trace them.

For much more about ways to capture and trace handwriting — including a link to 
jSignature, a program that can easily capture your signature in real time — please 
see our detailed documentation on the subject: 
	 http://wiki.evilmadscientist.com/capture

A link to this page can also be found on our main documentation site, 
	 http://axidraw.com/docs

10.8 Aside: Tracing of scanned handwriting

While we are frequently asked about this, it should be noted that there is not 
any straightforward way of automatically converting scanned handwriting 
into a set of high-quality vector paths that a plotter such as the AxiDraw can 
follow. Simple approaches such as centerline tracing rarely approximate the 
quality and character of real human handwriting.

This is a longstanding problem in artificial intelligence called “handwriting tra-
jectory reconstruction.” Solving it is well outside of what the AxiDraw software 
aims to support. (Again, the function of the AxiDraw is to plot the vectors that 
you supply to it.)

When software that performs handwriting trajectory reconstruction comes 
to exist some day, the AxiDraw will be here, ready to plot its output.

http://axidraw.com/docs
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10.9 Filling text and shapes
The AxiDraw software includes a second Inkscape extension, which can fill in ar-
eas with paths, such that they can be filled in with pen strokes on your page.  You 
can find it in the menu at Extensions > AxiDraw > Hatch Fill

Hatch Fill will fill any selected objects with a series of back and forth lines, with 
adjustable spacing and angle. The hatch spacing is measure in units of screen 
pixels (px), and the default value of 5.0 is appropriate for wide permanent mark-
ers. A lower spacing will produce a more uniform fill, and a higher spacing will 
produce a  more traditional hatch fill for shading.  You can use the “Live preview” 
option to see the effects of different choices without actually applying them to 
your shapes and text.

The “Connect nearby ends” option (enabled by default) connects the ends of the 
hatch lines to make long wiggling paths that plot very efficiently. An additional 
option is provided for insetting the fill from the edges. This helps to avoid “color-
ing outside the lines” when using the hatch fill.
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Here are some examples of how different settings can be used in Hatch Fill. Each 
of the following are examples are shown actual size, with a 0.016 inch (0.4 mm) 
stroke width, similar to that of a fine rollerball pen. The Tolerance parameter was 
set to 1.0.

Examples (4) and (6) above — with a single hatch at 45 degrees, inset from the 
edges, and with the ends connected — usually give good results for most situa-
tions. The key parameter that you’ll need to adjust (based on the pen that you use 
and so forth) is the Hatch Spacing.

(1) No fill

(2): Spacing 3 px, Angle 0°.
Connect nearby ends: off
Inset: off

(5) Same as (4), but 
      with crosshatch: on

(6) Same as (4) but 
       with Spacing 1.0 px
       (crosshatch is off)

(4) Spacing 3 px, Angle 45°.
Connect ends: On, Range 3.
Inset: on, distance 1.0

(3) Spacing 3 px, Angle 45°.
Connect nearby ends: off
Inset: on, distance 1.0

Objects, including 
any applied hatches

The hatch fill
alone
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10.10 Vectorizing images
The process of starting turning images (jpg, png, photoshop files, etc) into vector 
artwork is generally outside the scope of the AxiDraw software. That said, how to 
do so is a frequently asked question so we are including some notes on the subject. 
 
The process of converting a photograph into a piece of pen-ready vector line 
art can most accurately be described by the word “sketching.”  That is to say, it 
is not really a matter of file conversion, but rather one of artistic interpretation. 
There are genuinely a limitless number of ways to represent a photo with a set 
of strokes. Artists that work with plotters often write their own programs to per-
form this kind of conversion, and we will point out a few of these programs.

Inkscape includes a vectorizing tool, found in the menu at Path > Trace bitmap. 
It works by tracing the outlines of darker regions. It does work, and is some-
times useful for very simple shapes, but it generally does not produce high quality 
output that works well on plotters. You may end up with (for example) ghostly 
effects, or tens of thousands of tiny little loops that represent stray pixels on the 
input photo.

While this is nowhere near a comprehensive list, here are three examples of out-
put from different vector “sketching” programs. All three of these are free pro-
grams that are written and run in the Processing development environment.

This portrait was generated from an image with SquiggleDraw, available at:
	 https://github.com/gwygonik/SquiggleDraw

https://processing.org
https://github.com/gwygonik/SquiggleDraw
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The portrait above on the left is a stipple drawing, made with thousands of tiny 
circles of different sizes, as generated by StippleGen:
	 http://wiki.evilmadscientist.com/stipplegen

The portrait above on the right consists of a single wandering line. Plots like this 
can potentially print quickly because there is no pen up/pen down movement. 
This one was generated with an experimental program called ScribbleDraw, avail-
able upon request: https://shop.evilmadscientist.com/contact

http://wiki.evilmadscientist.com/stipplegen
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11: Maintenance and troubleshooting

The AxiDraw V3 should not require any regular maintenance under normal con-
ditions.

11.1 No lubrication required
The X carriage contains wheels that allow the X shafts and Y parts to slide. The 
wheels contain shielded and/or sealed ball bearing mechanisms that are perma-
nently filled with grease. The pen-lift (Z) stage uses grease-free Teflon-filled plain 
bearings. Do not apply oil or grease to any of the sliding mechanisms. 

11.2 Cleaning
Clean the AxiDraw only with a soft, clean cloth. The non-electronic metal parts 
may be cleaned with a cloth moistened with soap and water if needed. Avoid 
other cleaners and solvents. Do not wet the motors, cables, or controller board.

11.3 Storage
It is recommended to store the AxiDraw with the carriage either in the Home po-
sition or (especially if it needs to be put away in a  box) in the far opposite corner, 
fully extended in X and Y, such that the cable guides are fully extended and have 
the lowest profile. Unplugging the AxiDraw’s plug-in power supply when not in 
use will prolong the life of the machine.

11.4 Belt tension
The AxiDraw uses a single timing belt, looped in an “X” around the two motors 
and the Y carriage. This belt may gradually stretch a small amount, and can be 
re-tensioned where it is anchored, if necessary. The necessary hex wrench (2.5 
mm) is included with the AxiDraw. Do not retension the belt unless it is actually 
necessary to do so.

11.5 The wrenches
Several hex wrenches and two thin-profile crescent are included with the Axi-
Draw. One of these – the ball-end 5/64” (2 mm) wrench – is used for switching 
the pen between the vertical and angled orientations. The other wrenches are 
provided “just in case,” and are not needed in most circumstances. However, if 
something should come loose, it is nice to have the right tools on hand. Contact 
technical support for guidance when needed.

11.6 Wiring
If your motor wires should become disconnected at some point, here is where 
they go. Left motor: “Motor 2” locations, yellow, red, green, gray (from top to 
bottom). Right motor: Motor 1 (same order). Servo cable: B1 (lowest three pins 
on left hand side), with black wire towards the edge of the board.  Refer also to 
the illustrations in section “2.3 Unboxing” on page 10. 
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11.7 The pen-lift servo motor
The only “expendable” component of the AxiDraw is the small, blue pen-lift servo 
motor. They do wear out over time but are inexpensive and straightforward to 
replace. For heavy duty applications, you may wish to keep a spare on hand.  Con-
tact customer service if you think that you might need a replacement or a spare.

11.8 Loss of position
The most significant thing that can go wrong under normal operation is a loss 
of position control while the carriage is moving. This is typically manifested as a 
loud grinding or screeching noise. It can happen when moving at too high of a 
speed, or when the carriage hits an unexpected obstacle– for example if it was 
not moved to the Home Corner before plotting or if it was bumped while moving. 

If this should happen, press the pause button as soon as possible to cancel the 
plot.  Remove power to the machine if necessary.  Use Raise pen, turn off motors 
in the setup tab to de-energize the motors, and manually return the carriage to 
the Home Corner before trying to plot again.  As a sanity check, the carriage 
should return exactly to the Home Corner when a plot is finished. 

11.8 Service, repair, and parts support
The AxiDraw is designed to be serviceable, and we are here to help. Nothing 
should require regular replacement. However, most parts of the machine can be 
unscrewed and replaced if necessary. Please contact technical support directly if 
you need assistance with troubleshooting or repairing a mechanical issue.
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12. AxiDraw Tips and Tricks

1.	 It is often possible to get better print quality on top of a small stack of paper 
(say, 5-10 sheets) which gives a little cushion to your writing.

2.	 High quality paper – especially paper designed for use with pens – tends to 
give dramatically better results with pens than does cheap copy/laser paper. 
Bristol paper with a smooth finish is a great example of a paper designed to 
work well with pens.

3.	 The flatter that your paper is held, the better your print quality will be. Paper 
that is warped or “bubbled” will flex as the pen writes, leading to distortion. 
When the bubbles or warping are tall enough, it can also lead to stray marks 
on your page during pen-up movements. 

4.	 Reducing the amount of vertical pen travel that is needed will also improve 
print quality, since the pen-lift servo motor does introduce vibration. It will 
also make your plots faster.

5.	 If none of the motors move but (1) everything looks correct, and (2) your 
computer doesn’t report any errors, triple check that the 9 V power supply is 
plugged into a working outlet. 

6.	 When making multiple-color plots, you can get better registration when 
switching pens by making sure that each pen is set to the same height above 
the paper. A good way to do this is to rest the tip of the pen on a spacer when 
tightening the pen in place. Use a small, flat piece of wood, plastic, or metal. 

7.	 It is possible to completely detach the AxiDraw’s pen holder, and affix other 
types of tools to the front of the Y carriage. Four M4 tapped (or tappable) 
holes are provided for mounting other types of tool heads there.

8.	 Certain types of pens can “dry up” if left in the pen-up position for a minute 
or two. This can lead to an awkward situation where ink does not start flowing 
until after the machine has already been drawing for a bit. When working with 
pens like this, it may be helpful to “bleed” out the tip with a bit of scratch 
paper before printing.

9.	 Styles applied to paths (width, color, etc) are normally ignored by the Axi-
Draw software. If you have a dashed line and want it to plot with the dashes 
visible, you can use Extensions > Modify Path > Convert to Dashes to con-
vert the dashes into separate path segments.

10.	 All else being equal, you will get the best plotting results with lighter weight 
pens. Leaving the pen cap off is usually a good way to save a little weight.

11.	 One of the simplest things that you can do to improve the quality of your 
output is to use a medium or broad-nibbed fountain pen. (Lamy Safari is an 
excellent starter choice.)
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12.	 A single rubber band can be looped loosely around the pen holder as shown, 
to add a small amount of additional pressure for use with ball-point pens, or 
for operating the AxiDraw in other orientations (when gravity is not readily 
available to pull the pen to the surface). Do not add a rubber band unless it is 
actually needed; it will reduce the lifespan of the pen-lift servo motor. Exam-
ple rubber bands are included with the AxiDraw, but will degrade over time.

13.	 Inkscape has a keyboard shortcut, Alt-Q (Option-Q on Macs), which will ex-
ecute the last Inkscape extension once again. This is frequently useful when 
repeating a command, such as making one additional copy of a plot, without 
having to open the AxiDraw Control panel again.

14.	 When saving graphics in SVG format from Adobe Illustrator or CorelDRAW, a 
helpful tip is to select the “Presentation attributes” option in the SVG export 
options. This typically helps to make the formatting work better in Inkscape.

15.	 The order in which objects on your page will plot is generally determined by 
the order in which they were initially drawn. “Lower” objects on the same 
layer will print before “higher” objects on the same layer. You can use the 
Object > Raise and Object > Lower commands to re-order objects.

16.	 If you need to drive more than one AxiDraw from a given computer, a special 
version of AxiDraw Control is available. With that version, you can assign 
a “nickname” to each AxiDraw, and specify which one to use from within 
AxiDraw Control. Please contact technical support if this would be helpful 
to you.
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Extended Online documentation 
& resources for AxiDraw:

  axidraw.com/docs

www.evilmadscientist.com

shop.evilmadscientist.com

wiki.evilmadscientist.com

forum.evilmadscientist.com 

contact@evilmadscientist.com

Blog:

Store:

Docs:

Forum: 

Humans:

http://axidraw.com/docs
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