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STOP

Atlas Scientific does not make consumer electronics.

This equipment is intended for electrical engineers. If you are not familiar
with electrical engineering or embedded systems programing, this product
may not be for you.

This device was developed and tested using a Windows computer. It was not
tested on Mac, Atlas Scientific does not know if these instructions are
compatible with a Mac system.
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(dust and water splash proof)



Operating principle

The Wi-Fi Pool Kit has been designed to provide the engineer with a simple way of
remotely monitoring and controlling a pools system's chemistry. Sensor data is uploaded
to ThingSpeak ™, a free, cloud-based data acquisition and visualization platform. The
Wi-Fi Pool Kit has also been designed to be easily modified by the engineer. Feel free to
change the sensors or functionality of the device to meet your specific needs.

Overview
CPU

The Wi-Fi Pool Kit is controlled using an Adafruit Feather HUZZAH32 as its CPU. The
HUZZAH is programmed using the Arduino IDE and uses an onboard ESP32 as its
Wi-Fi transmitter. Adafruit HUZZAH32 datasheet.

3V GND

Sensor ports

The Wi-Fi Pool Kit PCB has 5 sensor ports. Three of the ports are electrically isolated.
The isolated ports are marked pH, ORP, and AUX. The isolated ports are needed to take
noise-free electrochemical readings. Because the sensing element of a temperature sensor
is never in direct contact with the water, electrical isolation is not needed for temperature
sensing.

The AUX port can be used to add an additional sensor of your choice. The terminal block
marked Port 5 has been designed to connect one or more dosing pumps to the device.
However, the port could also be used to connect a gas sensor.

°
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https://learn.adafruit.com/adafruit-huzzah32-esp32-feather

PCB

The overall design of the PCB is quite simple. The CPU is powered and programmed
through the panel-mount USB connector. The CPUs USB pin supplies the board's power
bus with 5V.

°
AtlasScientific ()

Temperature

Each of the four main sensor ports have an enable pin, which must be set correctly to
power the sensor. The enable pins are found here:

The first three pins (pH, ORP and Aux) must be set low to power on the sensor.
The last pin (Temp) must be set high to power on the sensor.

Truth table

Adafruit Huzzah32
GPIO

Sensor port 5 (the terminal block) does not have an enable pin and can not be turned off.

AtlasScientific
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Data protocol

The CPU communicates with all peripheral sensors using the 12C data protocol. All data
lines are directly connected to the CPUs I12C port. Using a different data protocol with this
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode.

When adding a new Atlas Scientific component to the kit, it must first be put into 12C
mode. Refer to the component's datasheet for instructions on how to switch it over.

Adding more of the same
sensor or component type

Adding additional components of the same type, such as an additional pH or ORP sensor,
is not hard to do. As mentioned above, you must set the device to 12C mode, and you
must make sure that its 12C address is not the same as the already existing component.

AtlasScientifico
Pool Kit

O® SCL
O @® SDA

3
<
g
8

12C Address 12C Address 12C Address 12C Address
99 (0x63) 98 (0x62) & 102 (0x66) % 99 (0x63)
| - . AtlasScientific
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This table lists the default 12C address of components commonly added to this kit.

oeice | 126 Aderss

Dosing pump

An optional dosing pump can be added to the Wi-Fi Pool Kit. Using both the Large
Embedded Dosing Pump and our sensor bridge is the simplest way to add on a dosing

pump.

I12C Address

EZO pH 99 (0x63)

EZO ORP 98 (0x62)

EZO DO 97 (0x61)

] ;Scientifico

P Wi+ — E :
A~ .,

- ———— O

Be sure to switch your pump to 12C
mode before you connect it to the
Wi-Fi Pool Kit.

You can directly connect an EZO Pump to the Wi-Fi Pool Kit without the sensor bridge
however you must remove the data cable connector and manually put the pump into 12C
mode.

6 Copyright © Atlas Scientific LLC


https://atlas-scientific.com/peristaltic/ezo-pmp-large-embedded-dosing-pump/
https://atlas-scientific.com/peristaltic/ezo-pmp-large-embedded-dosing-pump/

Uploading sensor data
to the cloud

The Atlas-Scientific Wi-Fi Pool Kit has been designed to upload sensor data to
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be
required to set up a free account with ThingSpeak ™ to upload and visualize the data.
With a free account, you can upload data once every 15 seconds. A paid account lets
you upload data once per-second; look here for more info about various ThingSpeak™
services.

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works.
If you want to use a different service, modify the device as you see fit.

Setting up your Wi-Fi kit
Step 1 «.co.rmingspe Accouns

Because the sensor data is stored / viewed on ThingSpeak, you will need
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

m ThingSpeak" Channels Apps  Support~ Commercial Use  How to Buy

To use ThingSpeak, you must sign in with your existing MathWorks account or create a new one.

Non-commercial users may use ThingSpeak for free. Free accounts offer limits on certain functionality. Commercial users are eligible for a time-limited free evaluation. To
get full access to the MATLAB analysis features on ThingSeak, log in to ThingSpeak using the email address associated with your university or organization.

To send data faster to ThingSpeak or to send more data from more devices, consider the paid license options for commercial, academic, home and student usage.

Email

4 MathWorks- % )

DATA AGGREGATION

]
‘ | 0 AND ANALYTICS
No account? Create one! -_I Q ThingSpeak
By signing in you agree to our privacy policy. ] *
0 ATLAB
= T
e . —_
. -1 ¢ > /:; .I
g | SMART CONNECTED DEVICES =
? l ALGORITHM DEVELOPMENT
SENSOR ANALYTICS

- AtlasScientific
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https://thingspeak.com/prices/thingspeak_standard
https://thingspeak.com/login

Ste p 2 Create a Channel

Your data is uploaded to ThingSpeak through a ‘Channel.” Select New Channel

|:| ThingSpeak“‘ Channels - Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S ¢ mriki Bariar Collect data in a ThingSpeak channel from a device,
e Search by tag EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
channel.

Click on the column headers of the table to sort by the
entries in that column or click on a tag to show
channels with that tag.

|:| ThingSpeak“ Channels~ | Apps~  Support~ Commercial Use ~ How to Buy

New Channel Help

Channels store all the data that a ThingSpeak application collects. Each channel includes

Name Atlas Sensors
eight fields that can hold any type of data, plus three fields for location data and one for
status data. Once you collect data in a channel, you can use ThingSpeak apps to analyze and
Description visualize it.
Channel Settings
Field 1 pH * Percentage complete: Calculated based on data entered into the various fields of a
channel. Enter the name, description, location, URL, video, and tags to complete your
channel.
Field 2 ORP (mV)
* Channel Name: Enter a unique name for the ThingSpeak channel.
Field 3 Temp (°C) » Description: Enter a description of the ThingSpeak channel.

Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable field 2 and 3)
For reference, this is what we entered.

Name Atlas Sensors
Field1 pH

Field 2 ORP (mV)
Field 3 Temp (°C)

Scroll to the bottom of the page and click Save Channel.

- AtlasScientific
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Ste p 3 Get ThingSpeak API keys

After you saved your channel settings, you will be redirected to your channel page.
Click on API keys.

|:| ThingSpeak“‘ Channels ~ Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S N Collect data in a ThingSpeak channel from a device,
S EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
Name Created Updated channel.
Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

& Atlas Sensors 2020-02-14 2020-05-1123:04

l Private ‘ Public ‘ Settings | Sharing ‘ APl Keys ‘ Data Import / Export

Learn to create channels, explore and transform
data.

Learn more about ThingSpeak Channels.

I:l ThingSpeak“ Channels ~ = Apps~  Support~ CommercialUse  How to Buy

Atlas Sensors

Channel 1D: XXXXXX
Author:
Access: Private

Private View Public View Channel Settings Sharing APl Keys Data Import / Export

Write API Key Help

AP keys enable you to write data to a channel or read data from a private channel. APl
keys are auto-generated when you create a new channel.

Key 00 0.0.0.0.6.4.0.4.9.6.44
APl Keys Settings
* Write API Key: Use this key to write data to a channel. If you feel your key has

been compromised, click Generate New Write API Key.
o Read API Keys: Use this key to allow other people to view your private channel

Be sure to save your Channel ID and Write API Key we are going to need these, in the
next few steps.

- AtlasScientific

9 Copyright © Atlas Scientific LLC «~———————Environmental Robotics



Ste p 4 Make sure your Arduino IDE libraries are up to date

A Make sure you have the correct path for the Esp32 Library

In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Preferences >

Settings  Metwork

Sketchbook location:

{C:h Browse
Editor language: System F:!E!-?u!t «w | (reguires restart of Arduinao)

Editor font size: 12

Interface scale: Automatic | 100 S % (requires restart of Arduing)

Theme: Dei'aulf ﬁeme | (requires restart of Arduino)

Show verbose output during: [ ] compilation [ ] upload

Compiler warnings: N:.;nne o

Display line numbers [] Enable Code Folding

Verify code after upload [] Use external editor

Check for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager URLs:  https:/fraw.githubusercontent. com/fespressif/arduino-esp32/ah-pages/package_esp32_index.json ﬁ

0K Cancel

Make sure this URL is in the textbox

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json
Click OK.

- AtlasScientific
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B Update the esp32 board

In the IDE, go to Tools > Board > Boards Manager

File Edit Sketch Tools Help

enum reading |
f/atep 1 tell
f/atep 2 cons
/fstep 4 tell
//atep 3 cons

enum reading_|

bool polling
bool send to_|

int return_cof
uint32_t next|
const unsigne
unsigned int

const unsigne|

const unsigne
const unsigne|

void setup()

pinMode (EN |

Auto Format

Archive Sketch

Fix Enceding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter
WiFi101 / WiFiNINA Firrnware Updater

Board:

Upload Speed: "115200"

CPU Frequency: "80 MHz"

Flash Size: "4MB (F5:2MB OTA:~1019KB)"
Debug port: "Disabled”

Debug Level: "None"

IwlP Variant: "v2 Lower Memory"

VTables: "Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

S5L Support: "All 551 ciphers (most compatible)”
Part

Get Board Info

Programmer: "AVRISP mkll”

Burn Bootloader

Ctrl+T

Ctrl+Shift+1
Ctrl+Shift+M
Ctrl+Shift+L

WICES, READ RESPONSE };

g we just received

Boards Manager...

fi
Arduino AVR Boards

Arduino Yin

Arduine Uno

Arduine Duemilanove or Diecimila
Arduine Mano

Arduine Mega or Mega 2560
Arduine Mega ADK
Arduine Leonardo

Arduine Leonarde ETH
Arduine Micro

Arduine Esplora

Arduine Mini

Arduine Ethernet

pinMode (EN_reo;

UUITUIT

@ Boards Manager X
Type | Al w | lesp32

esp32 ~

by Espressif Systems version 1.0.5 TNSTALLED

Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.

More Info

|Select version ~ | | Install Update || Remove

v
Close

In the search bar of the Boards Manager, lookup esp32.
Update to the most recent version if you don't already have it.

(Version 1.0.5 in not the most recent version)

11 Copyright © Atlas Scientific LLC
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C Download the ThingSpeak library for Arduino

Click HERE to download the latest version of the ThingSpeak library.
Don’t unzip it!

Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

File Edit Sketch Tools Help

Verify/Compile Ctrl+R

Upload Ctrl+U

Upload Using Programmer  Ctrl+Shift+U

Export compiled Binary Ctrl+Alt+5
£NUM e D COMPENSATE, REQUEST_DEVICES, BRELD RESPONSE }:
ffatep Show Sketch Folder Ctrl+K ng
St Include Library : A
:::::EZi Add File... Manage Libraries... Ctrl+5Shift+|

Add ZIP Library...

D Add the EZO 12C Library

To download the Ezo_I2¢ library file, click HERE.

¥ master ~ F 1branch D 0tags Go to file

2] Clone @

HTTPS  GitHub CLI

@ Atlas-5Scientific removed redundant examples, aquaponics kit has pump code by ¢

Examples removed redundant examples, aquapon NEED= " aa iRl COMAE TS = c e Ata T3y |
O Ezo_i2ccpp added the get_address() method to the  Use Git or checkout with SVM using the web URL.
D Ezo_i2ch added the get_address() method to the

¥ Open with GitHub Desktop

[M Ezo_i2c_util.cpp Created libraries for common functions
M Ezo_i2c_utilh Created libraries for common functions  [§) Download ZIP
[ LICENSE Initial commit 2 years ago
™ READMEmd Update README.md 18 days ago

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

- AtlasScientific
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https://www.arduinolibraries.info/libraries/thing-speak
https://github.com/Atlas-Scientific/Ezo_I2c_lib

Ste p 5 Flash the Pool kit with the correct code

A Select, open and adjust the code you want to use for your Wi-Fi Kit

File> Examples> EZO_I2C_lib-master> Examples> IOT _kits> pool_kit

@ pool_kit | Arduine 1.8.19 (Windows Store 1.8.57.0)

File Edit Sketch Tools Help
New Ctrl+MN
Open... Ctrl+0
Open Recent
Sketchbook
Examples
Close Ctrl+W
Save Ctrl+5S
Save As... Ctrl+Shift+5
Page Setup  Ctrl+Shift+P
Print Ctrl+P
Preferences  Ctrl+ Comma
Quit Ctrl+Q

11
12 WiFicClient clien
13
14 |/ /——————————————y

15 const
16 const
17 const
18 |const

15 //-—--

[

]
-

Ezo_bo
Ezo_bo
Ezo_kbo
Ezo_bo

[IST ST SR V)
[T VeI )

B
ol

Ezo_bo
PH,
ORP,
RTD,
FMEL

bi

W W B M
R = I == |

(7]
[

Ezo_bo

[
]

[
wn

//gets

const

()
m

String ssi
String pas
long myCha
char * myW.

ard PH = E
ard CORP

ard RTD
ard EFMEL =

ard device|

ard* defau

the lengt

uint8 t de

&
HTTPClient

HTTPUpdate
HTTPUpdateServer
LittleFS

MNetBIOS
Preferences

sD

SD_MMC
SimpleBLE

SPI

SPIFFS

Ticker

Update

UsSB

WebServer

WiFi
WiFiClientSecure
WiFiProv

Examples from Custom Libraries
ACROBOTIC 5501306
Adafruit BME280 Library
Adafruit BMEGS0 Library
Adafruit ESP8266
Adafruit HTU21DF Library
Adafruit LiquidCrystal
Adafruit SHT31 Library
Adafruit 5i7021 Library
atlas_gravity
EspSoftwareSerial
Ezo_l2c_lib-master
Ezo_uart_lib-master
PID
StepperDriver
ThingSpeak
INCOMPATIBLE

W

ifi pool kit that uses the Adafruit huzzah32 as its computer.

//include wifi library

//include thingspeak library

//imports a 4 function segquencer
//imports a 1 function segquencer
//brings in common print statements

C library from https://github.com/Atlas—Scientific/Fzo_I2c 1lib

Be library

//declare that this device connects to a Wi-Fi network,create a connect

N ingSpeak Credentials———---—-—

//The name of the Wi-Fi network you are connecting to
//¥our WiFi network password

//Your Thingspeak channel number

KXHHK ™ 7 //¥our ThingSpeak Write API ERey

//create a PH circuit object, who's address is 99 and name is "PH"
//create an ORP circuit cbhjsct who's address is 98 and nams is "CORE"
//create an RTD circuit ocbject who's address is 102 and name is "RTD"

//create an PMPL circuit object who's address is 109 and names is "EMPL"

pf boards used for sending commands to all or specific boards

13 Copyright © Atlas Scientific LLC

Examples 12c_lib_examples *lre talkinag to
10T _kits aquaponics_kit

Lly so we Projects hydroponics_kit add new boards

vice list) Sequencer_lib_examples hydroponics_kit_with_DO
legacy_hydroponics_kit
legacy_pool_kit
pool_kit
thingspeak_example

- AtlasScientific
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B Fill in your Wi-Fi / ThingSpeak credentials

Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the
code. (see step 3)

@ pool_kit | Arduino 1.8.13
File Edit Sketch Tools Help

poal_kit

1 #include <iot_cmd.h>

2 #include <ESPB26EWiFi.h> //include esp8266 wifi library

3 #include "ThingSpeak.h"™ //include thingspeak library

4 #include <sequencer4.h> //imports a 4 function seguencer

5 #include <sequencerl.h> //imports a 1 function sequencer

€& #include <Ezo_iZc util.h> //brings in common print statements

7 #include <Ezo_iZc.h> //include the EZO I2C library from https://github.com/Atlas-Scientific/Ezo I2¢c 1lib

g #include <Wire.h> //include arduinos iZc library

9

10 WiFiclient client; //declare that this device connects to a Wi—-Fi network,
11

12\// Fill in your Wi-Fi / ThingSpeak Credentials--—---——-—

13 const String ssid = "Wifi Name"; //The name of the Wi-Fi network you are connecting to
14 const String pass = "Wifi Password"; //Y¥our WiFi network password

15 const long myChannelNumber = 1234566; //Your Thingspeak channel number

16 const char * myWriteAPIRey = "300000000KNKHNH" 7 //¥our ThingSpeak Write API Key

177/

C Setting up your pump

If you do not have a pump attached, you can just skip this part. The code is rather
self explanatory. You set what parameters will trigger the pump to engage.

438 //parameters for setting the pump output

49 #define PUMP_BOARD PMPL //the pump that will do the output (if theres more than one)

50 #define PUMP_DOSE 10 //the dose that the pump will dispense in milliliters

51 #define EZO_BOCARD PH //the circuit that will be the target of comparison

52 #define IS GREATER_THAN true //true means the circuit's reading has to be greater than the comparison
53 #define COMPARISON VALUE 7 //the threshold above or below which the pump is activated

- AtlasScientific
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Ste p 6 Setting up the HUZZAH board

A Set the target CPU to flash

Tools> Board> ESP32 Arduino > Adafruit ESP32 Feather

@ pool_kit | Arduine 1.8.19 (Windows Store 1.8.57.0)
File Edit Sketch Tools Help

Aute Format Ctrl+T
Archive Sketch
) Fix Encoding & Reload
pool_ki Manage Libraries... Ctrl+5Shift+|
1 //This Serial Monitor Ctrl+Shift+M [1 Pool kit that usess the Adafruit huszah32 as
s Serial Plotter Ctrl+Shift+L
3 #inclu
4 |#inclu WiFi101 /S WiFiMIMA Firmware Updater //include wifi library
5 #inclu Board: "Adafruit ESP32 Feather" Boards Manager... //include thingspeak lik
;'5 ﬂ:i_nclu Upload Speed: "921600" Arduino AVR Boards ffimtjn:\rt‘s a 4 function s
8l iiiiii Flash.Frequenq: "80MHz" ESP32 Arduino FireBeetle-ESP22 j_nn_i
5 |$incia Partition Scheme: "Default” ESPBEE:E Boards Eﬂ; InteRebot Fig .y
10 | £inc1n BT | 1ibrary Onehorse ESP32 Dev Module D
11 T ’ ‘& Adafruit ESP32 Feather
12 WiFicl celE s Adafruit Metro ESP32-52 e
13 Programmer 3 Adafruit MagTag 2.9"
14 f/f———— Burn Bootloader \gSpeak Credential Adafruit FunHouse
15 const String ssid = "Wifi Name="; Adafruit Feather ESP32-52 (no PSRANFL
16 con=t String pass = "Wifi Password"; ModeMCU-325 =k
17 const long myChannelNumber = 1234566; MH ET LIVE ESP22DevKIT TLILE
8§ const char * myWriteAPIKey = "3OO0O0NNNNK"; MH ET LIVE ESP22MiniKit te
e ESP32vn loT Uno
=0 DOIT ESP32 DEVKITV1
21 Ezo board PH = Ezo board(5%, "PH"); {//fcreate a PH DOIT ESPduino3? =SS
22 Ezo board ORP = Ezo board(9%8, "ORE"); ffereate an CR OLIMEX ESP32-EVEB res
ES Ezo board RTD = Ezo board(102, "RTD"); //create an RT OLIMEX ESP32-GATEWAY res
fi Ezo board PMPL = Ezo board(10%, "EBEMEL"); /fcreate an EM R T dre
- OLIMEX ESP32-PoE-150
Z2E& Ezo board device list[] = { //fan array of boards used for o S
o PE, - OLIMEX ESP32-DevEit-LiPo
2 ORD, ThaiEasyElec's ESPino32
25 RTD, M35tack-Core-ESP32
30 DMPL M35tack-FIRE

15 Copyright © Atlas Scientific LLC
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B Adjust CPU Settings

Make sure the CPU settings on the Adafruit HUZZAH32 are correct.
To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.
Don't forget to set the correct com port for your device.)

File Edit Sketch |Tools | Help

Auto Format Ctrl+T
Archive Sketch
-~ Fix Encoding & Reload
1 |#includd Manage Libraries... Ctrl+Shift+]
2 #includs Serial Monitor Ctrl+Shift+M
@ #includs  geral Plotter Ctrl+Shift+L

4 #includg
23 neluds WiFi101 /f WiFiNINA Firmware Updater

n

oy

$¥include

: Board: "Adafruit ESP32 Feather” »

W i Upload Speed: "921600" 3
#includs plaad speect

q Flash Frequency: "80MHz" ¥

10 (WiPiclie Partition Scheme: "Default” -

11 Core Debug Level: "None" 2

12 |/ f————— Port: "COMBS" ]
13 const 5i Get Board Info

1% |const 59
= Programmer »

Burn Bootloader

&) pool_kit | Arduino 1.8.13
File Edit Sketch Tools Help

Upload

Compile and upload the code. . cre -
. AtlasScientific
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Ste p 7 See the readings

Open your Arduino serial monitor.
(You must have the serial monitor set to the com port from the Adafruit Feather HUZZAH.)

@ - o X
Send
Autoscroll [ Show timestamp Carriage return 9600 baud w Clear output

Set to carriage return and 9600 baud.

The Wi-Fi Pool Kit will always attempt to connect to ThingSpeak on bootup.

a X

(3
|

Send

RTD: 24.55 PH: 3.%4 CRP: 232.40
RTD: 24.55 PH: 3.%4 CRP: 233.10
RTD: 24.55 PH: 3.%4 CRP: 233.70
RTD: 24.55 PH: 3.9%4 CRP: 234.30
sent to thingspeak

RTD: 24.55 PH: 3.9%4 CRP: 236.40
RTD: 24.55 PH: 3.%4 CRP: 236.40
RTD: 24.55 PH: 3.%4 CRP: 237.00
RTD: 24.55 PH: 3.%4 CRP: 237.60
RTD: 24.56 PH: 3.%4 CRP: 237.90
RTD: 24.56 PH: 3.%4 OCRP: 238.20
RTD: 24.56 PH: 3.%4 CRP: 238.90
sent to thingspeak

RTD: 24.56 PH: 3.%94 CRP: 238.80
RTD: 24.56¢ PH: 3.894 ORP: 238.80

[ZE T VR 7% I VE R 7%

Autoscroll [ ] Show timestamp Carriage return | | 9600 baud w Clear output

- AtlasScientific
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If it cannot connect to your Wi-Fi you will see this:

@@ O =
Send

RTD: 24.&0 PH: 3.94 OQRP: 230.90

RTD: 24.80 PH: 3.94 QRP: 231.30

connecting to wifi

RTD: 24.60 PH: 3.94 ORP: 231.60

RTD: 24.60 PH: 3.94 CRP: 232.20

RTD: 24.60 PH: 3.94 CRP: 233.20

RTD: 24.&60 PH: 3.94 OQRP: 233.60

connecting to wifi

RTD: 24.&60 PH: 3.94 ORP: 234.00

RTD: 24.60 PH: 3.94 ORP: 234.40

RTD: 24.&0 PH: 3.94 CRP: 235.10

RTD: 24.&60 PH: 3.94 CORP: 236.10

connecting to wifi

RTD: 24.&0 PH: 3.94 ORP: 236.70

RTD: 24.&80 PH: 3.94 ORP: 237.00

Autoscroll [ ] Show timestamp Carriage return -« Clear output

Entering the poll command will stop the Wi-Fi Pool Kit from uploading the readings to

thingspeak, while you debug your Wifi problems.

18 Copyright © Atlas Scientific LLC
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Step 8 Sensor Calibration

Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

@@ — O *
Send
> help

Atlas Scientific I2C pool kit

Commands :
datalog Takes readings of all senscors every 15 sec send to thingspeak
Entering any commands stops datalog mode.
poll Takes readings continuously of all sensors
ph:cal,mid, 7 calibrate to pH 7
ph:cal, low, 4 calibrate to pH 4
phical, high, 10 calibrate to pH 10
ph:cal, clear clear calibration
orpical, 225 calibrate orp proke to 225mV
orp:cal, clear clear calibration
rtdical, t calibrate the temp proke to any temp wvalue
t= the temperature you have chosen
rtd:cal,clear clear calibration
Autoscroll [ ] Show timestamp Carriage return « | | 9600 baud v Clear output

A The poll command

Send the command poll; This will let you see the readings once per second and it will stop
uploading to ThingSpeak while you calibrate.

- AtlasScientific

19 Copyright © Atlas Scientific LLC ~————————=Environmental Robotics



B Calibrate pH

When calibrating pH, you must always calibrate to pH 7 first.
Remove the soaker bottle and rinse off the pH probe. Remove the top of the pH
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit
in the calibration solution until the readings stabilize. This will take about 1 — 2 mins.

Calibration

6.917 |

7.126 — X Unstabilized
7.223 | X

7.225

7.225 »

7.225 \/ Stabilized

7.223 ] After 20 mins, the calibration solution inside an
ph:cal,mid,7

open pouch is no longer considered accurate.

Dispose of the unused solution, after calibration.

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

<, AtlasScientific

20 Copyright © Atlas Scientific LLC ~——————Environmental Robotics



C Calibrate ORP

Remove the soaker bottle and rinse off the ORP probe. Remove the top of the ORP
225mV calibration solution pouch. Insert the ORP probe directly into the pouch, and let
the probe sit in the calibration solution until the readings stabilize (small movement from
one reading to the next is normal).

’M After
0 Calibration
$"I

{v

10 — 60 sec

342.0 ]
315.2 — X Unstabilized
268.7 |
240.1
240.1

2401 | «Stabilized
240.1 |
orp:cal,225
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D Calibrate Temperature

Calibrating the PT-1000 temperature probe is not required. However, if you want to,
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then
issue command rtd:cal,t

100 °C

Elevation in meters

305
229
152
V4

0
-76
-152

Calibration Complete
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Step 9 it ione

Once you are finished with calibration, issue the datalog command to resume taking a
reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.

~ pH
Min 4 13 |
13 on 0 ‘

i ;l;n 10:08 gy 4.150n |

4.13 0n 05 Jun 1IJ‘1705 n =

10:13 10:14

10:14

10:15

Max 273
.9 o
Jun 1019 2 Yn 10:16

L 10:T

10:7. T —
4 t0qs -~

Setup Complete!
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Correcting noisy pH readings

Some people may encounter noisy pH readings after setting up the Wi-Fi Pool Kit. This
is caused by electrical noise entering the Wi-Fi Pool Kit from your USB power supply.
When this happens, you will see stable temperature and ORP readings but the pH readings
will never stabilize enough to calibrate the probe.

1:30 1:31 1:32 1:33 1:34 1:35

Test:
If you power the Wi-Fi Pool Kit using a USB battery or a laptop running on batteries,

the pH readings will stabilize.

Solution:
Earth ground your USB power supply.
Use an earth grounded power strip that has USB power ports.

Earth Ground

d >

. AtlasScientific

24 Copyright © Atlas Scientific LLC T e ironmental Robotics



